unity launcher vanishes when switching to mirrored displays

Bug #991637 reported by Bryan C on 2012-04-30
112
This bug affects 18 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
High
Unassigned
Precise
High
Unassigned
Unity
Fix Released
High
Andrea Azzarone
5.0
Fix Released
High
Andrea Azzarone
6.0
Fix Released
High
Andrea Azzarone
unity (Ubuntu)
High
Andrea Azzarone
Precise
High
Unassigned
Quantal
High
Unassigned
Raring
High
Andrea Azzarone

Bug Description

On a fresh install of Ubuntu 12.04, Unity 5.10.0-0ubuntu6, if I switch my display settings from non-mirrored to mirrored, the launcher vanishes. Note that I have the launcher "auto-hide" setting disabled, so it should always be visible.

[Test Case]
Steps to reproduce:
* Open System Settings -> Displays.
* Make sure the launcher is only allowed to be shown on the external monitor.
* Check "Mirror displays" checkbox.
* Click "Apply".
* Unity launcher vanishes. The only way I've found to restore it is to switch back to non-mirrored mode.

[Regression Potential]
None.

Other applications are affected by the switch to mirrored mode. If a window is maximized prior to the mirroring, often it will take up a narrow vertical strip (maybe 20 pixels wide) on the right side of the screen - de-maximizing restores restores it to a window, but re-maximizing restores it to the narrow vertical strip.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.10.0-0ubuntu6
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
Date: Sun Apr 29 21:22:41 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Bryan C (bry111) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Øyvind Stegard (oyvinst) wrote :

Confirmed here. Mirroring laptop display (1920x1080) with external monitor of the exact same resolution, and the Unity Launcher disappears. Not very handy.

The Unity dash works, and draws its vertical line like there was a Launcher there on the left (although there isn't). Unity launcher is configured to be always present (no hiding).

Ubuntu 12.04 x64, Unity 5.16.0+bzr2410sruubuntu0+709 (SRU PPA), Nvidia driver 304.60.

Peter M. Clausen (pclausen) wrote :

See bug 1075390 - its not only a nvidia bug

Taiten Peng (taitenpeng) wrote :

This is not a nvidia bug for sure, I can reproduce on my own laptop with VGA external monitor.

Taiten Peng (taitenpeng) wrote :

Added to oem-priority as it's reported from our oem partner.

Changed in oem-priority:
assignee: nobody → Tammy Yang (wanchingy)
Changed in unity (Ubuntu):
assignee: nobody → Omer Akram (om26er)
Changed in oem-priority:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in oem-priority:
status: New → Incomplete
Changed in oem-priority:
status: Incomplete → Confirmed
James M. Leddy (jm-leddy) wrote :

Please fill out the oem priority request form https://hwe.canonical.com/oem-priority-request/

Changed in oem-priority:
status: Confirmed → Incomplete
Steve Magoun (smagoun) on 2013-02-07
Changed in oem-priority:
status: Incomplete → Confirmed
assignee: Tammy Yang (wanchingy) → nobody
Benjamin Xiao (ben-r-xiao) wrote :

This is also present in 12.10. I have two displays both at 1080p, running through DVI and HDMI. When I set display to mirrored mode, the launcher bar disappears.

Omer Akram (om26er) wrote :

My steps to reproduce this bug are:

1.Make sure the launcher is only allowed to be shown on the external monitor
2. mirror displays

The launcher will hide on both displays.

Changed in unity:
importance: Undecided → High
status: New → Confirmed
Changed in unity (Ubuntu Precise):
importance: Undecided → High
Changed in unity (Ubuntu Quantal):
importance: Undecided → High
status: New → Confirmed
Changed in unity (Ubuntu Raring):
assignee: Omer Akram (om26er) → nobody
Changed in unity (Ubuntu Precise):
status: New → Confirmed
Omer Akram (om26er) on 2013-02-14
Changed in unity:
milestone: none → 7.0.0
assignee: nobody → Andrea Azzarone (andyrock)
status: Confirmed → Triaged
Changed in unity (Ubuntu Raring):
status: Confirmed → Triaged
Changed in unity (Ubuntu Quantal):
status: Confirmed → Triaged
Changed in unity (Ubuntu Precise):
status: Confirmed → Triaged
Andrea Azzarone (azzar1) on 2013-02-14
Changed in unity:
status: Triaged → In Progress
Andrea Azzarone (azzar1) on 2013-02-14
Changed in unity (Ubuntu Precise):
status: Triaged → In Progress
Changed in unity (Ubuntu Raring):
status: Triaged → In Progress
Changed in unity (Ubuntu Quantal):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu Precise):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu Raring):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
status: In Progress → Fix Committed
Andrea Azzarone (azzar1) on 2013-02-14
Changed in unity (Ubuntu Quantal):
status: Triaged → In Progress
Changed in unity (Ubuntu Raring):
status: In Progress → Fix Committed
Andrea Azzarone (azzar1) on 2013-02-14
Changed in unity (Ubuntu Quantal):
status: In Progress → Fix Committed
tags: added: rls-r-incoming
Steve Magoun (smagoun) on 2013-02-15
Changed in oem-priority:
status: Confirmed → In Progress
Andrea Azzarone (azzar1) on 2013-02-18
Changed in unity (Ubuntu Precise):
status: In Progress → Fix Committed
Andrea Azzarone (azzar1) on 2013-02-18
description: updated
description: updated
Andrea Azzarone (azzar1) on 2013-02-18
Changed in unity (Ubuntu Precise):
status: Fix Committed → Confirmed
Changed in unity (Ubuntu Quantal):
status: Fix Committed → Confirmed
assignee: Andrea Azzarone (andyrock) → nobody
Changed in unity (Ubuntu Precise):
assignee: Andrea Azzarone (andyrock) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.12.0daily13.02.19.1-0ubuntu1

---------------
unity (6.12.0daily13.02.19.1-0ubuntu1) raring; urgency=low

  [ Brandon Schaefer ]
  * Multi-monitor: Mousepointer hangs when passing between monitors,
    although no Launcher is there (regression) (LP: #1120223)
  * Sticky edges should only use horizontal mouse movement (LP: #982543)

  [ Marco Trevisan (Treviño) ]
  * Launcher - Workspace switcher should not be in the Launcher by
    default (LP: #868423)
  * [regression] Unlocking a running application, removes it from the
    Launcher (LP: #1122311)
  * Launcher, Workspaces - dragging and dropping the workspaces icon on
    to the trash should switch Workspaces off (LP: #1118271)

  [ Chris Townsend ]
  * webapp: alt-tab gets "stucked" on the browser rather than going to
    the next entry (LP: #1070715)

  [ Nick Dedekind ]
  * Dash - the "Decade" and "Size" dash filter category widgets are
    broken (LP: #841899)
  * Dash Places group is shining on quick mouse over (LP: #1119487)

  [ Lukas Vacek ]
  * Show window list when right clicking an icon in launcher - enables
    quick window switching (LP: #1107866)

  [ Marco Trevisan (Treviño) <mail@3v1n0.net>, Lukas Vacek ]
  * Show window list when right clicking an icon in launcher - enables
    quick window switching (LP: #1107866)

  [ Andrea Azzarone ]
  * unity launcher vanishes when switching to mirrored displays (LP:
    #991637)
  * Opening an app with super+num shorcut doesn't give focus to the app
    (LP: #1125331)
  * Alt+` and detail switcher broken after revision 3153 (LP: #1129372)

  [ Sam Spilsbury ]
  * Unity unnecessarily clears the ShapeBounding shape of windows on
    minimize (LP: #1091600)
  * Can't access minimized window after Unity restarts (LP: #851964)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 3163
 -- Automatic PS uploader <email address hidden> Tue, 19 Feb 2013 14:26:14 +0000

Changed in unity (Ubuntu Raring):
status: Fix Committed → Fix Released
Benjamin Xiao (ben-r-xiao) wrote :

Will this fix be backported to Quantal?

James M. Leddy (jm-leddy) wrote :

or precise for that matter

Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.0.0 "R series".

Changed in unity:
status: Fix Committed → Fix Released
Shuduo Sang (sangshuduo) wrote :

Would anyone can help to accelerate OEM priority for precise? It does affect me seriously. Thanks.

Hello Bryan, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/5.20.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: added: verification-needed
Joey Zheng (jzheng) wrote :

@Shuduo, please follow Steve's comment to have a try and reply the result here.

Shuduo Sang (sangshuduo) wrote :

already verified on precise and saw this bug be fixed. pls put it into precise-updates ASAP then we can benefit from there. thanks. :)

On Mon, Jun 24, 2013 at 07:27:14AM -0000, Shuduo Sang wrote:
> already verified on precise and saw this bug be fixed. pls put it into
> precise-updates ASAP then we can benefit from there. thanks. :)

Putting this in precise-updates is blocked on all of these bug fixes
being verified:

  #892718 #926658 #942965 #991637 #1083186 #1122478

If this bug is fixed by the version in precise-proposed, it should be
tagged verification-done, per
https://wiki.ubuntu.com/QATeam/PerformingSRUVerification. However, the
other five bugs must still be verified before we can release the update.

Shuduo Sang (sangshuduo) wrote :

@Colin, thanks for your guiding. I have verified all of bugs you mentioned on OEM system although I have to use chromium to verify #1122478 instead of steam. :)
I don't know who is qualified to set the bug become verification-done if I'm not. But we OEM do want to accelerate this since this issue is blocking certification now. thanks.

James M. Leddy (jm-leddy) wrote :

Hi Shuduo,

You are totally qualified to set the verification-done tag :)

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of unity from precise-proposed was performed and bug 1195730 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and tag 1195730 "bot-stop-nagging". Thanks!

tags: added: verification-failed
Shuduo Sang (sangshuduo) on 2013-06-29
tags: added: verification-done
Shuduo Sang (sangshuduo) wrote :

Regarding bug #1195730, I use an OEM build based on precise plus unity 5.20.0 I build in my ppa [1] but I can't reproduce this issue. So I don't agree the root cause is unity 5.20.0.

[1]: https://launchpad.net/~sangshuduo/+archive/ppa

tags: removed: verification-failed
Shuduo Sang (sangshuduo) on 2013-07-03
tags: removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 5.20.0-0ubuntu2

---------------
unity (5.20.0-0ubuntu2) precise; urgency=low

  * Check to see if the window is supposed to have decorations instead
    of the window actually being decorated when Undecorate() is called.
    This fixes a regression from the previous SRU where windows opened
    maximized upon login could have extra decorations (LP: #1195730)

unity (5.20.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - ResultRendererTile: fix a crash if row.renderer<TextureContainer*>()
      is null (LP: #926658)
    - Fix unity launcher vanishes when switching to mirrored displays
      (LP: #991637)
    - Fix window decorations being drawn when they should not be.
      This fixes icaclient window "dancing" (LP: #1083186) and
      hides decoration in a test case with Steam (LP: #1122478)
    - [multimonitor] Dash - Opening dash or HUD on one screen removes panel
      shadow on the other (LP: #892718)
    - Press Alt+F1, panel’s shadow dissapear (LP: #942965)
  * Cherry-pick a manual test for decorations fix
 -- Christopher Townsend <email address hidden> Mon, 08 Jul 2013 09:37:30 -0600

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Ara Pulido (ara) wrote :

Confirmed with Tammy that this is now fixed for them in Precise

Changed in oem-priority:
status: In Progress → Fix Released
Rolf Leggewie (r0lf) wrote :

quantal has seen the end of its life and is no longer receiving any updates. Marking the quantal task for this ticket as "Won't Fix".

Changed in unity (Ubuntu Quantal):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints