Empty/Pinned icons in Unity launcher for new apps

Bug #945782 reported by peterzay on 2012-03-03
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Confirmed
Low
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

I installed Ubuntu 12.04 beta 28-feb-2012.

I then installed KMyMoney and Chromium.

Both apps left an icon in Unity launcher that was empty (question mark: ?) and permanently pinned to launcher.

A reboot gave the icons the desired image. The apps remain pinned permanently to launcher.

Permanent pinning of icons should not be the default behaviour. It should only be provided when the user manually requests it.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.4.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic-pae 3.2.6
Uname: Linux 3.2.0-17-generic-pae i686
.tmp.unity.support.test.1:

ApportVersion: 1.94-0ubuntu1
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
CurrentDmesg: [ 138.381657] init: plymouth-stop pre-start process (2325) terminated with status 1
Date: Sat Mar 3 13:48:42 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus: virtualbox, 4.1.8, 3.2.0-17-generic-pae, i686: installed
EcryptfsInUse: Yes
GraphicsCard:
 Advanced Micro Devices [AMD] nee ATI RV280 [Radeon 9200] [1002:5961] (rev 01) (prog-if 00 [VGA controller])
   Subsystem: Advanced Micro Devices [AMD] nee ATI Device [1002:2002]
   Subsystem: Advanced Micro Devices [AMD] nee ATI Device [1002:2003]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120228.1)
MachineType: HP Pavilion 061 D7222P-ABA M400Y
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-17-generic-pae root=UUID=07f7281b-ea8a-4b06-861d-7636a6ba87f3 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/14/2004
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 3.24
dmi.board.name: 'P4SD-LA'
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr3.24:bd04/14/2004:svnHPPavilion061:pnD7222P-ABAM400Y:pvr0qq1112RE101OXFOR10:rvnASUSTeKComputerINC.:rn'P4SD-LA':rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: D7222P-ABA M400Y
dmi.product.version: 0qq1112RE101OXFOR10
dmi.sys.vendor: HP Pavilion 061
version.compiz: compiz 1:0.9.7.0~bzr2995-0ubuntu5
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.1-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.1-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

peterzay (peterzay) wrote :
Omer Akram (om26er) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

Changed in unity (Ubuntu):
status: New → Incomplete
peterzay (peterzay) wrote :

I do not know if this is reproducible.

Try installing KMyMoney and Chromium on a current beta of Ubuntu 12.04 and see what happens.

If you cannot reproduce the problem, perhaps it was tuned out by newer beta code.

Changed in unity (Ubuntu):
status: Incomplete → New
peterzay (peterzay) wrote :

This problem is reproducible with the production release of Ubuntu 12.04 LTS Precise Pangolin.

Note that you must install from the Ubuntu Software Center and not Synaptic.

You will find attached a screenshot illustrating all the pertinent details.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Amir Eldor (amireldor) wrote :

Happens to me with other packages too (dropbox/pidgin/etc...).
I noticed it after trying to install several packages at the same time from the software center.

Sebastien Bacher (seb128) wrote :

seems a bit similar to bug #978392

Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity:
importance: Undecided → Low
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers