"Left Mouse Drag" and "Middle Mouse Drag" should be translatable

Bug #930510 reported by Koichi Akabe on 2012-02-11
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Medium
Gabor Kelemen
Unity
Fix Released
Medium
Gabor Kelemen
unity (Ubuntu)
Undecided
Unassigned

Bug Description

"Left Mouse Drag" and "Middle Mouse Drag" on Keyboard Shortcuts window are not translatable.

Step to reproduce:
1. Press Super key and show "Keyboard Shortcuts" window
2. See "Alt + Left Mouse Drag" and "Alt + Middle Mouse Drag" on the window
3. These words are not found in launchpad translation system

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.2.0-0ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-15.24-generic 3.2.5
Uname: Linux 3.2.0-15-generic x86_64
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,resize,compiztoolbox,vpswitch,regex,place,session,move,grid,wall,imgpng,gnomecompat,animation,wobbly,workarounds,expo,fade,ezoom,scale,unityshell]
Date: Sat Feb 11 10:54:02 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
SourcePackage: unity
UpgradeStatus: Upgraded to precise on 2012-02-10 (0 days ago)

Related branches

Koichi Akabe (vbkaisetsu) wrote :
Gabor Kelemen (kelemeng) wrote :

There are some more strings there that cannot be translated. I'll cook a patch soon.

Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Gabor Kelemen (kelemeng)
Gabor Kelemen (kelemeng) on 2012-02-18
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Tim Penhey (thumper) on 2012-02-21
Changed in unity:
assignee: nobody → Gabor Kelemen (kelemeng)
importance: Undecided → Medium
status: Confirmed → In Progress
milestone: none → 5.6.0
Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package unity - 5.6.0-0ubuntu1

---------------
unity (5.6.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #862972)
    - compiz crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()
      (LP: #926793)
    - compiz crashed with SIGSEGV in gdk_pixbuf_get_width() (LP: #937421)
    - Unity causes ibus to not work correctly (spaces incorrectly placed)
      (LP: #880876)
    - Dash - update Dash keyboard shortcuts so the 'CTRL + TAB' switches
      between Lenses and 'TAB' by itself moves the focus between categories
      (LP: #891648)
    - HUD - closing a window with <Alt>+<F4> opens the hud (LP: #923410)
    - unity-applications-daemon crashed with SIGSEGV in
      dee_sequence_model_free_row() (LP: #916356)
    - Launcher, Window Management - Launcher reveal should not be triggered
      when dragging a window (LP: #928805)
    - lenses are loaded on start, should be lazy loaded (LP: #929506)
    - Trash icon jumps about when trying to drag an icon onto it (LP: #932365)
    - HUD loses keypresses for the first second after opening (LP: #932906)
    - HUD doesn't give the focus back to the active application after dash/hud
      use (LP: #934061)
    - Launcher - unpinned apps show with empty pips in the launcher as if they
      exist on another workspace (LP: #937898)
    - Unity Dash should support Keywords parameter in .desktop (formerly X
      -GNOME-Keywords or X-AppInstall-Keywords) (LP: #941231)
    - Support FD.o Desktop Actions spec (LP: #942042)
    - Unity hangs when touching my touchpad/trackpad (LP: #942625)
    - [regression] Pressing alt doesn't show the menu title bar in top panel
      (LP: #943194)
    - Alt + F (or other mnemonic) doesn't work in gnome-terminal (LP: #943239)
    - [unity 5.6] Using Alt+F1 or Alt+F2 sends a ";3P" or ";3Q" to the active
      windows (LP: #943456)
    - [unity 5.6] holding alt and pressing a direction opens the alt-tab list
      in a buggy way (LP: #943902)
    - [unity-5.6] can't enter accents (^o->) in the dash since recent updates
      (LP: #944674)
    - Dash - Keyboard navigation for search filters is broken (LP: #844033)
    - Dash - If mouse highlights one icon in grid, keyboard navigation
      highlights another, so there are 2 highlighted icons (LP: #817436)
    - Alt+Tab default delay of 150ms is too long (LP: #888636)
    - Keyboard shortcut - F10 shortcut is used to show menu and this is wrong
      (LP: #878492)
    - Dash - Currently the app lens doesn't show applications that are
      available for purchase (LP: #916121)
    - Chromium is running, but not showing in launcher or alt-tab.
      (LP: #918474)
    - Dash - Different states of rating stars, and dimensions (LP: #924884)
    - alt-tab confused by a multiple instances of an application on different
      workspaces (LP: #925484)
    - Launcher - Icons are not colorized properly (LP: #930949)
    - Remove glow from Alt-tab edge and Search Field image assets
      (LP: #933578)
    - "Left Mouse Drag" and "Middle Mouse Drag" should be translatable
      (LP: #930510)
    - Launcher switcher...

Read more...

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Koichi Akabe (vbkaisetsu) wrote :

Hi,

It was fixed. Thanks!

However, po/unity.pot is not updated, so these fixes are not applied to Rosetta.
Could you update it?

Gabor Kelemen (kelemeng) on 2012-03-12
Changed in ubuntu-translations:
status: Triaged → Fix Released
Gabor Kelemen (kelemeng) wrote :

Koichi: the pot file was generated during the build, it is currently in the import queue[1]. It will be approved and imported soon, and we can start translating it. Updating the pot file in the bzr branch would be necessary to translate it in the upstream project, but that's currently not set up for translation.

[1]: https://translations.launchpad.net/ubuntu/precise/+source/unity/+imports

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers