Activity log for bug #926418

Date Who What changed Old value New value Message
2012-02-03 23:54:04 Jean-Baptiste Lallement bug added bug
2012-02-03 23:54:04 Jean-Baptiste Lallement attachment added unity_shotcuts_disabled.jpeg https://bugs.launchpad.net/bugs/926418/+attachment/2712269/+files/unity_shotcuts_disabled.jpeg
2012-02-04 08:02:44 Robert Roth unity (Ubuntu): status New Confirmed
2012-02-04 08:02:50 Robert Roth unity (Ubuntu): importance Undecided Low
2012-02-04 11:04:49 Omer Akram bug task added unity
2012-02-04 11:05:07 Omer Akram bug task added ayatana-design
2012-02-04 11:05:39 Omer Akram unity: importance Undecided Low
2012-02-04 11:05:42 Omer Akram unity: status New Confirmed
2012-02-09 13:29:13 John Lea description It's useless to show disabled shortcut (shortcut without a shortcut sequence associated) in the keyboard shortcut help. Screenshot attached. ProblemType: Bug DistroRelease: Ubuntu 12.04 Package: unity 5.2.0-0ubuntu1 ProcVersionSignature: Ubuntu 3.2.0-12.21-generic 3.2.2 Uname: Linux 3.2.0-12-generic x86_64 ApportVersion: 1.91-0ubuntu1 Architecture: amd64 CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,resize,fade,unitymtgrabhandles,scale,session,unityshell] Date: Sat Feb 4 00:49:16 2012 EcryptfsInUse: Yes InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012) ProcEnviron: PATH=(custom, user) LANG=en_US.utf8 SHELL=/bin/bash SourcePackage: unity UpgradeStatus: No upgrade log present (probably fresh install) It's useless to show disabled shortcut (shortcut without a shortcut sequence associated) in the keyboard shortcut help. Screenshot attached. -------------- Desired solution: - Disabled shortcuts should not be displayed
2012-02-09 13:29:19 John Lea tags amd64 apport-bug precise qa-manual-testing running-unity amd64 apport-bug precise qa-manual-testing running-unity udp
2012-02-09 13:29:25 John Lea ayatana-design: assignee John Lea (johnlea)
2012-02-09 13:29:27 John Lea ayatana-design: importance Undecided Medium
2012-02-09 13:29:29 John Lea ayatana-design: status New Triaged
2012-02-09 13:29:32 John Lea unity: milestone backlog
2012-04-23 04:20:49 Tim Penhey ayatana-design: status Triaged Fix Committed
2012-04-23 04:20:52 Tim Penhey unity: status Confirmed Triaged
2012-04-23 09:00:41 Andrea Azzarone unity: milestone backlog 5.12.0
2012-04-23 09:00:43 Andrea Azzarone unity: assignee Andrea Azzarone (andyrock)
2012-04-23 09:00:46 Andrea Azzarone unity (Ubuntu): assignee Andrea Azzarone (andyrock)
2012-04-23 09:00:50 Andrea Azzarone unity: status Triaged Fix Committed
2012-04-23 09:00:52 Andrea Azzarone unity (Ubuntu): status Confirmed Fix Committed
2012-04-26 09:14:43 Omer Akram description It's useless to show disabled shortcut (shortcut without a shortcut sequence associated) in the keyboard shortcut help. Screenshot attached. -------------- Desired solution: - Disabled shortcuts should not be displayed SRU testcase 1. go to ccsm and disable a default shortcut from there e.g. super+s 2. press and hold super+s you will see something as in the attached screenshot 3. now install unity from precise-proposed 4. now there won't be any item that says 'Disabled' It's useless to show disabled shortcut (shortcut without a shortcut sequence associated) in the keyboard shortcut help. Screenshot attached. -------------- Desired solution: - Disabled shortcuts should not be displayed
2012-04-26 09:14:48 Omer Akram bug added subscriber Ubuntu Stable Release Updates Team
2012-04-26 09:14:53 Omer Akram nominated for series Ubuntu Precise
2012-04-26 09:14:53 Omer Akram bug task added unity (Ubuntu Precise)
2012-04-27 11:32:59 Didier Roche unity: status Fix Committed Fix Released
2012-04-27 12:26:06 Launchpad Janitor branch linked lp:~ubuntu-desktop/unity/ubuntu
2012-04-27 13:14:46 Martin Pitt bug added subscriber SRU Verification
2012-04-27 13:14:48 Martin Pitt tags amd64 apport-bug precise qa-manual-testing running-unity udp amd64 apport-bug precise qa-manual-testing running-unity udp verification-needed
2012-04-30 04:28:22 Launchpad Janitor branch linked lp:ubuntu/precise-proposed/unity
2012-05-08 00:20:15 Launchpad Janitor unity (Ubuntu): status Fix Committed Fix Released
2012-05-08 00:25:13 Launchpad Janitor unity (Ubuntu Precise): status Fix Committed Fix Released
2012-09-05 13:33:08 Christian Giordano unity: status Fix Released Triaged
2012-10-12 13:19:34 John Lea description SRU testcase 1. go to ccsm and disable a default shortcut from there e.g. super+s 2. press and hold super+s you will see something as in the attached screenshot 3. now install unity from precise-proposed 4. now there won't be any item that says 'Disabled' It's useless to show disabled shortcut (shortcut without a shortcut sequence associated) in the keyboard shortcut help. Screenshot attached. -------------- Desired solution: - Disabled shortcuts should not be displayed Reverting to Triarged because: The shortcut disappeared but an empty whole is left. The shortcuts should reflow if a previous item gets hidden. The groups headers should move as well and if there is a group without shortcut shown, the group header should also be hidden. ------------------------ SRU testcase 1. go to ccsm and disable a default shortcut from there e.g. super+s 2. press and hold super+s you will see something as in the attached screenshot 3. now install unity from precise-proposed 4. now there won't be any item that says 'Disabled' It's useless to show disabled shortcut (shortcut without a shortcut sequence associated) in the keyboard shortcut help. Screenshot attached. -------------- Desired solution: - Disabled shortcuts should not be displayed
2012-10-12 13:19:37 John Lea unity (Ubuntu): status Fix Released Triaged
2012-10-12 13:19:42 John Lea unity (Ubuntu Precise): status Fix Released Triaged
2012-10-12 13:20:06 John Lea summary don't show disabled shortcut in keyboard shortcut help Keyboard shortcut - don't show disabled shortcuts in keyboard shortcut help
2012-10-15 14:42:40 John Lea unity: importance Low Medium
2012-10-15 14:42:42 John Lea unity (Ubuntu): importance Low Medium
2012-10-15 14:42:44 John Lea unity (Ubuntu Precise): importance Low Medium
2014-05-14 18:56:06 Mathew Hodson tags amd64 apport-bug precise qa-manual-testing running-unity udp verification-needed amd64 apport-bug precise qa-manual-testing running-unity udp
2014-05-14 19:02:54 Mathew Hodson unity (Ubuntu): status Triaged Fix Released
2017-10-13 08:34:27 Andrea Azzarone bug task deleted unity
2017-10-13 08:34:35 Andrea Azzarone unity (Ubuntu): assignee Andrea Azzarone (azzar1)
2017-10-13 08:34:42 Andrea Azzarone unity (Ubuntu): assignee Andrea Azzarone (azzar1)
2017-10-13 08:34:45 Andrea Azzarone unity (Ubuntu Precise): assignee Andrea Azzarone (azzar1)