compiz (unity) crashes with SIGSEGV when a window is minimized.

Bug #918329 reported by Omer Akram on 2012-01-18
42
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Daniel van Vugt
unity (Ubuntu)
Critical
Daniel van Vugt

Bug Description

TESTCASE:

Repeat:
1. Start any app that has a window.
2. Minimize the window.
3. Right click on the app in the Launcher and select Quit while it's minimized.

Unity/compiz will crash on the second iteration. Maybe the third if you're lucky.

ORIGINAL DESCRIPTION:

1. start chromium maximize it
2. start gnome terminal
3. minimize terminal and then chromium
4. now close both apps by right clicking their icons in the launcher
5. start chromium (considering it opens maximized)
6. minimize chromium
7. either system will just hang or unity will crash

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: compiz-core 1:0.9.6+bzr20110929-0ubuntu6
ProcVersionSignature: Ubuntu 3.0.0-15.24-generic 3.0.13
Uname: Linux 3.0.0-15-generic i686
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86 Kernel Module 285.05.09 Fri Sep 23 18:53:08 PDT 2011
 GCC version: gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3)
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu4
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
Date: Wed Jan 18 23:12:19 2012
Disassembly: => 0x147df59: Cannot access memory at address 0x147df59
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current-updates, 285.05.09, 3.0.0-14-generic, i686: installed
 nvidia-current-updates, 285.05.09, 3.0.0-15-generic, i686: installed
ExecutablePath: /usr/bin/compiz
GraphicsCard:
 nVidia Corporation G92 [GeForce 9800 GTX] [10de:0612] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: BFG Tech Device [19f1:0a76]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
JockeyStatus:
 xorg:nvidia_173 - NVIDIA accelerated graphics driver (Proprietary, Disabled, Not in use)
 xorg:nvidia_173_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Disabled, Not in use)
 xorg:nvidia_current_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Enabled, In use)
ProcCmdline: compiz
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-15-generic root=UUID=7f06de5d-a745-4fb3-b951-8e26f3452548 ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x147df59: Cannot access memory at address 0x147df59
 PC (0x0147df59) ok
 SP (0xbff5b5b0) ok
 Reason could not be automatically determined.
Signal: 11
SourcePackage: compiz
Stacktrace:
 #0 0x0147df59 in ?? ()
 No symbol table info available.
 Cannot access memory at address 0xbff5b5b0
StacktraceTop: ?? ()
Title: compiz crashed with SIGSEGV
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XorgConf:
 Section "Device"
  Identifier "My Graphics"
  Option "GLXVBlank" "on"
  Option "NoLogo" "True"
 EndSection
dmi.bios.date: 11/06/2009
dmi.bios.vendor: Intel Corp.
dmi.bios.version: RQG4110H.86A.0012.2009.1106.1345
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: DG41RQ
dmi.board.vendor: Intel Corporation
dmi.board.version: AAE54511-201
dmi.chassis.type: 3
dmi.modalias: dmi:bvnIntelCorp.:bvrRQG4110H.86A.0012.2009.1106.1345:bd11/06/2009:svn:pn:pvr:rvnIntelCorporation:rnDG41RQ:rvrAAE54511-201:cvn:ct3:cvr:
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu6
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Related branches

Omer Akram (om26er) wrote :

Stacktrace:
 #0 0x0147df59 in ?? ()
 No symbol table info available.
 Cannot access memory at address 0xbff5b5b0
StacktraceTop: ?? ()

Omer Akram (om26er) on 2012-01-18
visibility: private → public

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate a useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

outdated debug symbol package for libavahi-common3: package version 0.6.30-4ubuntu1 dbgsym version 0.6.30-0ubuntu2
outdated debug symbol package for libtiff4: package version 3.9.5-1ubuntu1 dbgsym version 3.9.4-5ubuntu6
outdated debug symbol package for libgpg-error0: package version 1.10-0.3ubuntu1 dbgsym version 1.10-0.2ubuntu1
outdated debug symbol package for libavahi-client3: package version 0.6.30-4ubuntu1 dbgsym version 0.6.30-0ubuntu2
outdated debug symbol package for passwd: package version 1:4.1.4.2+svn3283-3ubuntu2 dbgsym version 1:4.1.4.2+svn3283-3ubuntu1
outdated debug symbol package for libdatrie1: package version 0.2.4-3 dbgsym version 0.2.4-1
libcups2 version 1.5.0-8ubuntu6 required, but 1.5.0-8ubuntu7 is available
outdated debug symbol package for libstartup-notification0: package version 0.12-1 dbgsym version 0.10-1build1
outdated debug symbol package for libthai0: package version 0.1.15-2 dbgsym version 0.1.14-2ubuntu1
outdated debug symbol package for libltdl7: package version 2.4-2ubuntu1 dbgsym version 2.2.6b-2ubuntu3

Please upgrade your system to the latest package versions. If you still
encounter the crash, please file a new report.

Thank you for your understanding, and sorry for the inconvenience!

Changed in compiz (Ubuntu):
status: New → Invalid
tags: removed: need-i386-retrace
Omer Akram (om26er) on 2012-01-18
description: updated

Confirmed. Compiz crashed when I followed Omer's test case.

Changed in compiz (Ubuntu):
status: Invalid → Confirmed
Changed in compiz (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
Daniel van Vugt (vanvugt) wrote :

Here's (part of) a valgrind log. It shows lots of bad things going on in unity/compiz before the crash.

Changed in unity (Ubuntu):
status: New → Confirmed
assignee: nobody → Daniel van Vugt (vanvugt)
Daniel van Vugt (vanvugt) wrote :

This looks like bug 864758. But that one is closed already. Maybe it is the same bug and just wasn't fixed adequately... ?

summary: - compiz crashed with SIGSEGV
+ compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
+ CompWindow, 0>::get(CompWindow*) (pluginclasshandler.h:153) from
+ compiz::CompizMinimizedWindowHandler<UnityScreen,
+ UnityWindow>::minimize() (compizminimizedwindowhandler.h:184)
summary: compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
- CompWindow, 0>::get(CompWindow*) (pluginclasshandler.h:153) from
- compiz::CompizMinimizedWindowHandler<UnityScreen,
- UnityWindow>::minimize() (compizminimizedwindowhandler.h:184)
+ CompWindow, 0>::get(CompWindow*) (pluginclasshandler.h:153)
no longer affects: unity (Ubuntu)
affects: compiz (Ubuntu) → unity (Ubuntu)
Changed in unity:
status: New → Confirmed
assignee: nobody → Daniel van Vugt (vanvugt)

marking it as duplicate of bug 918360 which i reported after this one. it has the logs and all

Daniel van Vugt (vanvugt) wrote :

Already have this one in progress. Reversed duplicate pointers.

Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
description: updated
summary: - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
- CompWindow, 0>::get(CompWindow*) (pluginclasshandler.h:153)
+ compiz crashes with SIGSEGV when a window is minimized.
summary: - compiz crashes with SIGSEGV when a window is minimized.
+ compiz (unity) crashes with SIGSEGV when a window is minimized.
Omer Akram (om26er) on 2012-01-20
Changed in unity (Ubuntu Oneiric):
importance: Undecided → Critical
Changed in unity:
importance: Undecided → Critical
Changed in unity (Ubuntu Oneiric):
status: New → In Progress
Changed in unity (Ubuntu):
importance: Undecided → Critical
Changed in unity (Ubuntu Oneiric):
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in unity:
status: In Progress → Fix Committed
Omer Akram (om26er) wrote :

removed the oneiric task since the new upload to oneiric does not have this bug.

no longer affects: unity (Ubuntu Oneiric)
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in unity:
milestone: none → 5.2.0
Didier Roche (didrocks) on 2012-02-03
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.4 KiB)

This bug was fixed in the package unity - 5.2.0-0ubuntu1

---------------
unity (5.2.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Unity needs a way to switch (tab) between windows on current workspace
      (LP: #863399)
    - compiz crashed with SIGSEGV in BamfLauncherIcon::NameForWindow()
      (LP: #865840)
    - Gradual degradation in desktop performance. (LP: #888039)
    - compiz (unity) crashes with SIGSEGV when a window is minimized.
      (LP: #918329)
    - FavoriteStore external change support (LP: #681503)
    - Launcher - Make Launcher left of screen reveal more responsive and less
      prone to false positives (LP: #765819)
    - Window auto-maximise functionality should be disabled on monitors with a
      resolution above 1024 x 600 (LP: #797808)
    - Dash: very high latency responding to input (LP: #828582)
    - Dash - Behaviour of the 'All' button in the Dash filters broken in
      several ways (LP: #841864)
    - alt-tab - The app title in the top left of the top bar should change as
      the alt-tab focus changes (LP: #855516)
    - Keyboard shortcut - Add keyboard shortcut hint overlay that is displayed
      when a user presses and holds the Super key (LP: #855532)
    - Unity crashes when started in an environment without utouch support
      (LP: #860707)
    - Dash - Remove Dash Home shortcut icons (LP: #885738)
    - Dash - Most Frequently Used apps change to Recently Used, without
      Launcher favorites (LP: #893214)
    - Should have a launcher on every monitor (LP: #915944)
    - Launcher autohide behaviour on multi-monitor (LP: #915946)
    - the unity wrapper should kill compiz before restarting it (LP: #919132)
    - Launcher - Implement workspace/launcher cross interactions (LP: #690143)
    - Application icons should only display windows from the current workspace
      in the window spread (LP: #689733)
    - Notification area ("system tray") missing when using dual monitors of
      different sizes, with their bottoms aligned (LP: #778256)
    - Clicking Nautilus launcher icon fails to open a Nautilus file explorer
      window when copying a file and all other Nautilus windows are closed /
      bamf should skip the taskbar (LP: #784804)
    - Dash - the search box is not aligned correctly relative to the Launcher
      BFB button (LP: #838904)
    - Dash - A expand/collapse arrow is missing from all the filter category
      headers (LP: #841870)
    - Dash - the filter buttons should not have a mouse over state
      (LP: #838901)
    - Dash - the "Filter results" text is the wrong size, wrong font weight,
      and aligned incorrectly in both the vertical and horizontal axis
      (LP: #863240)
    - Add SUPER+TAB switching mode that enables the user to switch
      applications via the Launcher (LP: #891620)
    - Software Centre - automatically add app icon to launcher (LP: #761851)
    - Compiz add transparency to titlebar along with the panel (LP: #912682)
    - The search box is too opaque and dark (LP: #913717)
    - Dash - Make statefulness of Dash Home and Dash Lenses consistent
      (LP: #914759)
    - Unity 5.0: "All" button for filters render as "..." (LP: #91...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.