Expo plugin not marked as essential for Unity plugin (in ccsm)

Bug #897697 reported by Marcin Juszkiewicz
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Didier Roche
unity (Ubuntu)
Low
Didier Roche

Bug Description

When I am using ccsm to configure some bits (nevermind that it is not recommended) I noticed that some plugins can not be disabled as ccsm tells that Unity plugin requires them. But this is not a case for Expo plugin which has icon under launcher icons...
---
.tmp.unity.support.test.0:

ApportVersion: 1.90-0ubuntu1
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,resize,resizeinfo,vpswitch,regex,gnomecompat,mousepoll,move,wall,compiztoolbox,place,imgpng,grid,session,animation,expo,unitymtgrabhandles,fade,scale,workarounds,unityshell]
CompositorRunning: compiz
DistUpgraded: Fresh install
DistroCodename: precise
DistroRelease: Ubuntu 12.04
DistroVariant: ubuntu
GlAlternative: lrwxrwxrwx 1 root root 24 paź 19 2010 /etc/alternatives/gl_conf -> /usr/lib/mesa/ld.so.conf
GraphicsCard:
 ATI Technologies Inc Cedar PRO [Radeon HD 5450] [1002:68f9] (prog-if 00 [VGA controller])
   Subsystem: Micro-Star International Co., Ltd. Device [1462:2120]
InstallationMedia: Kubuntu 10.04 "Lucid Lynx" - Release Candidate amd64 (20100419.1)
MachineType: Gigabyte Technology Co., Ltd. EP35C-DS3R
Package: unity 4.24.0-0ubuntu2b1
PackageArchitecture: amd64
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-1-generic root=UUID=b998ea79-ff6e-44e6-b6d4-b5eddddedde0 ro nodmraid 8250.nr_uarts=7 crashkernel=384M-2G:64M,2G-:128M quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-1.3-generic 3.2.0-rc2
Tags: precise running-unity precise running-unity precise running-unity ubuntu reproducible compiz-0.9
Uname: Linux 3.2.0-1-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout libvirtd lpadmin plugdev sambashare vboxusers video
dmi.bios.date: 06/18/2009
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F4
dmi.board.name: EP35C-DS3R
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF4:bd06/18/2009:svnGigabyteTechnologyCo.,Ltd.:pnEP35C-DS3R:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnEP35C-DS3R:rvr:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: EP35C-DS3R
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu7
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.27-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu4
version.xserver-xorg-core: xserver-xorg-core 2:1.10.4-1ubuntu5
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

Related branches

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : BootDmesg.txt

apport information

tags: added: apport-collected compiz-0.9 precise reproducible running-unity ubuntu
description: updated
Revision history for this message
Marcin Juszkiewicz (hrw) wrote : BootLog.gz

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : CurrentDmesg.txt

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : Dependencies.txt

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : DpkgLog.txt

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : GconfCompiz.txt

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : GdmLog.txt

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : GdmLog1.txt

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : GdmLog2.txt

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : LightdmDisplayLog.txt

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : LightdmGreeterLog.txt

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : LightdmLog.txt

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : Lspci.txt

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : Lsusb.txt

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : MonitorsUser.xml.txt

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : ProcCpuinfo.txt

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : ProcEnviron.txt

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : ProcInterrupts.txt

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : ProcModules.txt

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : UdevDb.txt

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : UdevLog.txt

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : UnitySupportTest.txt

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : XorgConf.txt

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : XorgLog.txt

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : XorgLogOld.txt

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : Xrandr.txt

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : dmidecode.txt.txt

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : locale.txt

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : peripherals.txt

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : setxkbmap.txt

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : xdpyinfo.txt

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : xinput.txt

apport information

Revision history for this message
Marcin Juszkiewicz (hrw) wrote : xkbcomp.txt

apport information

Revision history for this message
Rick Spencer (rick-rickspencer3) wrote :

Desktop Team: I'm not sure if you want to respond to this or not. If you won't be supporting this scenario, please close the bug, or mark it as low, etc...

Changed in unity (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Revision history for this message
Didier Roche (didrocks) wrote :

Hey, thanks for this bug report, but there are two notions there:
- the wall plugin (the one which has the button in the laucher), is an unity dependency.
Unity depends on a "largedesktop" feature, which is provided by both wall and cube, so both are compatible and at least one of the two should be enabled to unity to be enabled. There is no issue there.
- the expo plugin is used when you click on a launcher icon when the application as already the focus (and that you have more than one intance of this application). This one expose all windows from your current application. We detect the dependency at startup and if it's not there, the feature is simply disabled, so it's not mandatory.
Putting the report as Invalid there. Thanks for your bug report and do not hesitate to file any other issue you can encounter. :)

Changed in unity (Ubuntu):
status: New → Invalid
Revision history for this message
Marcin Juszkiewicz (hrw) wrote :

When I disable Expo plugin (Desktop Wall is enabled) and click launcher icon there is no reaction. When I enable it again it gives me desktops preview.

With two Chrome windows open when I press on Chrome icon in launcher I get preview of them even with Expo plugin disabled.

Enabling "Rotate Cube" enables "Desktop Cube" which conflicts with "Desktop Wall" which is required by "Unity" - that's what ccsm just told me.

Revision history for this message
Didier Roche (didrocks) wrote :

We need to discuss that with sam, as it was part of his initial presentation to me about the different of wall and expo, and that's why we added the "largedesktop" feature there.

> Enabling "Rotate Cube" enables "Desktop Cube" which conflicts with "Desktop Wall" which is required by "Unity" - that's what ccsm just told me.
This is because of this feature set, this is totally wanted (but maybe sam meant "expo" instead of Wall. In this case, how to not loose the exposing window capability?

Will ping Sam on that!

Revision history for this message
Sam Spilsbury (smspillaz) wrote : Re:[Bug 897697] Re: Expo plugin not marked as essential for Unity plugin (in ccsm)

Wall and cube are responsible for switching desktops with keybindings - hence they conflict. Expo does not provide this feature.

If you wanted to enforce those features being available, I see no problem with making unityshell depend on expo and scale for now.

Sam

Sent from Samsung Mobile

 Didier Roche <email address hidden> wrote:

null

Revision history for this message
Didier Roche (didrocks) wrote :

Thanks sam, I'll do that directly in unity upstream then :)

Changed in unity (Ubuntu):
status: Invalid → Triaged
assignee: Canonical Desktop Team (canonical-desktop-team) → Didier Roche (didrocks)
Changed in unity:
assignee: nobody → Didier Roche (didrocks)
status: New → Triaged
Omer Akram (om26er)
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity:
importance: Undecided → Low
Changed in unity:
status: Triaged → Fix Committed
Omer Akram (om26er)
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Didier Roche (didrocks)
Changed in unity:
milestone: none → 5.2.0
Didier Roche (didrocks)
Changed in unity:
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (5.4 KiB)

This bug was fixed in the package unity - 5.2.0-0ubuntu1

---------------
unity (5.2.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Unity needs a way to switch (tab) between windows on current workspace
      (LP: #863399)
    - compiz crashed with SIGSEGV in BamfLauncherIcon::NameForWindow()
      (LP: #865840)
    - Gradual degradation in desktop performance. (LP: #888039)
    - compiz (unity) crashes with SIGSEGV when a window is minimized.
      (LP: #918329)
    - FavoriteStore external change support (LP: #681503)
    - Launcher - Make Launcher left of screen reveal more responsive and less
      prone to false positives (LP: #765819)
    - Window auto-maximise functionality should be disabled on monitors with a
      resolution above 1024 x 600 (LP: #797808)
    - Dash: very high latency responding to input (LP: #828582)
    - Dash - Behaviour of the 'All' button in the Dash filters broken in
      several ways (LP: #841864)
    - alt-tab - The app title in the top left of the top bar should change as
      the alt-tab focus changes (LP: #855516)
    - Keyboard shortcut - Add keyboard shortcut hint overlay that is displayed
      when a user presses and holds the Super key (LP: #855532)
    - Unity crashes when started in an environment without utouch support
      (LP: #860707)
    - Dash - Remove Dash Home shortcut icons (LP: #885738)
    - Dash - Most Frequently Used apps change to Recently Used, without
      Launcher favorites (LP: #893214)
    - Should have a launcher on every monitor (LP: #915944)
    - Launcher autohide behaviour on multi-monitor (LP: #915946)
    - the unity wrapper should kill compiz before restarting it (LP: #919132)
    - Launcher - Implement workspace/launcher cross interactions (LP: #690143)
    - Application icons should only display windows from the current workspace
      in the window spread (LP: #689733)
    - Notification area ("system tray") missing when using dual monitors of
      different sizes, with their bottoms aligned (LP: #778256)
    - Clicking Nautilus launcher icon fails to open a Nautilus file explorer
      window when copying a file and all other Nautilus windows are closed /
      bamf should skip the taskbar (LP: #784804)
    - Dash - the search box is not aligned correctly relative to the Launcher
      BFB button (LP: #838904)
    - Dash - A expand/collapse arrow is missing from all the filter category
      headers (LP: #841870)
    - Dash - the filter buttons should not have a mouse over state
      (LP: #838901)
    - Dash - the "Filter results" text is the wrong size, wrong font weight,
      and aligned incorrectly in both the vertical and horizontal axis
      (LP: #863240)
    - Add SUPER+TAB switching mode that enables the user to switch
      applications via the Launcher (LP: #891620)
    - Software Centre - automatically add app icon to launcher (LP: #761851)
    - Compiz add transparency to titlebar along with the panel (LP: #912682)
    - The search box is too opaque and dark (LP: #913717)
    - Dash - Make statefulness of Dash Home and Dash Lenses consistent
      (LP: #914759)
    - Unity 5.0: "All" button for filters render as "..." (LP: #91...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.