launcher does not show minimized update manager while clicked

Bug #877444 reported by Shannon on 2011-10-18
132
This bug affects 27 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

The update manager gets launched automatically because it founds some new update. I click on the laucher button, it does NOT show the update manager window. I tried everything I can but the window simply does not show up.

It looks similar to bug #801593, but I am not sure, because this application should not be positioned "across desktops".

However, the differences are: 1) I am not

Shannon (xrfang-gmail) wrote :

I am sorry that #733349 is different. It says to click on the button to MINIMIZE a normal window.

My problem is that I cannot RESTORE a minimized window by clicking on its launcher icon.

Cas (calumlind) on 2011-10-19
summary: - launcher does not show minimized application while clicked
+ launcher does not show minimized update manager while clicked
razor (razorxpress) wrote :

Same here. Even though the icon shows active color(orange) it does not restore. So I click it 50 times before I have to issue
$ sudo service lightdm restart

Shannon (xrfang-gmail) wrote :

Cas, I feel that it is better not to restrict this bug to update manager only. Because:

1) This bug is not 100% reproducible, but it happens from time to time, to any application, noticeably, firefox.

2) The other times while it happens with firefox, I am using my office PC running 11.04, which just upgraded to 11.10 (both have this problem) with 2 monitors.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-10-25
Changed in unity:
status: New → Confirmed

At home : The bug occurs each time update manager proposes new available upgrades automatically .. i must close U-m by right click + quit and re-open update -manager .

Stephen Early (steve-greenend) wrote :

This affects me too: update manager starts automatically because there are available updates, and hides itself. The Unity launcher shows it as running (icon is present, showing number of available updates, with a blue-ish arrowhead by it) but nothing happens when it's clicked. The only option that does anything on the menu available with right-click is "Quit", which works as expected.

description: updated
Greg Lynch (gregalynch) wrote :

I recently installed mjuhasz's backported Oneric fixes for bug #819721 (nux) and bug #842566 (bamf), and now the problem described in this thread seems to be fixed, as well. I'm not sure which one did the trick.

Greg Lynch (gregalynch) wrote :

Nevermind - I thought the problem was fixed but today it reappeared

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, does it still happen in precise? Does it work if you click on something else and then try again go back to update-manager?

Changed in unity (Ubuntu):
importance: Undecided → High
status: Confirmed → Incomplete
Changed in unity:
importance: Undecided → High
status: Confirmed → Incomplete
Shannon (xrfang-gmail) wrote :

Sorry I am still using 11.10. This problem is NOT fixed in 11.10, it happens very frequently either on my desktop in office or my laptop (both 11.10). Will report back if it still exists in 12.04, after it is released :)

Gabe Gorelick (gabegorelick) wrote :

It seems to be fixed in precise. Will report back if it pops up again.

Sebastien Bacher (seb128) wrote :

Thank you for the update, closing the bug

Changed in unity:
status: Incomplete → Fix Released
Changed in unity (Ubuntu):
status: Incomplete → Fix Released
David Racine (bass-dr) wrote :

This is not solved in precise. I had this problem in 11.10, installed 12.04 from scratch and the problem did not appear at first. But today I notice this exact problem on both my laptop and my desktop.

I can still use right-click menu not only to close the app, but also to "install all updates". This option works now (not sure if it was before), but the update manager's main window never shows up anyway, we really need to close and reopen update manager for it to show up, the icons stays in the tray unclickable.

Shannon (xrfang-gmail) wrote :

same here. this happened once yesterday. however it was ok in all previous updates after install precise. even since the first report back in ocelot, this bug does not happen every time.

David Racine (bass-dr) wrote :

Do we have to fill a new bug or someone could reopen this one?

tags: added: precise
zasran (erik-zasran) wrote :

I still see the bug in updated precise 12.04.

What does Fix released actually mean? Is the fix available in updates or is it simply checked in somewhere waiting for release?

BTW I never saw the bug in 2D version of Unity (I had a computer that couldn't handle 3D very well so I used 2D or classic or whatever was it called). I consistently see it in "normal" Unity.

David Racine (bass-dr) wrote :

I opened bug #1003950, but not much activity so far. I think the bug was realy solved in a previous release, but then reappeared in newer releases. I have no much clue why this problem comes and go.

Joel Östblom (joel-ostblom) wrote :

I am experiencing this bug in 14.04.

Frederic Defoy (fdefoy) wrote :

I am also having the problem right now in Ubuntu 14.04

I also experience a similar issue with other windows disapearing from the screens AND the launcher after I minimize them. It may be another problem not sure... I confirm it happened with Chrome and terminal windows from Remmina.

Maidomax (maidomax) wrote :

I am having the same issue on Ubuntu 14.04
I didn't have it with other programs.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers