compiz crashed with SIGSEGV in BamfLauncherIcon::NameForWindow()

Bug #865840 reported by Jono Bacon on 2011-10-04
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Tim Penhey
unity (Ubuntu)
Critical
Tim Penhey

Bug Description

This seemed to happen when I was using Alt-Tab.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity 4.20.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
ApportVersion: 1.23-0ubuntu2
Architecture: i386
CrashCounter: 1
Date: Mon Oct 3 19:01:19 2011
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
ProcCmdline: compiz
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0xa6dcc6: movdqu (%edi),%xmm1
 PC (0x00a6dcc6) ok
 source "(%edi)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%xmm1" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 ?? () from /lib/i386-linux-gnu/libc.so.6
 BamfLauncherIcon::NameForWindow(unsigned long) () from /usr/lib/compiz/libunityshell.so
 unity::switcher::SwitcherView::OnDetailSelectionChanged(bool) () from /usr/lib/compiz/libunityshell.so
 sigc::internal::slot_call1<sigc::bound_mem_functor1<void, unity::switcher::SwitcherView, bool>, void, bool const&>::call_it(sigc::internal::slot_rep*, bool const&) () from /usr/lib/compiz/libunityshell.so
 nux::Property<bool>::operator=(bool const&) () from /usr/lib/compiz/libunityshell.so
Title: compiz crashed with SIGSEGV in BamfLauncherIcon::NameForWindow()
UpgradeStatus: Upgraded to oneiric on 2011-07-13 (82 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Jono Bacon (jonobacon) wrote :
visibility: private → public

StacktraceTop:
 __strlen_sse2_bsf () at ../sysdeps/i386/i686/multiarch/strlen-sse2-bsf.S:52
 length (__s=0x0) at /usr/include/c++/4.6/bits/char_traits.h:261
 assign (__s=0x0, this=0xbf880e6c) at /usr/include/c++/4.6/bits/basic_string.h:1121
 operator= (__s=0x0, this=0xbf880e6c) at /usr/include/c++/4.6/bits/basic_string.h:550
 BamfLauncherIcon::NameForWindow (this=0xa3058d0, window=60817786) at /build/buildd/unity-4.20.0/plugins/unityshell/src/BamfLauncherIcon.cpp:284

Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-10-25
Changed in unity:
status: New → Confirmed
Didier Roche (didrocks) on 2011-10-25
Changed in unity (Ubuntu):
importance: Medium → Critical
Tim Penhey (thumper) wrote :

Assigning null to a std::string is not allowed.

tags: added: bitesize
Changed in unity:
importance: Undecided → Critical
Tim Penhey (thumper) wrote :

Jono, do you recall having any particular non-standard apps running during these alt-tab crashes? I think I've found the actual problem, but it would be great to be able to reproduce it.

Tim Penhey (thumper) on 2012-01-24
Changed in unity:
assignee: nobody → Tim Penhey (thumper)
status: Confirmed → In Progress
Omer Akram (om26er) on 2012-01-24
Changed in unity (Ubuntu):
assignee: nobody → Tim Penhey (thumper)
status: Confirmed → In Progress
Tim Penhey (thumper) on 2012-01-24
Changed in unity:
milestone: none → 5.2.0
Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-02-01
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-02-03
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.4 KiB)

This bug was fixed in the package unity - 5.2.0-0ubuntu1

---------------
unity (5.2.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Unity needs a way to switch (tab) between windows on current workspace
      (LP: #863399)
    - compiz crashed with SIGSEGV in BamfLauncherIcon::NameForWindow()
      (LP: #865840)
    - Gradual degradation in desktop performance. (LP: #888039)
    - compiz (unity) crashes with SIGSEGV when a window is minimized.
      (LP: #918329)
    - FavoriteStore external change support (LP: #681503)
    - Launcher - Make Launcher left of screen reveal more responsive and less
      prone to false positives (LP: #765819)
    - Window auto-maximise functionality should be disabled on monitors with a
      resolution above 1024 x 600 (LP: #797808)
    - Dash: very high latency responding to input (LP: #828582)
    - Dash - Behaviour of the 'All' button in the Dash filters broken in
      several ways (LP: #841864)
    - alt-tab - The app title in the top left of the top bar should change as
      the alt-tab focus changes (LP: #855516)
    - Keyboard shortcut - Add keyboard shortcut hint overlay that is displayed
      when a user presses and holds the Super key (LP: #855532)
    - Unity crashes when started in an environment without utouch support
      (LP: #860707)
    - Dash - Remove Dash Home shortcut icons (LP: #885738)
    - Dash - Most Frequently Used apps change to Recently Used, without
      Launcher favorites (LP: #893214)
    - Should have a launcher on every monitor (LP: #915944)
    - Launcher autohide behaviour on multi-monitor (LP: #915946)
    - the unity wrapper should kill compiz before restarting it (LP: #919132)
    - Launcher - Implement workspace/launcher cross interactions (LP: #690143)
    - Application icons should only display windows from the current workspace
      in the window spread (LP: #689733)
    - Notification area ("system tray") missing when using dual monitors of
      different sizes, with their bottoms aligned (LP: #778256)
    - Clicking Nautilus launcher icon fails to open a Nautilus file explorer
      window when copying a file and all other Nautilus windows are closed /
      bamf should skip the taskbar (LP: #784804)
    - Dash - the search box is not aligned correctly relative to the Launcher
      BFB button (LP: #838904)
    - Dash - A expand/collapse arrow is missing from all the filter category
      headers (LP: #841870)
    - Dash - the filter buttons should not have a mouse over state
      (LP: #838901)
    - Dash - the "Filter results" text is the wrong size, wrong font weight,
      and aligned incorrectly in both the vertical and horizontal axis
      (LP: #863240)
    - Add SUPER+TAB switching mode that enables the user to switch
      applications via the Launcher (LP: #891620)
    - Software Centre - automatically add app icon to launcher (LP: #761851)
    - Compiz add transparency to titlebar along with the panel (LP: #912682)
    - The search box is too opaque and dark (LP: #913717)
    - Dash - Make statefulness of Dash Home and Dash Lenses consistent
      (LP: #914759)
    - Unity 5.0: "All" button for filters render as "..." (LP: #91...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers