compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow, CompWindow, 0>::get()

Bug #864758 reported by Konstantin Makarov on 2011-10-02
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nux
Fix Released
Critical
Unassigned
Unity
Fix Released
Critical
Sam Spilsbury
nux (Ubuntu)
Critical
Unassigned
unity (Ubuntu)
Critical
Sam Spilsbury
Oneiric
Undecided
Unassigned

Bug Description

crashed when I tried to minimize image viewer

TESTCASE

Open some application
Do sleep 10 && killall -9 (the application)
Minimize the application

It won't crash after 10 seconds

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: libnux-1.0-0 1.14.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
CrashCounter: 1
Date: Sun Oct 2 20:30:38 2011
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcCmdline: compiz
ProcEnviron:
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7fd4c43b4e2f <_ZN18PluginClassHandlerI11UnityWindow10CompWindowLi0EE3getEPS1_+383>: mov (%rax,%rdx,8),%rbp
 PC (0x7fd4c43b4e2f) ok
 source "(%rax,%rdx,8)" (0x1800000720) not located in a known VMA region (needed readable region)!
 destination "%rbp" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: nux
StacktraceTop:
 PluginClassHandler<UnityWindow, CompWindow, 0>::get(CompWindow*) () from /usr/lib/compiz/libunityshell.so
 compiz::CompizMinimizedWindowHandler<UnityScreen, UnityWindow>::minimize() () from /usr/lib/compiz/libunityshell.so
 UnityWindow::minimize() () from /usr/lib/compiz/libunityshell.so
 CompWindow::minimize() ()
 unity::PanelMenuView::OnMinimizeClicked() () from /usr/lib/compiz/libunityshell.so
Title: compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow, CompWindow, 0>::get()
UpgradeStatus: Upgraded to oneiric on 2011-09-28 (4 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare vboxusers
XsessionErrors:
 (nautilus:2057): Gtk-CRITICAL **: gtk_action_set_visible: assertion `GTK_IS_ACTION (action)' failed
 (nautilus:2057): Gtk-CRITICAL **: gtk_action_set_visible: assertion `GTK_IS_ACTION (action)' failed

Related branches

Konstantin Makarov (cmakarov) wrote :

StacktraceTop:
 getInstance (base=0x3f5f290) at /usr/include/compiz/core/pluginclasshandler.h:153
 PluginClassHandler<UnityWindow, CompWindow, 0>::get (base=0x3f5f290) at /usr/include/compiz/core/pluginclasshandler.h:185
 compiz::CompizMinimizedWindowHandler<UnityScreen, UnityWindow>::minimize (this=0x7fd4b4a7db50) at /build/buildd/unity-4.20.0/plugins/unityshell/src/compizminimizedwindowhandler.h:169
 UnityWindow::minimize (this=0x35ae8c0) at /build/buildd/unity-4.20.0/plugins/unityshell/src/unityshell.cpp:1591
 CompWindow::minimize (this=0x3f8f9a0) at /build/buildd/compiz-0.9.6+bzr20110929/src/window.cpp:4529

affects: ubuntu → nux (Ubuntu)
Changed in nux (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Didier Roche (didrocks) on 2011-10-03
Changed in nux (Ubuntu):
importance: Medium → Critical
Jean-Baptiste Lallement (jibel) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:
1. Is this reproducible?
2. If so, what specific steps should we take to recreate this bug? Be as detailed as possible.
This will help us to find and resolve the problem.

visibility: private → public
Changed in nux (Ubuntu):
status: New → Incomplete
Changed in nux:
status: New → Invalid
importance: Undecided → Critical
Changed in unity:
importance: Undecided → Critical
status: New → Confirmed
milestone: none → 4.24.0
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in nux (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
Omer Akram (om26er) on 2011-10-05
affects: nux (Ubuntu) → unity (Ubuntu)
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Omer Akram (om26er) on 2011-10-05
Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity:
status: Incomplete → In Progress
Changed in unity (Ubuntu):
milestone: none → oneiric-updates
Konstantin Makarov (cmakarov) wrote :

I've tried to reproduce but it only freezes, and does not crash.

Changed in unity:
status: In Progress → Fix Committed
status: Fix Committed → Triaged
status: Triaged → In Progress
Changed in nux:
status: Invalid → Fix Committed
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
description: updated
Didier Roche (didrocks) on 2011-10-14
Changed in nux:
status: Fix Committed → Invalid
Omer Akram (om26er) on 2011-10-16
Changed in unity:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-10-17
Changed in nux:
status: Invalid → Fix Released

Hello Konstantin, or anyone else affected,

Accepted unity into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
Miklos Juhasz (mjuhasz) wrote :

I tested the proposed version and it works.

I executed: sleep 10 && killall -9 gedit
, then minimized gedit. In 10 seconds gedit was gone.

One minor thing: I had Thunderbird minimized that time and its window got restored from minimized state at the same time when gedit died. As if I had clicked on the launcher icon to bring back the window to the desktop.

Martin Pitt (pitti) on 2011-10-19
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.24.0-0ubuntu2

---------------
unity (4.24.0-0ubuntu2) oneiric-proposed; urgency=low

  * Cherry-pick upstream:
    - SRU0-Regression: scrollbar displacement caused dash rows to show less
      icons (LP: #875023)
    - Really reverts the UI change that was still uploaded even if we had
      reverted it…

unity (4.24.0-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release and some cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #864758)
    - unity panel menus don't stay open when clicked on second monitor
      (LP: #869196)
    - (oneiric) menu bar in wrong place and invisible (LP: #845856)
    - Lens range widgets do not function correctly (LP: #862996)
    - Cannot raise window from panel after minimize (LP: #863114)
    - unity-panel-service crashed with SIGSEGV in g_closure_invoke()
      (LP: #843280)
    - Windows get corrupted sometimes when semi-maximizing them. (LP: #865177)
    - Automaximization happens on unminimize (LP: #868930)
    - compiz crashed with SIGSEGV in nux::ROProperty<std::string>::operator
      std::string() (LP: #869109)
    - Dash - horizental divider line in between categories incorrectly drawn
      (LP: #841750)
    - F10 opens a random menu item when it should open the first one
      [regression] (LP: #862849)
    - Switching desktops after using showdesktop can cause hidden windows to
      become "active" (LP: #864503)
    - Clicking blank space on top panel doesn't raise maximized window to
      front (LP: #864708)
    - unity launcher loses track of deja-dup windows (LP: #865051)
    - Dash - App Lens 'Rating' filter behaves incorrectly (LP: #865482)
    - Launcher does not show on "Show desktop" (LP: #867959)
    - ibus character selection window not drawn (LP: #867885)
    - the dash's entry get wrongly colored on left or right key use
      (LP: #868434)
    - [ibus] Pressing down when ibus is active moves focus (LP: #872730)
    - Double-click on the dash top panel is taken effect on the window
      underneith (LP: #870844)
 -- Didier Roche <email address hidden> Tue, 18 Oct 2011 12:47:54 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.24.0-0ubuntu2b1

---------------
unity (4.24.0-0ubuntu2b1) oneiric-proposed; urgency=low

  * No-change reupload because of broken powerpc build.

unity (4.24.0-0ubuntu2) oneiric-proposed; urgency=low

  * Cherry-pick upstream:
    - SRU0-Regression: scrollbar displacement caused dash rows to show less
      icons (LP: #875023)
    - Really reverts the UI change that was still uploaded even if we had
      reverted it…

unity (4.24.0-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release and some cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #864758)
    - unity panel menus don't stay open when clicked on second monitor
      (LP: #869196)
    - (oneiric) menu bar in wrong place and invisible (LP: #845856)
    - Lens range widgets do not function correctly (LP: #862996)
    - Cannot raise window from panel after minimize (LP: #863114)
    - unity-panel-service crashed with SIGSEGV in g_closure_invoke()
      (LP: #843280)
    - Windows get corrupted sometimes when semi-maximizing them. (LP: #865177)
    - Automaximization happens on unminimize (LP: #868930)
    - compiz crashed with SIGSEGV in nux::ROProperty<std::string>::operator
      std::string() (LP: #869109)
    - Dash - horizental divider line in between categories incorrectly drawn
      (LP: #841750)
    - F10 opens a random menu item when it should open the first one
      [regression] (LP: #862849)
    - Switching desktops after using showdesktop can cause hidden windows to
      become "active" (LP: #864503)
    - Clicking blank space on top panel doesn't raise maximized window to
      front (LP: #864708)
    - unity launcher loses track of deja-dup windows (LP: #865051)
    - Dash - App Lens 'Rating' filter behaves incorrectly (LP: #865482)
    - Launcher does not show on "Show desktop" (LP: #867959)
    - ibus character selection window not drawn (LP: #867885)
    - the dash's entry get wrongly colored on left or right key use
      (LP: #868434)
    - [ibus] Pressing down when ibus is active moves focus (LP: #872730)
    - Double-click on the dash top panel is taken effect on the window
      underneith (LP: #870844)
 -- Martin Pitt <email address hidden> Tue, 25 Oct 2011 07:01:51 +0200

Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Changed in nux (Ubuntu):
status: New → Fix Released
importance: Undecided → Critical
Rolf Leggewie (r0lf) on 2016-04-24
no longer affects: nux (Ubuntu Oneiric)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers