compiz crashed with SIGSEGV in _XFreeEventCookies()

Bug #851472 reported by Holger Knust on 2011-09-16
538
This bug affects 122 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Sam Spilsbury
unity (Ubuntu)
Critical
Sam Spilsbury
Oneiric
Critical
d tunthuwa

Bug Description

I tried to take a screenshot and paste it into GIMP prior to this error but had multiple other apps open.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: compiz-core 1:0.9.5.94+bzr2803-0ubuntu5
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu1
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,move,grid,place,imgpng,gnomecompat,resize,regex,session,unitymtgrabhandles,snap,vpswitch,mousepoll,wall,animation,workarounds,expo,fade,ezoom,scale,unityshell]
CompositorRunning: compiz
CrashCounter: 1
Date: Thu Sep 15 20:27:05 2011
DistUpgraded: Log time: 2011-08-26 06:52:00.319056
DistroCodename: oneiric
DistroVariant: ubuntu
ExecutablePath: /usr/bin/compiz
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:04b8]
 nVidia Corporation Device [10de:0dd6] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:04b8]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110804)
MachineType: Dell Inc. Dell System XPS L702X
ProcCmdline: compiz
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.0.0-11-generic root=UUID=017bb51c-9d68-4616-8ad2-20e3260e969d ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x7f15d8b5e4f3 <_XFreeEventCookies+19>: mov 0x40(%rax),%rbp
 PC (0x7f15d8b5e4f3) ok
 source "0x40(%rax)" (0x00001290) not located in a known VMA region (needed readable region)!
 destination "%rbp" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: compiz
StacktraceTop:
 _XFreeEventCookies () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 XNextEvent () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 PrivateScreen::processEvents() ()
 CompEventSource::callback() ()
 Glib::Source::dispatch_vfunc(_GSource*, int (*)(void*), void*) () from /usr/lib/libglibmm-2.4.so.1
Title: compiz crashed with SIGSEGV in _XFreeEventCookies()
UpgradeStatus: Upgraded to oneiric on 2011-09-11 (4 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 07/22/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A12
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 0K4H3G
dmi.board.vendor: Dell Inc.
dmi.board.version: FAB1
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA12:bd07/22/2011:svnDellInc.:pnDellSystemXPSL702X:pvr:rvnDellInc.:rn0K4H3G:rvrFAB1:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: Dell System XPS L702X
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.5.94+bzr2803-0ubuntu5
version.ia32-libs: ia32-libs 20090808ubuntu21
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Related branches

Holger Knust (hknust) wrote :

StacktraceTop:
 _XFreeEventCookies (dpy=0x855810) at ../../src/XlibInt.c:780
 XNextEvent (dpy=0x855810, event=0x7fffa408d510) at ../../src/NextEvent.c:47
 PrivateScreen::processEvents (this=0x8404a0) at /build/buildd/compiz-0.9.5.94+bzr2803/src/screen.cpp:636
 callback (this=<optimized out>) at /build/buildd/compiz-0.9.5.94+bzr2803/src/eventsource.cpp:71
 CompEventSource::callback (this=<optimized out>) at /build/buildd/compiz-0.9.5.94+bzr2803/src/eventsource.cpp:63

Changed in compiz (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
Omer Akram (om26er) on 2011-09-22
visibility: private → public
Changed in compiz (Ubuntu):
importance: Medium → Critical
Changed in unity:
importance: Undecided → Critical
status: New → Confirmed
tags: added: iso-testing
Changed in compiz (Ubuntu):
status: Confirmed → Triaged
Changed in compiz (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
milestone: none → ubuntu-11.10
tags: added: rls-mgr-o-tracking
tags: removed: bugpattern-needed
tags: added: bugpattern-written
Alessandro Losavio (alo21) wrote :

I have this problem when I close some type of program (like Ubuntu Software Center), via Launcher (Right click > Close).

David Barth (dbarth) wrote :

There should be a fix ready already.

Changed in compiz (Ubuntu Oneiric):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Sam Spilsbury (smspillaz)
Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
Omer Akram (om26er) on 2011-09-24
Changed in unity:
status: Confirmed → Triaged

I just had this crash happen several seconds after closing Thunderbird via the Launcher and minimizing a Document Viewer window, while doing nothing else.

P P (duzy84) wrote :

I run skype and it happened.

Didier Roche (didrocks) on 2011-09-26
Changed in unity:
milestone: 4.18.0 → 4.20.0
pschonmann (pschonmann) wrote :

Occurs when i plugged out mounted Android phone in mass storage mode

Marek Brenčič (jackjack) wrote :

Same as guy before me. Pluged Desire (flash in chromoium,benshee,totem) and then it crashed.

James Clemence (jvc26) wrote :

Also affects me, closed scribus then got this crash.

P P (duzy84) wrote :

I just clicked on windows manager and.... bang.

Robert Carr (robertcarr) wrote :

This is easily reproducible on my system.

Start firefox. Maximize it. Minimize it. Right click in launcher and quit firefox from there. A little prowling and its not obvious how its happening though

Nick Moffitt (nick-moffitt) wrote :

It seems that right-clicking launcher icons is a recurring theme in this bug. I just had it happen to me as I was upgrading: I right-clicked on the update manager (and the menu appeared behind everything, but thats a totally separate bug!) and just after interacting with the menu I got this compiz crash.

Rainer Rohde (rainer-rohde) wrote :

I can confirm the statement made above (#15).

Also, sometimes Thunderbird gets unresponsive and only by wildly alt-tabbing it comes back to live, however, right-clicking and quitting it crashes Compiz with the whole desktop resetting.

Bryce Harrington (bryce) wrote :

Confirmed reproducing it with steps in comment #15

florin (florin-arjocu) wrote :

It did not occur while doing what #15 says, but I confirm I also could reproduce a bug like #15 said. In my reproduction (after the "real" occurrence ), Apport did not start, I had a system hang-out for a second, then the top bar reapeared. It looked like this bug.

Omer Akram (om26er) on 2011-09-28
affects: compiz (Ubuntu Oneiric) → unity (Ubuntu Oneiric)
Changed in unity (Ubuntu Oneiric):
milestone: ubuntu-11.10 → none
milestone: none → ubuntu-11.10
Omer Akram (om26er) on 2011-09-28
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu Oneiric):
status: Triaged → In Progress
Svivi (svivi) wrote :

I just close the Rhythmbox and Compiz crashed.

Diska (discardi-nicola) wrote :

the same after i close totem via unity ( right button on icon in unity and click on quit )

Jason Smith (jassmith) on 2011-09-29
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu Oneiric):
status: In Progress → Fix Committed
Paulo Lopes (jetdrone) wrote :

I got to this bug report after following these steps:

* open a terminal window
* minimizing the window with the minimize button
* the minimize buttons where still visible on the top bar and i clicked the close window
* got this crash

Didier Roche (didrocks) on 2011-09-29
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package unity - 4.20.0-0ubuntu1

---------------
unity (4.20.0-0ubuntu1) oneiric; urgency=low

  * New upstream release + cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #835259)
    - dash does not scroll down during keyboard navigation (LP: #852506)
    - compiz crashed with SIGSEGV in _XFreeEventCookies() (LP: #851472)
    - compiz crashed with SIGSEGV in g_object_unref() (LP: #847512)
    - compiz crashed with SIGSEGV in nux::WindowCompositor::MouseEventCycle()
      (LP: #831678)
    - compiz and X can disagree on the stacking order (LP: #845719)
    - compiz crashed with SIGSEGV in unity::dash::LensView::OnResultAdded()
      (LP: #855252)
    - CCSM crashes Unity (LP: #861643)
    - compiz crashed with SIGSEGV in PrivateWindow::addWindowStackChanges()
      (LP: #862115)
    - Touch - When dragging a window with a 3 touch, dragging to the top
      should show the maximize gesture preview. (LP: #750316)
    - compiz crashed with SIGABRT in raise() (LP: #750386)
    - Launcher - Spread should not affect the state of window (LP: #764673)
    - [UIFe] Add system setting icon to Launcher (LP: #764744)
    - compiz crashed with SIGABRT in raise() [Merely unchecking the Unity
      plugin is enough to crash Compiz...] (LP: #823386)
    - Launcher - does not hide if revealed from top 24px of the left edge of
      the screen (LP: #835989)
    - Clickable areas of previously active window remains on 'Show Desktop'
      (LP: #836325)
    - Cannot search for some apps in Dash (LP: #837075)
    - Dash - Search box cursor not responding correctly to focus (LP: #839704)
    - Multi-display: Application menu only showing on primary screen
      (LP: #845212)
    - Ellipsized values in size filter (LP: #851359)
    - (oneiric) dash result expansions don't display icons (LP: #854615)
    - run the wrong command if enter is hit before the view is refreshed
      (LP: #856205)
    - Java application windows cut-off/truncated/not displayed properly
      (LP: #857201)
    - compiz crashed with SIGSEGV in sigc::signal_base::impl() (LP: #831769)
    - Minimizing a window should switch focus to the windows underneath it
      (breaks restore) (LP: #859885)
    - Ratings filter allows ratings > 1.0 (LP: #861255)
    - Serious Unity problem stuck in spread when dragging icons back to the
      dash (LP: #862045)
    - Must use hardware keyboard to perform search for applications in Unity
      (LP: #739812)
    - Files lens should also search Downloads (LP: #748915)
    - The dash crosses the monitor boundary when resolution is 1152x864 or
      lesser width (LP: #765338)
    - Dash - dragging a file outside of the Desktop Dash should close the Dash
      (LP: #764641)
    - Text in Dash search text box overflows and doesn't crop with longer
      strings; RtL input starts in wrong place (LP: #834765)
    - Where the average background colour is either very light or dark, adjust
      this value to darken/lighten in order to preserve readability
      (LP: #837993)
    - Dash does not resize when I connect to an external display and mirror
      displays (LP: #83813...

Read more...

Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Christer (christer-madsen) wrote :

To me it feels like a Banshee problem.. I have Firefox, Empathy, Gwibber, Banshee playing something, and sometimes Software Center... Banshee suddenly stops playing, and boom compiz crashed!! It happens EVERY time like clockwork! Same thing.. When I'm enjoying music and doing other stuff, I know when the music stops, Banshee has crashed and somehow dragged Compiz down with it.. Or that's what it seems to me anyways! Totally annoying, because most of the open windows have shifted slightly down maybe like 150 pixels from where they were just before the stupid crash....

cande (cande) wrote :

I Had firefox, UbuntuOne and Thunderbird started, and just tried to minimize Thunderbird

d tunthuwa (scorpio711) on 2011-10-18
Changed in unity (Ubuntu Oneiric):
assignee: Sam Spilsbury (smspillaz) → d tunthuwa (scorpio711)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers