Stacked Monitors: missing screen area when lower (low res) monitor is centered under high-res monitor

Bug #842745 reported by Luke Scharf on 2011-09-06
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Unassigned
unity (Ubuntu)
Medium
Unassigned

Bug Description

Big dead-zone and missing screen elements (such as the dock) when a 1366x768 display is centered (using the "monitor preferences" dialog) underneath a 2048x1152 display in a multi-monitor configuration.

To reproduce: Use two monitors of mismatched sizes, with the higher-resolution monitor on the top and the primary (and lower resolution) display on the bottom. Open the "monitor preferences" dialog, and place the higher resolution display on top and put the lower resolution display below, and centered. Observe the missing portions of the GUI and display-area.

Workaround: Align the screens in the "monitor preferences" panel, so that the left sides are flush. Centering the screens (relative to each other), or lining up the right-sides cause the dock to disappear and a portion of the laptop's display to become useless.

I've attached a screenshot to illustrate the problem. It looks OK at a glance, so I'd like to direct your attention to the bottom portion -- the dock is missing (presumably off of the left side of the screen), and the indicator-bar is partially obscured by the dead-zone.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.16-0ubuntu1~natty1
Uname: Linux 2.6.39-02063904-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,gnomecompat,snap,vpswitch,grid,place,imgpng,regex,resize,session,move,mousepoll,unitymtgrabhandles,wall,animation,expo,workarounds,ezoom,staticswitcher,fade,ring,scale,unityshell]
CompositorRunning: compiz
Date: Tue Sep 6 09:06:29 2011
DistUpgraded: Log time: 2011-09-02 11:05:20.927172
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 virtualbox-ose, 4.0.4, 2.6.39-02063904-generic, x86_64: installed
 virtualbox-ose, 4.0.4, 2.6.38-11-generic, x86_64: installed
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Toshiba America Info Systems Device [1179:0005]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
InstallationMedia__: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
MachineType: TOSHIBA PORTEGE R835
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.39-02063904-generic root=UUID=d046bba5-6bff-42e7-ae6e-afcab4507acb ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-09-02 (3 days ago)
dmi.bios.date: 08/06/2011
dmi.bios.vendor: TOSHIBA
dmi.bios.version: Version 3.00
dmi.board.asset.tag: 0000000000
dmi.board.name: Portable PC
dmi.board.vendor: TOSHIBA
dmi.board.version: Version A0
dmi.chassis.asset.tag: 0000000000
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: Version 1.0
dmi.modalias: dmi:bvnTOSHIBA:bvrVersion3.00:bd08/06/2011:svnTOSHIBA:pnPORTEGER835:pvrPT324U-008003:rvnTOSHIBA:rnPortablePC:rvrVersionA0:cvnTOSHIBA:ct10:cvrVersion1.0:
dmi.product.name: PORTEGE R835
dmi.product.version: PT324U-008003
dmi.sys.vendor: TOSHIBA
version.compiz: compiz 1:0.9.4+bzr20110606-0ubuntu1~natty2
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4.1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Luke Scharf (lukescharf) wrote :
Luke Scharf (lukescharf) wrote :
Omer Akram (om26er) on 2011-09-07
tags: added: multimonitor
Changed in unity (Ubuntu):
status: New → Confirmed

I am having similar issues. I have a higher res monitor stacked on my laptop display. I can't drag windows down, they get hung on the top of the laptop display. I get a strange dead invisible window on the top left of my high res display.

Luke Scharf (lukescharf) wrote :

I just upgraded to the Ubutu 11.10 Beta (Oneiric Ocelot), and this issues seems to have been fixed.

Luke Scharf (lukescharf) wrote :

There may still be other issues relating to the stacked monitor configuration, but I can align the monitors to reflect the physical configuration of monitors on my desk, and I can see all of the basic GUI elements I'm supposed to, and I can move the mouse-cursor to visible parts of the display (and only visible parts of the display).

Daniel van Vugt (vanvugt) wrote :

Partly confirmed. I can't reproduce the misplaced indicators, but the launcher will fail to display if it's set to autohide. You need to push the mouse all the way to the virtual left hand side of the largest monitor (still on the small one) before the launcher appears on the small monitor.

WORKAROUND: Configure the Launcher to never hide in CompizConfig Settings Manager.

Changed in unity:
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

Looking at the code, the missing dock (launcher) issue does not look like it is fixed in oneiric either. Both versions of unity for 11.04 and 11.10 appear to use the root mouse pointer location 0 (unity 3) or <= 1 (unity 4) to reveal the launcher. However in the case of this bug we need the launcher to reveal itself when x is much larger than 1 because the small screen starts at an x offset much larger than 1.

Unity 3:
   if (root_x_r == 0)
    self->launcher->EdgeRevealTriggered ();

Unity 4:
  if (pointerX <= 1)
  {
    if (abs(pointerY-self->_edge_pointerY) <= 5)
    {
      self->launcher->EdgeRevealTriggered(pointerX, pointerY);
    }

Luke Scharf (lukescharf) wrote :

I'm seeing the same dock behavior on Oneiric. It had been masked to me, because I had set the dock to always be visible. After I rm'd my compiz-related dot files, I see the same problem with unhiding the dock.

There are a number of problems with the stacked monitor configuration and Unity/compiz. Before blanking my compiz dot files, Compiz was regularly placing windows over the split between the windows, but I haven't captured a video or characterized enough of it to submit a helpful big report. Also, window pickers seem to display all of the windows upside down on the split (I've filed a separate bug report with a screenshot about this one). Also, Compiz crashes regularly in this configuration -- it's getting better, and I've been trying to gather enough information to characterize it in a helpful way.

Jason Smith (jassmith) on 2011-09-23
tags: added: mm-launcher-team
tags: added: mm-window-management
removed: mm-launcher-team
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
David Barth (dbarth) on 2011-09-23
Changed in unity:
importance: High → Medium
Changed in unity (Ubuntu):
importance: High → Medium
Bryce Harrington (bryce) wrote :

Attempted to reproduce this on Ubuntu Precise. Can confirm the issues outlined in the description no longer occur; behavior seems fairly solid now. I routinely run an above/below monitor arrangement and can definitely recall the many problems when centering the small monitor under the larger one, but they seem gone.

In comment #8 it sounds like there might be some other issues remaining, but those need to be tested on Precise and if reproducible should be filed as new bug reports.

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Bryce Harrington (bryce) on 2011-12-20
Changed in unity:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints