Dash very slow with blur in Oneiric beta1[ATI report]

Bug #841527 reported by manny on 2011-09-05
114
This bug affects 23 people
Affects Status Importance Assigned to Milestone
Unity
Invalid
High
Jay Taoko
Unity Distro Priority
High
Unassigned
unity (Ubuntu)
High
Jay Taoko

Bug Description

in natty all the way to oneiric alpha3 dash speed was good, but now with the new blur introduced just before the beta, it is slow and hardly browse-able in my computer. It even locks up sometimes...

ATI radeon x1250 (open drivers)

probably due to the open drivers not totally supporting the blur...

on another computer i have with intel card, dash is ok.

while it looks better with the eye candy, speed is priority over looks. Specially on something that is used frequently like the dash.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.12.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic i686
Architecture: i386
BootLog:
 fsck from util-linux 2.19.1
 /dev/sda8: clean, 158631/1406272 files, 806511/5620726 blocks
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
Date: Mon Sep 5 00:06:08 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
GraphicsCard:
 ATI Technologies Inc RS690M [Radeon X1200 Series] [1002:791f] (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Device [1025:0123]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110901)
MachineType: Acer Extensa 4420
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-10-generic root=UUID=f6401f77-e849-469f-b05d-044a839154a4 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/11/2008
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: V1.18
dmi.board.name: Extensa 4420
dmi.board.vendor: Acer
dmi.board.version: Rev
dmi.chassis.asset.tag: None
dmi.chassis.type: 1
dmi.chassis.vendor: Acer
dmi.chassis.version: None
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrV1.18:bd06/11/2008:svnAcer:pnExtensa4420:pvr0100:rvnAcer:rnExtensa4420:rvrRev:cvnAcer:ct1:cvrNone:
dmi.product.name: Extensa 4420
dmi.product.version: 0100
dmi.sys.vendor: Acer
version.compiz: compiz 1:0.9.5.92+bzr2791-0ubuntu1
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

manny (estelar57) wrote :
Changed in unity (Ubuntu):
status: New → Confirmed
manny (estelar57) wrote :

similar bug here:

https://bugs.launchpad.net/ubuntu/+source/unity/+bug/824890

it says it was "fixed" before the beta, but some of us are still experiencing it.

Dash blur works nicely with Intel i915 and Nvidia GTX 570 but this Radeon X1300 is painfully slow.

manny (estelar57) wrote :

no blur option seems to improve speed, but i still feel it slower than on natty...

Pavel Rojtberg (rojtberg) wrote :

it must be unitys blur implementation, as there are no performance issues when using the blur compiz plugin..

Didier Roche (didrocks) on 2011-09-30
Changed in unity:
status: New → Confirmed
Danillo (danillo) wrote :

Blur is terrible also on an Intel GM965 with Unity 4.20.0 in Oneiric Beta 2.

Isn't this a duplicate of bug #824890?

manny (estelar57) wrote :

@danillo

this bug is mostly for ATI owners, since on my intel hardware it was running fine, but they should be related.

manny (estelar57) on 2011-10-03
summary: - Dash very slow with blur in Oneiric beta1
+ Dash very slow with blur in Oneiric beta1[ATI report]
Pavel Rojtberg (rojtberg) wrote :

using the current xorg-edgers mesa drivers this issue is gone. So I guess it is a driver bug, but I cant point to a specific commit..

Jendrik Seipp (jendrikseipp) wrote :

Same issue still occurs on Precise alpha 2 with unity5.2.0. Dash is very slow with ATI Radeon 3650 and open driver.

Omer Akram (om26er) wrote :

We should consider blacklisting such GPUs so that they fallback to Unity2d

Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High

Wouldn't it suffice to remove the blur for old GPUs?

David Barth (dbarth) wrote :

@jaytaoko: there will always been slow machines, so there is no need trying to optimize the blur for low-end HW (including my own thinkpad). Either the blur can run with them, or
1. de-activate upon detecting a slow machine
2. blacklist those GPUs and default to 2D.

WDYT?

Changed in unity:
assignee: nobody → Jay Taoko (jaytaoko)
milestone: none → 5.6.0
Changed in unity (Ubuntu):
assignee: nobody → Jay Taoko (jaytaoko)
Jay Taoko (jaytaoko) wrote :

If it is only slow because of the blur. It can be deactivated in CCSM:
    Ubuntu Unity Plugin > Experimental tab > Set "Dash Blur" to "No Blur"

The consequences of blacklisting is that some systems will fall back to Unity 2D. Something I am not sure all the owners of such systems want.

I have a Radeon X1950 pro that I can plug and see how it behaves with Precise right now. I will report here.

Tim Penhey (thumper) on 2012-02-20
tags: added: distro-priority
Didier Roche (didrocks) on 2012-02-20
Changed in unity-distro-priority:
status: New → Fix Committed
importance: Undecided → High
Pavel Rojtberg (rojtberg) wrote :

I still think that one should look at the blur code before blacklisting. Blur should perform good on any GL 2.0+ hardware. And if it does not there must be a bug in the blur code.
As I previously said - the blur plugin provided by compiz runs fine on the same hardware where the Unity Blur fails.
Even if you "fix" the performance issue by throwing faster hardware at it, you still have higher power consumption.

Jay Taoko (jaytaoko) wrote :

I have tested with a Radeon X1950 Pro. This one use the open source driver as it is no longer supported by fglrx. I couldn't notice performance issue with the blur in the dash.

What we are lacking is a tool that would check the performance of the graphics effects used in Unity. Such a tool is planned but not yet ready.

For now, if you have system that is showing performance issue in the dash, I recommend you turn off "Active Blur" in CCSM or you limit to "Static Blur" or "No Blur".

Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
manny (estelar57) wrote :

for me the situation is much better than before. Not sure other people.

Tested with x1250 and 6310.

performance is ok. Probably the drivers have improved.

The tool for checking the performance seems a good idea. Specially if we find any more regressions in the future.

Didier Roche (didrocks) on 2012-03-15
Changed in unity:
status: Incomplete → Invalid
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: Incomplete → Invalid
Nikola Snele (n-schnelle) wrote :

Enabling "Fix screen updates in XGL with fglrx" in Workarounds seems to help a bit.

I am using mobility radeon hd 2400 with opensource driver.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers