Ubuntu

compiz assert failure: compiz: /usr/include/boost/smart_ptr/shared_ptr.hpp:418: T* boost::shared_ptr<T>::operator->() const [with T = UnityFBO]: Assertion `px != 0' failed.

Reported by Andy Whitcroft on 2011-08-31
346
This bug affects 43 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Critical
Canonical Desktop Experience Team
Oneiric
Critical
Unassigned
Unity
Critical
Unassigned
unity (Ubuntu)
Critical
Canonical Desktop Experience Team
Oneiric
Critical
Canonical Desktop Experience Team
Precise
Critical
Canonical Desktop Experience Team

Bug Description

SRU test case on intel laptop

1. Plug in an external monitor over VGA2
2. Cycle fn+f8 a bunch of times

Unity crashes.

Now install unity from oneiric-proposed see it wont crash

========Original Report==========

It usually happens within 20 cycles, and usually during the external monitor only (internal screen off) to internal monitor only (external off) transition.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity 4.10.2-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-10.15~drmverbosity201108251748-generic 3.0.3
Uname: Linux 3.0.0-10-generic x86_64
Architecture: amd64
AssertionMessage: compiz: /usr/include/boost/smart_ptr/shared_ptr.hpp:418: T* boost::shared_ptr<T>::operator->() const [with T = UnityFBO]: Assertion `px != 0' failed.
CrashCounter: 1
Date: Wed Aug 31 15:08:56 2011
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcCmdline: compiz --replace
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
Signal: 6
SourcePackage: unity
StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 __assert_fail () from /lib/x86_64-linux-gnu/libc.so.6
 UnityScreen::glPaintOutput(GLScreenPaintAttrib const&, GLMatrix const&, CompRegion const&, CompOutput*, unsigned int) () from /usr/lib/compiz/libunityshell.so
 GLScreen::glPaintOutput(GLScreenPaintAttrib const&, GLMatrix const&, CompRegion const&, CompOutput*, unsigned int) () from /usr/lib/compiz/libopengl.so
Title: compiz assert failure: compiz: /usr/include/boost/smart_ptr/shared_ptr.hpp:418: T* boost::shared_ptr<T>::operator->() const [with T = UnityFBO]: Assertion `px != 0' failed.
UpgradeStatus: Upgraded to oneiric on 2011-06-09 (82 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

lp:~smspillaz/unity/unity.fix_864784_868120_872625v2
Merged into lp:unity at revision 1816
Jason Smith (community): Approve on 2012-01-05
Mirco Müller: Pending requested 2011-12-16
Neil J. Patel: Pending requested 2011-12-16
lp:~smspillaz/unity/unity.oem-fixes
Merged into lp:unity/4.0 at revision 1726
Jason Smith (community): Approve on 2012-01-05
Robert Carr: Approve on 2012-01-04
Andy Whitcroft (apw) wrote :

StacktraceTop:
 __GI___assert_fail (assertion=0x7f8ed46b690e "px != 0", file=<optimized out>, line=418, function=<optimized out>) at assert.c:81
 operator-> (this=<optimized out>) at /usr/include/boost/smart_ptr/shared_ptr.hpp:418
 operator-> (this=<optimized out>) at /build/buildd/unity-4.10.2/plugins/unityshell/src/unityshell.cpp:2142
 glPaintOutput (this=<optimized out>, attrib=<optimized out>, transform=<optimized out>, region=<optimized out>, output=<optimized out>, mask=<optimized out>) at /build/buildd/unity-4.10.2/plugins/unityshell/src/unityshell.cpp:671
 UnityScreen::glPaintOutput (this=0x15be500, attrib=..., transform=..., region=..., output=0x103d300, mask=3) at /build/buildd/unity-4.10.2/plugins/unityshell/src/unityshell.cpp:662

Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2011-09-12
visibility: private → public
tags: added: bugpattern-needed
Didier Roche (didrocks) on 2011-09-30
Changed in unity:
status: New → Confirmed
Didier Roche (didrocks) on 2011-09-30
Changed in unity (Ubuntu):
importance: Medium → Critical
Alistair Buxton (a-j-buxton) wrote :

I got this crash when I disabled a monitor with windows on it.

Daan Bos (daanbos) wrote :

Happened to me while switching to TwinView with Nvidia X Server Settings.

Alistair Buxton (a-j-buxton) wrote :

Yeah, I'm using twinview too. Turning it on or off seems to cause the crash.

Changed in unity (Ubuntu Precise):
status: New → Confirmed
Changed in unity (Ubuntu Oneiric):
importance: Critical → High
Changed in unity (Ubuntu Precise):
importance: Undecided → High
Changed in unity (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
milestone: none → oneiric-updates
Changed in unity (Ubuntu Precise):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
tags: added: rls-mgr-p-tracking
tags: removed: bugpattern-needed
tags: added: bugpattern-written
andre (schroedinger) wrote :

Same here: twinview

Robert Hooker (sarvatt) wrote :

Way to reproduce on an intel laptop:

1) Plug in an external monitor over VGA
2) Cycle fn+f8 a bunch of times

It usually happens within 20 cycles, and usually during the external monitor only (internal screen off) to internal monitor only (external off) transition.

Changed in oem-priority:
importance: Undecided → High
Changed in oem-priority:
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
tags: added: blocks-hwcert regression-release
Steve Magoun (smagoun) on 2011-12-15
Changed in oem-priority:
status: New → Confirmed
importance: High → Critical
Omer Akram (om26er) on 2011-12-15
description: updated
Bryce Harrington (bryce) on 2011-12-20
Changed in unity (Ubuntu Precise):
status: Confirmed → Triaged
tags: added: precise
Omer Akram (om26er) on 2012-01-03
Changed in unity:
importance: Undecided → Critical
Changed in unity (Ubuntu Oneiric):
importance: High → Critical
Changed in unity (Ubuntu Precise):
importance: High → Critical
David Barth (dbarth) on 2012-01-05
Changed in unity:
milestone: none → 4.28.0
status: Confirmed → Fix Committed
Omer Akram (om26er) on 2012-01-05
Changed in unity:
status: Fix Committed → Fix Released
Omer Akram (om26er) on 2012-01-05
description: updated
David Barth (dbarth) on 2012-01-12
tags: added: rls-p-tracking
Changed in unity (Ubuntu Precise):
milestone: none → precise-alpha-2

Hello Andy, or anyone else affected,

Accepted unity into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity (Ubuntu Oneiric):
status: Confirmed → Fix Committed
tags: added: verification-needed
CmaJ (matutet) wrote :

After installing unity 4.28.0 "SRU2" from the "proposed" repositories on my Ubuntu 11.10, it works for me. :)

Great job.

Omer Akram (om26er) on 2012-01-16
tags: added: verification-done
removed: verification-needed
Omer Akram (om26er) wrote :

fix is already in Precise/

Changed in unity (Ubuntu Precise):
status: Triaged → Fix Released
Tim Chen (ctf) on 2012-01-17
tags: added: lab-taipei
Steve Magoun (smagoun) on 2012-01-23
Changed in oem-priority:
status: Confirmed → Fix Committed
Changed in oem-priority:
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.28.0-0ubuntu2

---------------
unity (4.28.0-0ubuntu2) oneiric-proposed; urgency=low

  * Cherry-pick some additional fixes:
    - fix a regression where transparency is setup on the panel (LP: #830949)
    - the wrong commit causing a crash was revert. Revert the revert and
      revert the right guilty commit.

unity (4.28.0-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release.
    - don't segfault in geis_configuration_get_value() (lp: #850623)
    - get focus on dash by pressing the super key first time after login
      (lp: #860805)
    - clicking on panel when dash is open no longer causes maximized window
      to raise (lp: #873100)
    - window management, alt-tab - After using 'show desktop' to minimise all
      windows, opening any new window also incorrectly restores all
      the minimised windows (lp: #871801)
    - compiz crashed with SIGSEGV in
      unity::switcher::SwitcherModel::DetailSelectionWindow() (lp: #834630)
    - compiz crashed with SIGSEGV in g_strcmp0() (lp: #832151)
    - compiz crashed with SIGSEGV in nux::BaseWindow::GetInputWindowId()
      (when onboard is used) (lp: #865890)
    - fix multi-monitor crashers (lp: #838128, #864037, #864784, #868120)
    - Fix SIGSEGV after SwitcherController desctruction (lp: #887465)
    - Fix for "right-clicking launcher when choosing a workspace causes
      quicklists to freeze" (lp: #791810)
  * debian/patches/add_postrelease_buildfix.patch:
    - add post-release fix to build in a clean env
  * backport some additional reverts or regression fixes
 -- Didier Roche <email address hidden> Thu, 19 Jan 2012 09:54:44 +0100

Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Chris Van Hoof (vanhoof) on 2012-01-30
Changed in oem-priority:
status: Fix Committed → Fix Released
To post a comment you must log in.