Horizontally scrolling while highlighting an item in the dash or on an indicator will open the item.

Bug #837004 reported by jhfhlkjlj on 2011-08-29
54
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
Undecided
Andrea Azzarone
Unity
Fix Released
Undecided
Unassigned
nux (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

I'm on a laptop. When I try and two-finger scroll down the listed page with my cursor over an icon it will open the item as if I'm clicking it. This is because horizontal clicking is easier to activate in two-finger scrolling mode.

Steps to reproduce:
1. Open Unity Dash
2. Go to the Applications Dash
3. Expand 'Installed Results' so that the scrollbar appears on the right.
4. Move your pointer over an icon, and scroll horizontally.
5. Notice that the icon gets activated as if you had clicked it.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.10.2-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-9.14-generic 3.0.3
Uname: Linux 3.0.0-9-generic x86_64
Architecture: amd64
CasperVersion: 1.279
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,resize,fade,unitymtgrabhandles,scale,session,unityshell]
Date: Mon Aug 29 17:13:45 2011
LiveMediaBuild: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110828)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

description: updated
Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

A video of the problem would also be very useful if possible.

Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete

"Happens with 100 percent reproducibility."

And this is just simply trying to scroll down the dash results on my trackpad. I would love to make a video for you guys but gtk-recordmydesktop is in such horrible shape that nothing remotely viewable is made from it. If you can suggest a working screen recorder I'd be happy to demonstrate but as it stands now I'd have to use a video camera (which I don't have access to at the moment).

Aha, a caped stranger flew through the window with an Android phone! I present the bug in WebM format! (Since the ogg encoder wasn't working for me...)

Changed in unity:
status: Incomplete → New
Changed in unity (Ubuntu):
status: Incomplete → New
Cobo (geracobo) wrote :

This happens to me as well, 100% of the time.
It does not happen in Unity 2D though.

the issue here is that applications are also launched with the middle
click in the dash, when scrolling really fast you endup making a
middle click so the issue basically is that middle click is causing
the problem and should probably not launch the app, could anyone in
this bug report also confirm that?

Well, it is true that middle click launches an application in Unity, and not in Unity 2D. But I don't think that's the problem since I use two-finger scrolling with my touchpad, and I don't think that causes a middle click event to be fired.

Cobo (geracobo) wrote :

The two-finger scrolling thing got me thinking, so I tried changing the scroll method to edge scrolling, and it stopped happening.
The problem, at least on my laptop, appears to be that tapping the touchpad with two fingers produces a right click, which also launches the icon.

Something's changed though, it used to open multiple instances of the same app the instance I scrolled, but now it looks like I can scroll a little over icons, but if I make an effort to scroll multiple times over an icon, it opens the app, making it more evident that the problem is caused by tapping with two fingers. I don't remember updating after the last time I checked if this still happened so I'm not sure what 'fixed' it.

For the record, I have tap-to-click disabled. This is a legit scroll. I remember Natty having a bug where scrolling with the same trackpad on the sound indicator would sometimes "click". So perhaps this isn't a bug in unity but xorg inputs itself!

Updates have also changed the behavior a little bit for me as well. Sometimes I can scroll but often it will still launch the application.

Changed in unity (Ubuntu):
status: New → Confirmed
Eylem (eylemkoca) wrote :

I too can confirm that this happens 100% of the time with two-finger scrolling.

Didier Roche (didrocks) on 2011-09-30
Changed in unity:
status: New → Confirmed
sharpkiddie (mark-eurogamer) wrote :

I can also confirm that two finger scrolling (with tap to click disabled) launches applications from the dash. If I switch to edge scrolling, it's fine.

Chow Loong Jin (hyperair) wrote :

I suspect this is the same as bug #880497 which arises from horizontal scrolling, as it is really easy to accidentally scroll horizontally while using two-finger scrolling. Could you check if that is the case?

Go into Mouse and Touchpad settings, and under Scrolling, select Two-finger scrolling and uncheck "Enable horizontal scrolling". Then try reproducing this bug.

You are completely correct. This is due to horizontal scrolling. Disabling this removes the bug.

I shall consolidate the two bug reports, marking yours as a dupe since it's older and has less info. Thanks so much for figuring this out :)

description: updated
summary: - Scrolling while highlighting an item in the dash will open the item.
+ Horizontally scrolling while highlighting an item in the dash will open
+ the item.

I just realized: This is the same bug I reported during the lucid cycle in a different incarnation. Scrolling horizontally on the INDICATORS also regards as a click (like scrolling on the volume indicator to quickly change volume). It was bug 728865.

I'm marking that as a dupe of this one as it has less information/subscribers.

summary: - Horizontally scrolling while highlighting an item in the dash will open
- the item.
+ Horizontally scrolling while highlighting an item in the dash or on an
+ indicator will open the item.
Andrea Azzarone (azzar1) on 2011-11-13
Changed in nux:
status: New → Confirmed
Andrea Azzarone (azzar1) on 2011-11-22
Changed in unity:
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Changed in nux:
status: Confirmed → In Progress
assignee: nobody → Andrea Azzarone (andyrock)
Didier Roche (didrocks) on 2011-11-22
Changed in nux (Ubuntu):
status: New → In Progress
Andrea Azzarone (azzar1) on 2011-11-29
Changed in nux:
status: In Progress → Fix Committed
Changed in nux (Ubuntu):
status: In Progress → Fix Committed
Gord Allott (gordallott) on 2012-01-12
Changed in unity:
status: Invalid → Fix Committed
milestone: none → 5.0.0
Didier Roche (didrocks) on 2012-01-12
Changed in nux:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 2.0.0-0ubuntu1

---------------
nux (2.0.0-0ubuntu1) precise; urgency=low

  [ Aurélien Gâteau ]
  * New upstream release:
    - compiz crashed with SIGSEGV in nux::ROProperty<std::string>::operator
      std::string() (LP: #881106)
    - compiz crashed with SIGSEGV in
      nux::WindowCompositor::FindKeyFocusAreaFrom() (LP: #860852)
    - compiz crashed with SIGSEGV in nux::Area::FindKeyFocusArea()
      (LP: #848952)
    - compiz crashed with SIGILL in typeinfo for std::ostream() (LP: #849881)
    - compiz crashed with SIGSEGV in nux::WindowThread::IsInsideLayoutCycle()
      (LP: #864686)
    - Select quicklist items with just one right click (LP: #688830)
    - OnMouseDoubleClick in InputArea isn't working (LP: #708020)
    - Menubar - horizontal scroll over a menu opens it (LP: #775872)
    - Clicking on a dash category header should not give it keyboard focus
      (LP: #905921)
    - Horizontal scroll on maximize/restore window control restores window.
      (LP: #809717)
    - Horizontally scrolling while highlighting an item in the dash or on an
      indicator will open the item. (LP: #837004)
    - compiz crashed with SIGSEGV in free() (LP: #864446)
    - Mouse wheel doesn't works if the mouse pointer is inside dash scrollbar.
      (LP: #888819)
  * debian/rules, debian/control:
    - add nuxabiversion capability as upstream is breaking a lot the ABI
      wasn't bumping the soname. Create a virtual package similar to what
      we already do in compiz to ensure we dep on the right version.
      Remove the makeshlibs override then as not needed anymore.
    - bump to nux 2.0 with new libnux-2.0-0, libnux-2.0-common, libnux-2.0-dev
      packages. Make the necessary changes in .install files as well
    - don't ship anymore the -doc package.
  * debian/nux-tools.install:
    - move the apport file there instead of the -common package to enable
      co-instability
 -- Didier Roche <email address hidden> Fri, 13 Jan 2012 09:04:48 +0100

Changed in nux (Ubuntu):
status: Fix Committed → Fix Released

Any chance to have this package in Ubuntu 11.10 too??

2012/1/13 Launchpad Bug Tracker <email address hidden>

> This bug was fixed in the package nux - 2.0.0-0ubuntu1
>
> ---------------
> nux (2.0.0-0ubuntu1) precise; urgency=low
>
> [ Aurélien Gâteau ]
> * New upstream release:
> - compiz crashed with SIGSEGV in nux::ROProperty<std::string>::operator
> std::string() (LP: #881106)
> - compiz crashed with SIGSEGV in
> nux::WindowCompositor::FindKeyFocusAreaFrom() (LP: #860852)
> - compiz crashed with SIGSEGV in nux::Area::FindKeyFocusArea()
> (LP: #848952)
> - compiz crashed with SIGILL in typeinfo for std::ostream() (LP:
> #849881)
> - compiz crashed with SIGSEGV in
> nux::WindowThread::IsInsideLayoutCycle()
> (LP: #864686)
> - Select quicklist items with just one right click (LP: #688830)
> - OnMouseDoubleClick in InputArea isn't working (LP: #708020)
> - Menubar - horizontal scroll over a menu opens it (LP: #775872)
> - Clicking on a dash category header should not give it keyboard focus
> (LP: #905921)
> - Horizontal scroll on maximize/restore window control restores window.
> (LP: #809717)
> - Horizontally scrolling while highlighting an item in the dash or on an
> indicator will open the item. (LP: #837004)
> - compiz crashed with SIGSEGV in free() (LP: #864446)
> - Mouse wheel doesn't works if the mouse pointer is inside dash
> scrollbar.
> (LP: #888819)
> * debian/rules, debian/control:
> - add nuxabiversion capability as upstream is breaking a lot the ABI
> wasn't bumping the soname. Create a virtual package similar to what
> we already do in compiz to ensure we dep on the right version.
> Remove the makeshlibs override then as not needed anymore.
> - bump to nux 2.0 with new libnux-2.0-0, libnux-2.0-common,
> libnux-2.0-dev
> packages. Make the necessary changes in .install files as well
> - don't ship anymore the -doc package.
> * debian/nux-tools.install:
> - move the apport file there instead of the -common package to enable
> co-instability
> -- Didier Roche <email address hidden> Fri, 13 Jan 2012 09:04:48 +0100
>
> ** Changed in: nux (Ubuntu)
> Status: Fix Committed => Fix Released
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/837004
>
> Title:
> Horizontally scrolling while highlighting an item in the dash or on an
> indicator will open the item.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/nux/+bug/837004/+subscriptions
>

Changed in unity (Ubuntu):
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers