Ubuntu

unity-panel-service at 100% cpu when opened /w rb without album cover

Reported by Fabien Tassin on 2011-07-07
80
This bug affects 20 people
Affects Status Importance Assigned to Milestone
The Sound Menu
High
Conor Curran
Unity
Undecided
Unassigned
banshee (Ubuntu)
Undecided
Unassigned
indicator-sound (Ubuntu)
Undecided
Unassigned
rhythmbox (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Constantine

Bug Description

in oneiric, simply click on the sound indicator, unity-panel-service goes to 100% cpu until the sound menu is closed.

unity-services 4.2.0-0ubuntu1
---
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,gnomecompat,commands,vpswitch,resize,snap,mousepoll,regex,move,place,imgpng,session,animation,wall,workarounds,expo,ezoom,staticswitcher,fade,scale,unityshell]
DistroRelease: Ubuntu 11.10
NonfreeKernelModules: nvidia
Package: unity 4.2.0-0ubuntu3
PackageArchitecture: i386
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/usr/bin/tcsh
ProcVersionSignature: Ubuntu 3.0.0-5.6-generic 3.0.0-rc7
Tags: unity-2d oneiric running-unity
Uname: Linux 3.0.0-5-generic i686
UpgradeStatus: Upgraded to oneiric on 2011-05-09 (66 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare wireshark

Fabien Tassin (fta) wrote :

it seems to happen when Rhythmbox is opened and there's no cover for the current album.

Paolo Rotolo (paolorotolo) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 806848
When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Changed in unity (Ubuntu):
status: New → Incomplete
Fabien Tassin (fta) wrote :

Still happening, with everything up-to-date.
it's trivial to reproduce, as I said in #2.

When I attach gdb to unity-panel-service and reproduce, the stack always shows the gtk3 menu at various stages of being redrawn. So it seems the redraw is invoked too fast when there's no cover to show in the sound menu.

apport information

tags: added: apport-collected oneiric running-unity unity-2d
description: updated

apport information

Changed in unity (Ubuntu):
status: Incomplete → New
summary: - unity-panel-service at 100% cpu when opened
+ unity-panel-service at 100% cpu when opened /w rb without album cover
Omer Akram (om26er) wrote :

@fta, is this still an issue? I faced it once few weeks ago and have not seen it after, Could you confirm if its still happening

Fabien Tassin (fta) wrote :

no idea. TBH, I no longer care about this bug and about unity* in general, I moved to gnome-shell where I can use everything I want without freezing X, hogging my CPU or sucking all my RAM. At last I can work without restarting my desktop every day and enjoy the full h/w acceleration in all the apps supporting it.

Omer Akram (om26er) wrote :

assuming this as fixed though I believe it might have been something in the SoundMenu

Changed in unity:
status: New → Invalid
Changed in unity (Ubuntu):
status: New → Invalid
Vincenzoml (vincenzoml) wrote :

This is still an issue in oneiric fully up-to-date. I do not have that much time but maybe I can help.

Changed in unity:
status: Invalid → Confirmed
Changed in unity (Ubuntu):
status: Invalid → Confirmed

This is not just about the 100% CPU usage. Unity-panel-service increases memory usage by 2MB every second you leave the sound menu open after you pause rhythmbox. This is in addition to the, in my case, 75% to 85% CPU usage.

I stopped the music and left the computer for a while with the soundmenu opened. When I came back unity-panel-service using 1.6 GB of RAM. I had to kill it from a virtual terminal to make the system responsive again.

Here's how I reproduce it.

1) Open system monitor or top and sort by memory usage
2) Open soundmenu and start Rhythmbox from there.
3) Press play in the soundmenu to start a song
4) Press pause in the soundmenu

Now while soundmenu is open, unity-panel-service memory usage increases at a 2MB per second rate and it never goes down, not even closing rhythmbox or soundmenu.

Artyom Gavrichenkov (ximaera) wrote :

Either this has nothing to do with Rhytmbox or the bug #877758 is not a duplicate of this one. unity-panel-service sometimes takes 100% CPU when no music player is running and I'm trying to open network menu. I don't even have Rhytmbox installed.

Artyom Gavrichenkov (ximaera) wrote :

I've tried to reproduce this behaviour with Banshee and Exaile, and it didn't work this way. However, unity-panel-service sometimes hangs on my machine as well, but I can't reproduce it.

Here's a video of my desktop where you can see unity-panel-service memory going up and using 70-80% CPU while the soundmenu is open.

http://ubuntuone.com/2lFBvyiFkPUGcMOjQKmzXt

Omer Akram (om26er) on 2011-10-25
Changed in indicator-sound (Ubuntu):
status: New → Confirmed
Changed in rhythmbox (Ubuntu):
status: New → Confirmed

The same happens with Banshee.
I can reproduce the 100% CPU usage and the memory leak with Banshee. I'm running the latest unity updates.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in banshee (Ubuntu):
status: New → Confirmed
affects: banshee → banshee (Ubuntu)
Changed in banshee (Ubuntu):
status: New → Confirmed
Chow Loong Jin (hyperair) wrote :

I don't think Banshee's at fault here. And probably not Rhythmbox either. Both of them just implement the MPRIS2 interface and let the sound menu take care of that. If anything, it's indicator-sound or unity. I'm marking the Banshee task as invalid.

Changed in banshee (Ubuntu):
status: Confirmed → Invalid
timuckun (timuckun) wrote :

Unity panel service hits' 100% CPU on my machine on seemingly random intervals. It seems to happen often after it wakes up from sleep

Pedro Villavicencio (pedro) wrote :

not a rhythmbox issue, probably the indicator is causing the problem there.

Changed in rhythmbox (Ubuntu):
status: Confirmed → Invalid

Still happens with precise pangolin alpha (32 bits) with rhythmbox when the album cover is missing. CPU does not get to 100%, just 70% and memory does not grow as fast, maybe because this is a 32 bit platfrorm. I was also affected in a 64 bit Oneiric.

doken (doken) wrote :

Has happened to me with Banshee, Rhythmbox and Amarok, either independently or running together, when any of them does not have cover art. On 64bit 11.10.

Conor Curran (cjcurran) on 2012-03-13
Changed in indicator-sound:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Conor Curran (cjcurran)
milestone: none → 0.8.4.0
milestone: 0.8.4.0 → none
status: Triaged → Confirmed
Conor Curran (cjcurran) on 2012-03-14
Changed in unity:
status: Confirmed → Invalid
Changed in indicator-sound:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Changed in indicator-sound:
milestone: none → 0.8.4.0
Conor Curran (cjcurran) wrote :

Debugged this today thoroughly. It seems I am getting repeated draw signals from GTK. i.e. my expose method is being called repeatedly by GTK. I am not constantly queuing draw calls as first suspected. Will try to initially fix this from the GTK side, if all else fails I will try to attempt to ignore the irrelevant expose calls.

When there is album art expose is called excessively too but I filter/ignore a large set of these by comparing the album art path with what is current on display.

When there is no album art everytime a new image is prepared using pango => expensive.

Changed in indicator-sound (Ubuntu):
status: Confirmed → In Progress
Constantine (fe-pavel) on 2012-03-15
Changed in unity (Ubuntu):
assignee: nobody → Constantine (fe-pavel)
Charles Kerr (charlesk) on 2012-03-15
Changed in indicator-sound:
status: In Progress → Fix Committed
Conor Curran (cjcurran) on 2012-03-16
Changed in indicator-sound:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 0.8.4.0-0ubuntu1

---------------
indicator-sound (0.8.4.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - indicator-sound "Choose Playlist" menu item does nothing when using
      Rhythmbox (LP: #952550)
    - crashed with SIGSEGV in g_strdup() (LP: #946607)
    - crashed with SIGABRT in pa_operation_unref() (LP: #944148)
    - crashed with signal 5 in g_type_create_instance() (LP: #921755)
    - slider on unmute resets volume (LP: #921065)
    - play controls not exposed in HUD (LP: #949032)
    - unity-panel-service at 100% cpu when opened /w rb without album
      cover (LP: #806848)
 -- Ken VanDine <email address hidden> Fri, 16 Mar 2012 14:04:30 -0400

Changed in indicator-sound (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers