Dual-Screen setup broken in Unity (natty)

Bug #791660 reported by Jesse Matties on 2011-06-02
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
New
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

With this same configuration in 10.10, everything worked beautifully. On a fresh install of 11.04, dual-screen has not worked.
The Monitor is detected fine, and the correct resolution is available, however only the top Unity bar shows on the external display; the rest is black. The mouse works everywhere on both screens, but the top portion of the main laptop screen is black. When dragging windows into the black area on either screen, the window disappears, but the mouse remains.

The monitor is connected with a VGA cable.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xorg 1:7.6+4ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: wl
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,imgjpeg,compiztoolbox,decor,regex,animation,workarounds,grid,gnomecompat,text,commands,obs,snap,imgsvg,move,resize,imgpng,scale,unitymtgrabhandles,place,expo,vpswitch,mousepoll,session,ezoom,staticswitcher,wall,unityshell]
CompositorRunning: compiz
DRM.card0.DP.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI.A.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1366x768
 edid-base64: AP///////wAGrzwWAAAAAAETAQOAHxF4CsilnldUkiaZUFQAAAABAQEBAQEBAQEBAQEBAQEBEhtWRlAAIzAmFjYANa0QAAAYAAAADwAAAAAAAAAAAAAAAAAgAAAA/gBBVU8KICAgICAgICAgAAAA/gBCMTQwWFcwMSBWNiAKABs=
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: Off
 modes: 1280x1024 1280x1024 1280x960 1280x960 1280x960 1152x864 1152x864 1152x864 1024x768 1024x768 1024x768 832x624 800x600 800x600 800x600 800x600 640x480 640x480 640x480 640x480 720x400
 edid-base64: AP///////wAEcnBXwQEAAAsPAQNtIht46iQfoVpJmSUaTFW/7wBxQHFKcU+BQIFKgU+BgAEBMCoAmFEAKkAwcBMAUg4RAAAeAAAA/wBFVEwyMTAyMjA4CiAgAAAA/QAxSxhQDgAKICAgICAgAAAA/ABBY2VyIEFMMTcxNQogAFM=
Date: Wed Jun 1 23:32:17 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 bcmwl, 5.100.82.38+bdcom, 2.6.38-8-generic, x86_64: installed
 acpi_call, 1.0, 2.6.38-8-generic, x86_64: installed
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Toshiba America Info Systems Device [1179:fd80]
 nVidia Corporation GT216 [GeForce GT 330M] [10de:0a2b] (rev ff) (prog-if ff)
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
MachineType: TOSHIBA Satellite M645
ProcEnviron:
 LANGUAGE=en_CA:en
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=14375327-5315-4a6f-8591-dd386808f581 ro quiet splash
Renderer: Unknown
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/30/10
dmi.bios.vendor: TOSHIBA
dmi.bios.version: 1.70
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: NBQAA
dmi.board.vendor: TOSHIBA
dmi.board.version: 1.00
dmi.chassis.asset.tag: *
dmi.chassis.type: 9
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnTOSHIBA:bvr1.70:bd12/30/10:svnTOSHIBA:pnSatelliteM645:pvrPSMPMU-01201W:rvnTOSHIBA:rnNBQAA:rvr1.00:cvnTOSHIBA:ct9:cvrN/A:
dmi.product.name: Satellite M645
dmi.product.version: PSMPMU-01201W
dmi.sys.vendor: TOSHIBA
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Jesse Matties (jmatties) wrote :
Jesse Matties (jmatties) on 2011-06-02
description: updated
Robert Roth (evfool) on 2011-06-02
affects: ubuntu → unity (Ubuntu)
Omer Akram (om26er) on 2011-06-02
tags: added: multimonitor
Jesse Matties (jmatties) on 2011-06-02
description: updated
Dinesh (linux-future) wrote :

I am experiencing the same issue. I am attaching a screenshot to show this symptom. My setup is: 1280x800 (left) and 1680x1050 (right). The hardware I am running on is Lenovo x200 tablet (left) and Dell 2209wa (right). The system is fully updated. I believe this might be a regression.

Dinesh (linux-future) wrote :

Here are the packages on my system:

ii unity 3.8.14-0ubuntu1~natty1 Interface designed for efficiency of space and interaction.
ii unity-asset-pool 0.8.20-0ubuntu2 Unity Assets Pool
ii unity-common 3.8.14-0ubuntu1~natty1 Common files for the Unity interface.
ii unity-place-applications 0.2.46-0ubuntu3 Application place for unity
ii unity-place-files 0.5.46-0ubuntu5.1 File place for unity

Dinesh (linux-future) on 2011-06-14
summary: - Unity Dual-Screen
+ Dual-Screen setup broken in Unity (natty)
Mikko Kortelainen (kortsi) wrote :

Also affects me on a ThinkPad X220 with 1366x768 internal display on the left and an LG L1953HR 1280x1024 on the right. Only mouse and top bar visible in the external display. Switching left and right screens looks a little bit different. The mouse works in the black area if you can guess where to click.

I am attaching a couple of screenshots.

Dinesh (linux-future) wrote :

Hello, its been about 10 days and no activity on this bug. Can we escalate it ? I have tried bringing this bug up in the ubuntu irc channel but nobody responded. Are we missing any details? How do we get this prioritized / fixed? Devs?

Bilal Akhtar (bilalakhtar) wrote :

I've marked bug #795458 as the master bug of this one. It seems that the fix to that bug in Unity 3.8.16 (which will hit updates soon) fixes this bug. I had this issue with unity 3.8.14 but installing 3.8.16 from the proposed repository fixes the issue.

Dinesh (linux-future) wrote :

Bilal, thank you for highlighting the correct bug. Glad to see it fixed. I will try it out and comment if it worked for me.

Dinesh (linux-future) wrote :

I tested this with unity 3.8.16. It's fixed for me on Lenovo x200 tablet.

> I tested this with unity 3.8.16. It's fixed for me on Lenovo x200
> tablet.

Gald to hear that :-)

To post a comment you must log in.