Sometimes dragging down from the panel just stops working

Bug #774121 reported by Greg A on 2011-04-30
46
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Marco Trevisan (Treviño)
unity (Ubuntu)
Low
Marco Trevisan (Treviño)

Bug Description

Binary package hint: unity

This is the same as Bug #750155 I think, but that one is marked as fixed and I'm still seeing this.

Haven't got a way of reproducing it at the moment, but if I find one I'll let you know.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.12-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,resize,regex,vpswitch,move,animation,imgpng,mousepoll,grid,unitymtgrabhandles,gnomecompat,place,workarounds,wall,wobbly,expo,ezoom,staticswitcher,session,fade,scale,unityshell]
Date: Sat Apr 30 14:42:54 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110127)
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-04-19 (10 days ago)

Related branches

Greg A (etulfetulf) wrote :
Greg A (etulfetulf) wrote :

Note that when this happens I can no longer drag any maximised windows (it's not just a single window that refuses to drag). Unmaximised windows can be moved as normal. Also worth saying that I can drag the maximised window if I hold Alt and drag it's body.

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

 * Is this reproducible?
 * If so, what specific steps should we take to recreate this bug?

 This will help us to find and resolve the problem.

Changed in unity:
importance: Undecided → Low
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

could you describe the bug there or at least copy the description rather than pointing to another bug which breaks reading of the description by email or force to load another bug just to know what this one is about?

Changed in unity (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Greg A (etulfetulf) wrote :

I haven't got a reproduceable test case yet (the other bug did, and the case in question has been fixed).

The only other description from that bug is "It's like the dragging code doesn't receive any events". This is about dragging maximised windows "down from the panel" to unmaximise them.

Changed in unity:
status: Incomplete → New
Changed in unity (Ubuntu):
status: Incomplete → New
Omer Akram (om26er) wrote :

I too see this problem on certain occasions though don't have the exact steps. I'll try to find a few steps to reproduce this problem.

Alex Launi (alexlauni) on 2011-05-03
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Egor Yakubov (egor-j-94) wrote :

This proplem appears when you close maximized application, which is minimizing to indicator area. I've got such problem with Deluge and evolution-indicator from https://launchpad.net/~goehle/+archive/goehle-ppa.

DeadVirus (amfcosta13) wrote :

Why this bug has low priority? It is really annoying and happens a lot! I have to keep apps that minimize to indicator area in a window mode because of this.

Ok, it seems reproducible to me.

1) Install deluge-gtk, in its options enable the appindicator and minimize in app-indicator
2) Open deluge, put it fullscreen, close it (to send it to appindicator)

Now it's impossible to drag any window *util* you don't re-map deluge and you don't restore it.

Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Omer Akram (om26er) on 2011-09-09
Changed in unity:
milestone: none → 4.16.0
Didier Roche (didrocks) on 2011-09-15
Changed in unity:
milestone: 4.16.0 → 4.18.0
Neil J. Patel (njpatel) on 2011-09-26
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-09-26
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 4.18.0-0ubuntu1

---------------
unity (4.18.0-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - Screen corruption when resuming from suspend/hibernate (LP: #676166)
    - unity-panel-service crashed with SIGSEGV in bamf_factory_view_for_path()
      (LP: #764024)
    - Dash and launcher appear underneath windows (LP: #805087)
    - unity-panel-service crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #811401)
    - [Oneric] unity-panel-service crashed with SIGSEGV in getenv()
      (LP: #817691)
    - compiz crashed with SIGSEGV in unity::FilterBar::RemoveFilter()
      (LP: #845732)
    - crash on closing a window (LP: #856015)
    - Cannot open a window that starts iconified (LP: #732997)
    - Launcher - When useing Alt F1 launcher keyboard navigation, Launcher
      should not scroll until top or bottom of Launcher is reached
      (LP: #765749)
    - Stacking problem when switching between apps with multiple windows
      (LP: #802527)
    - Pull panel to de-maximize window occasionally not working in a secondary
      screen (LP: #802651)
    - Window under Dash gets focused if it opened later (LP: #830730)
    - Clickable areas of previously active window remains on 'Show Desktop'
      (LP: #836325)
    - A minimized window 'remains' behind on the desktop if
      /apps/compiz-1/plugins/unityshell/screen0/options/show_minimized_windows
      is set to true (LP: #847967)
    - a11y support on Unity is broken (LP: #851103)
    - compiz crashed with SIGSEGV in dee_model_get_tag() (LP: #840758)
    - crash when looping paint list in preparePaint (on closing windows)
      (LP: #853807)
    - Alt-Tab should not preview windows at excessively large sizes
      (LP: #854740)
    - Clicking on a tweet/message link sometimes does not work (LP: #790565)
    - Dragging a launcher icon makes it squashed (LP: #855761)
    - unable to unminimize gedit windows where more than one window where one
      has a dialog open (LP: #856030)
    - (oneiric) alt-tab UX doesn't work well on multi-monitor (LP: #855364)
    - Launcher shows on the primary monitor instead of the left most monitor
      (LP: #857668)
    - Keynav - pressing down key causes launcher items to jump up and down
      (LP: #858469)
    - Windows creep cross the screen with ALT+TAB (LP: #722830)
    - Minimize animation flickr when for maximized apps (LP: #737125)
    - All unity windows are invisible (panel, launcher, dash) (LP: #745996)
    - Dash "See 97 more results" has ~1 second of latency (LP: #731158)
    - Windows cannot be dragged down from panel if banshee closed to sound
      menu (LP: #781215)
    - no menu bar on top, compositing bug? (LP: #806358)
    - Launcher - a spread can accidentally be triggered during the 'dragging
      and dropping behind the Launcher' interaction (LP: #832988)
    - Impossible to navigate between panel menus when the mouse cursor is over
      the panel (LP: #834065)
    - Pressing alt on maximized window does show menu but not window controls
      (LP: #836274)
    - Application name drawn under Dash controls when window opens under Dash
      (LP: #838176)
    - Start ...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers