Launcher tooltips sometimes don´t show

Bug #769335 reported by Alistair Buxton on 2011-04-23
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Andrea Azzarone
unity (Ubuntu)
Low
Unassigned
Natty
Low
Unassigned

Bug Description

=== Test case ===

1. Grab unity 3.8.16 from natty-proposed
2. Move mouse over the "Applications" icon on the launcher. A tooltip saying "Applications" appears to the right of the icon.
3. Click the mouse. The Application list appears.
4. Click the mouse again. The application list disappears, but the "Applications" tooltip does not reappear.
5. Move the mouse anywhere on the launcher.
6. Tooltips should be displayed

===

Binary package hint: unity

To reproduce:

1. Move mouse over the "Applications" icon on the launcher. A tooltip saying "Applications" appears to the right of the icon.
2. Click the mouse. The Application list appears.
3. Click the mouse again. The application list disappears, but the "Applications" tooltip does not reappear.
4. Move the mouse anywhere on the launcher. None of the tooltips are displayed.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.10-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
Date: Sat Apr 23 04:25:32 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110422)
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Alistair Buxton (a-j-buxton) wrote :
summary: - Launch tooltips sometimes don´t show
+ Launcher tooltips sometimes don´t show
Mirco Müller (macslow) wrote :

Following your described 4 steps, I can't reproduce this here. I'm using the same unity version (also with an nvidia-based gfx-card using the binary blob-driver on a 64-bit system).

Does this happen everytime you try to trigger it?

For me tooltips appear/change when I move the mouse to a (new) launcher-icon. Clicking the "Applications" icon on the launcher (called "Applications-lense" now btw) does not make its tooltip disappear. Only when I move off of the "Applications-lense" icon the toolip vanishes.

Alistair Buxton (a-j-buxton) wrote :

Yes it is 100% reproducable. See video:

http://www.youtube.com/watch?v=U4ysH_cYydo

Alex Launi (alexlauni) on 2011-05-05
Changed in unity:
status: New → Confirmed
importance: Undecided → Low
Changed in unity (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
tags: added: bitesize
drew212 (mstngdrew212) on 2011-05-09
Changed in unity (Ubuntu):
assignee: nobody → drew212 (mstngdrew212)
status: Confirmed → In Progress
Adolfo Jayme (fitojb) wrote :

I can reproduce it too. Also, if the launcher is set in “autohide” and you have a maximised window below, if you try to do step 4 you can’t because the launcher hides itself. It seems that the launcher, after closing a lens, can’t detect if the mouse still is over itself.

Andrea Azzarone (azzar1) wrote :

@drew212 are you still working on that?

drew212 (mstngdrew212) wrote :

@Andrea Azzarone I have been trying to sift through the code to figure out were this kind of thing is handled. I was hoping to get a mentor to help work on this but haven't had the time. If you feel you can get this done easily feel free to assign yourself.

Andrea Azzarone (azzar1) on 2011-05-28
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: drew212 (mstngdrew212) → Andrea Azzarone (andyrock)
Andrea Azzarone (azzar1) on 2011-05-30
Changed in unity (Ubuntu):
assignee: Andrea Azzarone (andyrock) → nobody
Didier Roche (didrocks) on 2011-05-30
Changed in unity:
status: Confirmed → In Progress
Andrea Azzarone (azzar1) on 2011-06-02
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Andrea Azzarone (azzar1) on 2011-06-02
Changed in unity (Ubuntu):
status: Fix Committed → In Progress
Didier Roche (didrocks) on 2011-06-06
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Neil J. Patel (njpatel) on 2011-06-16
description: updated
Changed in unity:
milestone: none → 3.8.16
Changed in unity (Ubuntu Natty):
importance: Undecided → Low
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.8.16-0ubuntu1

---------------
unity (3.8.16-0ubuntu1) oneiric; urgency=low

  * New upstream version:
    - Unable to load icon text-x-preview at size 48 in a loop (lp: #794556)
    - Display garbled upon restoring original resolution (lp: #795454)
    - Display garbled upon connecting external displays (lp: #795458)
    - Panel disappears after resolution change (lp: #795459)
    - Dragging the launcher with right mouse button is
      confusing as menu pops up (lp: #735031)
    - In a double monitor setup the Unity top panel in the second screen is
      cut at the right (lp: #750481)
    - Launcher tooltips sometimes don´t show (lp: #769335)
    - Menu key should open quicklist for the selected item in the launcher
      (lp: #750778)
    - unity is spamming ~/.xsession-errors when windows are closed
      (lp: #767642)
    - Dash button ignores transparency when clicked. (lp: #767733)
 -- Sebastien Bacher <email address hidden> Thu, 16 Jun 2011 18:10:09 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

reopening the fix created bug #798318 and has been reverted

Changed in unity (Ubuntu Natty):
status: Fix Committed → Triaged
Changed in unity (Ubuntu):
status: Fix Released → Triaged
Changed in unity:
status: Fix Committed → Triaged
Andrea Azzarone (azzar1) on 2011-06-18
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Giovanni Mellini (merlos) wrote :

I can reproduce the bug with 3.8.16-0ubuntu1~natty1
I have the same behavior of Fitoschido on comment #4

Andrea Azzarone (azzar1) on 2011-06-23
Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-06-24
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Omer Akram (om26er) on 2011-07-18
Changed in unity:
status: Fix Committed → Fix Released
Andrea Azzarone (azzar1) on 2011-12-06
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
dino99 (9d9) on 2013-05-18
Changed in unity (Ubuntu Natty):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers