alt+tab broken with click-to-focus off

Bug #762032 reported by Alex Mauer on 2011-04-15
238
This bug affects 51 people
Affects Status Importance Assigned to Milestone
Unity
Invalid
Undecided
Unassigned
compiz (Ubuntu)
Medium
Unassigned
unity (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: unity

If compiz is configured with “Click to Focus” off, then alt+Tab is broken:
* Open a full-screen/maximized application, such as a browser
* Open a normally-windowed application such as a terminal or pidgin’s buddy list
* Move the focus to the browser (alt+tab)
* Keeping the mouse cursor where the windowed application will *not* be, press alt+tab.

Focus will remain with the full-screen app, while it should move to the window switched to by alt+tab.
If in the final step you put the mouse cursor where the windowed application will be after alt+tab, focus changes to the windowed application as expected.

Omer Akram (om26er) wrote :

there is a proposed design by MPT here https://wiki.ubuntu.com/MenuBar#focus-follows-mouse if anyone would like to work on it patches welcome. But as discussed in bug 674138 it is not something Unity dev would like to work on, so people interested in the fix are welcome to work out patches following the design as suggested above.

Changed in unity (Ubuntu):
importance: Undecided → Wishlist
Changed in compiz (Ubuntu):
importance: Undecided → Wishlist
Changed in unity:
status: New → Invalid
Changed in compiz (Ubuntu):
status: New → Invalid
Omer Akram (om26er) wrote :

I think this should be done in compiz so marking unity bugs as invalid.

Changed in unity (Ubuntu):
status: New → Confirmed

Setting bug state as commented by Omer.

Changed in compiz (Ubuntu):
status: Invalid → Confirmed
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Luke Plant (spookylukey) wrote :

This affects me when using "Ubuntu Classic" on Natty i.e. compiz without Unity.

"Alt-tab" is set to trigger the "Next window" action in the "Application Switcher" plugin.

Sometimes the behaviour seems erratic, and it isn't always reproducible.

If I use the "Ring switcher" plugin instead, the behaviour seems much better. This is a reasonable work-around, but the animation of the "Ring switcher" is much more annoying than the normal "Application switcher". The "static application switcher" seems even more broken than "Application switcher"

neels (neels) wrote :

I can confirm Luke Plant's remarks. Using the ring switcher helps restore near usual focus-follows-mouse behavior, but looks slightly annoying.

I am, I must say, quite put off by the direction the ubuntu default configuration is taking with 11.04. It is a slap in the face of people using normal computers and laptops. This bad regression on FFM behavior is one part of that. I've been with ubuntu from the start, am now looking for other distros for the first time. It's that bad... :.(

Ian Forde (ianforde) wrote :

How is this bug a wishlist item rather than a Major Regression? With "Select windows when the mouse moves over them" disabled (aka - focus follows mouse), Alt-Tab is *BROKEN* in 11.04 in Classic mode, whereas in 10.10 and earlier it worked perfectly.

I can understand how this gets past QA before a release, but it's a serious productivity killer for those of us who use it. And it's not like it's an unusual configuration either... I like using Ubuntu. But I'd think that this issue deserves more than "Wishlist" status.

Jan Pfeifer (pfjan) wrote :

I second Ian Forde. This is a major productivity killer.

Whenever I have to use more than one window I have to go back to the mouse: not only a drag but also a major contributor for carpal tunnel syndrome.

Joshua Szmajda (josh-optoro) wrote :

+1. This bug has increased my mouse time dramatically.

Ian Forde (ianforde) wrote :

As an aside, it's not just that it worked in 10.10 and earlier releases. It's worked in virtually *EVERY* UNIX flavor and Linux distro since... well, at least the last decade. Is this being actively looked at? Or is it something that's not considered a priority? IMHO, leaving a major regression unaddressed and unassigned for almost 2 months whilst leaving it in Wishlist status doesn't reflect well upon... well... anything. Is there anything we can do to help get this more noticed in order to get proper resolution? Or is this now planned behavior moving forwards such that focus-follows-mouse is no longer supported? <tongue-in-cheek> If it is the latter, should that option be removed from the settings pages? </tongue-in-cheek>

Joel Rosdahl (jrosdahl) wrote :

+1 here as well.

Bug, not wishlist!

Paul Sladen (sladen) wrote :

I think in this case, it's clear that there's a bug; it's just not of high-importance for a particular use-case, and it's good to be honest about that.

That of course still means that anyone else is welcome to come along, scratch their own itch, track it down and ensure it gets fixed quicker!

Changed in compiz (Ubuntu):
importance: Wishlist → Low
Ian Forde (ianforde) wrote :

I'm confused as to your statement that it's "not of high importance for a particular use-case". To be honest, I think your info may be wholly inaccurate.

This is not some corner case regarding desktop behavior. It's a MAJOR use of X, period.

Focus-follows-click or focus-follows-mouse.

Those have been the 2 options since I started using Motif back in 1993. It's been true on every single UNIX and Linux flavor that I've ever used: FreeBSD, SunOS 4.x, Solaris 2.X, IRIX, OSF/1, HP-UX, AIX, RHL, RHEL, Fedora, Mandrake, Ubuntu-up-until-this-release-that-decided-to-break-a-major-use-case.

I'm all for having this resolved, but the speed with which updates are being put out for Unity, and the patently obvious disregard for such a major issue in favor of other issues speaks volumes to me about the distro's priorities. I'm grateful for Ubuntu. I really am. And to the devs, testers, and architects who worked tirelessly to give us something for free. But since it's free, I can't vote with my wallet to protest something. I don't even want to protest. I just want my mouse and alt-tab to work properly, like they have for the last 18 years.

Hell - is anyone up the Ubuntu chain even reading this?

Tim Cuthbertson (gfxmonk) wrote :

There's a remarkably similar bug in gnome shell: https://bugzilla.gnome.org/show_bug.cgi?id=597190
I've submitted a patch against mutter that fixes it, although it hasn't been accepted yet. I don't know how much is shared between mutter / compiz, but the thread and patch may be at least enlightening even if the patch can't be applied (assuming the reason for breakage is the same).

David Baird (dhbaird) wrote :

I would like to politely correct the author of post #11, who says this is only "a particular use-case." The author is mistaken to believe that the (well written) steps to reproduction make it sound like this is an obscure use case, whereas this is actually substantial use case, as iterated in post #12.

Up until *now*, the ability to have coexistence of ALT-TAB and mouse-hover-focus has been an extremely useful way of choosing where to focus. And, it has been supported quite well in numerous windowing systems, including GNOME.

But now it is broken; And it is broken in an obscure way, which necessitates the complex reproduction instructions of this bug report.

pfaffman (pfaffman) wrote :

ALT-TAB is broken if you use focus follows mouse. This is a bug.

Focus follows mouse is a much more powerful way to manage and use windows. The fact that the default is click-to-focus so that most people don't know how much better that focus follows mouse is explains why not everyone is highly annoyed by this. I guess lots of those click-to-focus people are also happy to, well, click to focus rather than using ALT-TAB.

Tim, is it possible for you to set up a PPA or otherwise make your patches available?

The ring-switcher thing is highly annoying, though it does solve the problem.

Does KDE have this problem?

Tim Cuthbertson (gfxmonk) wrote :

@pfaffman:
My patches are visible in that bug I linked, but that will do ubuntu little good as:
 - they fix a similar bug in mutter, not compiz (ie. they would help if you want to run gnome-shell, but this is a unity bug. I linked it because the fix *may* be similar, but I have zero knowledge of the compiz/unity codebase)
 - you're better off with owen taylor's patch (see the thread), which was the one eventually committed for mutter 3.2

pfaffman (pfaffman) wrote :

@tim:

Oh. Great. I misread that you fixed this bug somewhere else.

I'm surprised that more people don't use focus-follows-mouse. I suppose that I might use alt-tab more often than I type in a window partially obscured by another. I guess not using focus-follows-mouse is the path of least resistance. I guess I'll see how annoying that is.

I'm installing Xubuntu now.

tags: added: focus-follows-mouse
Daniel Hahler (blueyed) on 2013-10-09
Changed in compiz (Ubuntu):
status: Confirmed → Triaged
importance: Low → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.