Trash/ws switcher icon in unity resets to default icon theme on the event of a deletion or emptying the trash or after an upgrade

Bug #761289 reported by FrenchNux on 2011-04-15
70
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Didier Roche
unity (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: unity

unity 3.8.8

when I delete files or empty trash, trash icon gets changed to default icon.

Related branches

FrenchNux (christophe-pauc) wrote :
description: updated
Rohit R (rr0hit) on 2011-04-15
summary: - icon trash unity change itself
+ The Trash icon in unity resets to default icon theme on the event of a
+ deletion
summary: - The Trash icon in unity resets to default icon theme on the event of a
- deletion
+ The trash icon in unity resets to default icon theme on the event of a
+ deletion or emptying the trash
description: updated
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed

Same issue here. I've also noticed that this happen after installing a program with Ubuntu Software Center, not only the Trash icon revert to the old version but also the "Workspace Switcher" icon.

Paul Sladen (sladen) wrote :

Christian: what versions of 'unity', 'unity-asset-pool' and 'humanity-icon-theme' and 'ubuntu-mono' do you have installed?

  dpkg -l unity unity-asset-pool humanity-icon-theme ubuntu-mono

Didier Roche (didrocks) on 2011-04-18
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
assignee: nobody → Didier Roche (didrocks)
milestone: none → 3.8.10
summary: - The trash icon in unity resets to default icon theme on the event of a
- deletion or emptying the trash
+ Trash/ws switcher icon in unity resets to default icon theme on the
+ event of a deletion or emptying the trash or after an upgrade
Paul Sladen (sladen) wrote :

I appears that there are multiple (3?) code-paths for icon loading and the conditional theme override for the loading is only attached to one of those codepaths. For the case of package upload, this will cause a invalidation and rebuild of:

  /usr/share/icons/unity-icon-theme/icon-theme.cache

which I presume forces the reloading. One kludge would be to also add 'workspace-switcher' to the 'ubuntu-mono' icon package again, but this would has the nasty downside of changing the purple icon for the Workspace switcher in the bottom of the GNOME2 Panel/Classic interface (we would have had the same problem with 'user-trash-*' but those have been revert by design for Ubuntu 10.04).

Didier Roche (didrocks) on 2011-04-18
Changed in unity:
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-04-19
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.8.10-0ubuntu1

---------------
unity (3.8.10-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Application windows can sometimes fail to display and will mask regions
      of the screen (LP: #709461)
    - Launcher appears _under_ application windows (LP: #743834)
    - Unity Launcher Temporarily Appears Broken at Login (LP: #756951)
    - compiz crashed with signal 7 in g_file_get_uri() (LP: #728319)
    - Only with few windows (and one maximized) or Dodge active window - When
      re-focusing on maximised window Unity launcher does not hide
      (LP: #734681)
    - UIFe: Unity Dash button does not give adequate feedback (LP: #748676)
    - Focus problem with Thunderbird (LP: #753951)
    - compiz crashed with SIGSEGV in PrivateWindow::updateStartupId()
      (LP: #759363)
    - unity places don't start up on login. (LP: #761225)
    - unity crashes when emptying trash twice (LP: #761643)
    - compiz crashed with SIGSEGV in PlacesResultsController::Clear()
      (LP: #761211)
    - compiz crashed with SIGSEGV in PanelView::~PanelView() (LP: #761634)
    - compiz crashed with SIGSEGV in SimpleLauncherIcon::SetIconName()
      (LP: #763560)
    - compiz crashed with SIGSEGV in PlacesView::ConnectPlaces() (LP: #761942)
    - Intellihide stuck with in x=0 on the bfb (LP: #764643)
    - compiz crashed with SIGSEGV in PlacesView::OnResizeFrame() (LP: #763800)
    - unity crashed with GError in reset_unity_compiz_profile(): Failed to
      contact configuration server; the most common cause is a missing or
      misconfigured D-Bus session bus daemon. See
      http://projects.gnome.org/gconf/ for information. (Details - 1: Failed
      to get connection to session: Command line `dbus-launch
      --autolaunch=f0af37ac055f6f348acd417f00000008 --binary-syntax --close-
      stderr' exited with non-zero exit status 1: No protocol
      specified\nAutolaunch error: X11 initialization failed.\n) (LP: #753528)
    - Chromium fullscreen + Alt-TAB confuses the launcher (LP: #757434)
    - Cannot click on left-most indicator on panel if a non-indicator icon
      appears (LP: #761409)
    - vim.gnome window is invisible (LP: #719001)
    - Trash/ws switcher icon in unity resets to default icon theme on the
      event of a deletion or emptying the trash or after an upgrade
      (LP: #761289)
    - Incorrect keynav hilight/opened Quicklist without any request
      (LP: #764730)
    - indicator font does not update when changing font in Appearance
      Preferences. (LP: #759886)
    - In dash search filter drop box, black text is on a black background when
      item is selected (LP: #761201)
 -- Didier Roche <email address hidden> Tue, 19 Apr 2011 19:30:20 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Doug McMahon (mc3man) wrote :

Well if the fix was to use the old icons for ws and trash then it's good
Current behavior seems to be to boot to old trash icon (clear container) and new ws icon.
Then any number of common actions will return the ws icon to old purple and white one.

Nekhelesh Ramananthan (nik90) wrote :

I still have this bug. I log in, and the new icons are in place, however few minutes later they revert back to the old icons. This happens only for the trash , and the workspace switcher launcher icon.

Jacopo Moronato (jmoronat) wrote :

Has the trash icon been reverted to Humanity icon style with 3.8.10 update ? I can see that icon, with both full and empty trash.

Didier Roche (didrocks) wrote :

The icon for the trash have been reverted on design request to the old icons, this is normal.

Can you elaborate on which actions makes for you the workspace switcher reverting to the old Humanity icon?

Nekhelesh Ramananthan (nik90) wrote :

When I click "empty trash" the workspace icon reverts to the old icon.

Jacopo Moronato (jmoronat) wrote :

Didier, I can confirm.

Didier Roche (didrocks) wrote :

Ok, I've been able to reproduce this time and find the correct solution I think! So after unity 3.8.10-0ubuntu2, you will normally not have anymore workspace switcher icon change. :)

Changed in unity:
status: Fix Released → Fix Committed
Changed in unity (Ubuntu):
status: Fix Released → Fix Committed
Changed in unity:
milestone: 3.8.10 → 3.8.12
Doug McMahon (mc3man) wrote :

with rev 1167 applied can no longer cause the icon to revert back to the old ws with any of the various methods that would have caused to do so

Didier Roche (didrocks) wrote :

excellent Doug! Thanks for confirming :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.8.10-0ubuntu2

---------------
unity (3.8.10-0ubuntu2) natty; urgency=low

  * Cherry-pick some fixes before freeze:
    - Fix tooltip stays stuck next to the launcher (LP: #751077)
    - Trash/ws switcher icon in unity resets to default icon theme on the event
      of a deletion or emptying the trash or after an upgrade (LP: #761289)
    - double clicks should be disabled on bfb/Place launcher icon/double key
      press (LP: #766776)
    - Intellihide can be puzzled by dash / and post reveal broken (LP: #767250)
 -- Didier Roche <email address hidden> Wed, 20 Apr 2011 20:10:19 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-04-22
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments