compiz crashed with SIGSEGV in nux::Area::InitiateResizeLayout()

Bug #757709 reported by Daniel Holbach on 2011-04-11
38
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
High
Unassigned
Unity
Fix Released
Critical
Neil J. Patel
nux (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Critical
Neil J. Patel

Bug Description

Not sure what exactly happened.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: libnux-0.9-0 0.9.42-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
Date: Mon Apr 11 18:12:04 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100816)
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=de_DE:de:en_GB:en
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: nux
StacktraceTop:
 nux::Area::InitiateResizeLayout(nux::Area*) () from /usr/lib/libnux-0.9.so.0
 nux::Area::SetMinimumSize(int, int) () from /usr/lib/libnux-0.9.so.0
 nux::Area::SetMinMaxSize(int, int) () from /usr/lib/libnux-0.9.so.0
 PanelTray::Sync() () from /usr/lib/compiz/libunityshell.so
 PanelTray::IdleSync(PanelTray*) () from /usr/lib/compiz/libunityshell.so
Title: compiz crashed with SIGSEGV in nux::Area::InitiateResizeLayout()
UpgradeStatus: Upgraded to natty on 2011-01-15 (85 days ago)
UserGroups: adm admin audio cdrom dialout lpadmin plugdev sambashare

Related branches

Daniel Holbach (dholbach) wrote :

StacktraceTop:
 nux::Area::InitiateResizeLayout (this=0x974fc90, child=0x0) at ./Area.cpp:419
 nux::Area::SetMinimumSize (this=0x974fc90, w=-487071442, h=24) at ./Area.cpp:150
 nux::Area::SetMinMaxSize (this=0x974fc90, w=-487071442, h=24) at ./Area.cpp:169
 PanelTray::Sync (this=0x974fc90) at /build/buildd/unity-3.8.6/src/PanelTray.cpp:96
 PanelTray::IdleSync (self=0x974fc90) at /build/buildd/unity-3.8.6/src/PanelTray.cpp:169

Changed in nux (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Alex Launi (alexlauni) on 2011-04-11
Changed in nux:
status: New → Confirmed
Changed in unity:
status: New → Confirmed
Changed in nux (Ubuntu):
status: New → Confirmed
Changed in nux:
importance: Undecided → Medium
Changed in unity:
importance: Undecided → Medium
Changed in nux:
assignee: nobody → Jay Taoko (jaytaoko)
visibility: private → public
Didier Roche (didrocks) on 2011-04-12
Changed in unity:
milestone: none → 3.8.8
Changed in nux:
importance: Medium → High
Changed in nux (Ubuntu):
importance: Medium → High
Changed in unity:
importance: Medium → High
Neil J. Patel (njpatel) on 2011-04-12
Changed in nux:
assignee: Jay Taoko (jaytaoko) → nobody
Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
importance: High → Critical
status: Confirmed → Triaged
Didier Roche (didrocks) on 2011-04-13
Changed in nux:
status: Confirmed → Triaged
Changed in nux (Ubuntu):
status: Confirmed → Triaged
Neil J. Patel (njpatel) on 2011-04-13
Changed in nux:
status: Triaged → Invalid
affects: nux (Ubuntu) → unity (Ubuntu)
Changed in unity (Ubuntu):
assignee: nobody → Neil J. Patel (njpatel)
importance: High → Critical
status: Triaged → Fix Committed
Changed in unity:
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2011-04-14
Changed in nux:
status: Invalid → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 0.9.44-0ubuntu1

---------------
nux (0.9.44-0ubuntu1) natty; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in nux::WindowCompositor::RenderTopViews()
      (LP: #754461)
    - compiz crashed with SIGSEGV in nux::Area::InitiateResizeLayout()
      (LP: #757709)
    - Add ATI Radeon Mobility 7500 to compiz blacklist (LP: #760687)
    - Letters cut off at the end in the applications window (LP: #753083)
 -- Didier Roche <email address hidden> Thu, 14 Apr 2011 22:02:48 +0200

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.8.8-0ubuntu1

---------------
unity (3.8.8-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Empty desktop after login (LP: #687660)
    - compiz crashed with SIGSEGV in nux::Area::InitiateResizeLayout()
      (LP: #757709)
    - compiz crashed on initial load of Java Citrix Client/Inkscape in
      PrivateWindow::processMap() (LP: #758307)
    - Sometimes dragging down from the panel just stops working (LP: #750155)
    - Ensure Unity prioritises icon loading from Unity-icon-theme
      (LP: #750471)
    - text truncated in Dash. Empty search from Applications or Files lense
      returns “Your search did not” due to cut off label (LP: #757362)
    - should list PlacesGroup.cpp in POTFILES.in (LP: #757663)
    - Launcher intellhide stuck after edge reveal (LP: #757810)
    - unity-preferences doesn't load translations (LP: #759682)
    - dynamic quicklists are not working (LP: #729074)
    - with second monitor, first monitor does not show nautilus
      application/global menu when displaying desktop (LP: #743149)
    - Launcher - The Workspace, File Lens, App Lens and Trash Launcher icons
      need to be rendered correctly (LP: #745555)
    - the launcher background gets dimmed after icons dnd (LP: #747304)
    - Numpad 'Enter' does not work on unity launcher when navigating through
      keyboard (LP: #760003)
    - Launcher shouldn't hover when being in the dash (LP: #760770)
    - Launcher displays key shortcuts while holding Super while the dash is
      open but the shortcuts are unfunctional (LP: #760728)
    - Running/active indicators point to space between launcher icons for
      folded icons (LP: #703067)
    - user-trash.svg and user-trash-full.svg not lens grayscale versions
      (LP: #741804)
    - code-cleanup: unregistered any established ubus-interests (LP: #757588)
    - dropdown box in places search bar does not resize when font size changes
      (LP: #759763)
    - [FFE] Centered layout for expo plugin (LP: #754689)
    - Unity launcher icons tooltips do not disappear when swiching workspaces
      (LP: #744795)
    - Dash - Update Dash scroll bar (LP: #750374)
    - Letters cut off at the end in the applications window (LP: #753083)
  * debian/control:
    - build-dep on grail/geis with version bumped
  * 01_dont_dep_on_latest_geis_grail.patch:
    - not needed anymore
 -- Didier Roche <email address hidden> Thu, 14 Apr 2011 22:03:42 +0200

Changed in nux (Ubuntu):
status: New → Fix Released
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers