[FFE] Centered layout for expo plugin

Bug #754689 reported by Sam Spilsbury on 2011-04-08
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
Unity
Fix Released
Wishlist
Sam Spilsbury
compiz-plugins-main (Ubuntu)
Wishlist
Unassigned
unity (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: unity

This is a request for a feature freeze exception for the expo plugin of compiz.

DX will be adding two new options with default keys "X Space" and "Y Space" which affects the layout of the spread view to allow the launcher and panel to reserve space there on either side of the screen. This more closely matches the visual design targets for Natty, and in addition, the old layout just looked inconsistent due to the incorrect visual spacing.

See screenshot of the new layout: http://smspillaz.ucc.asn.au/didier-rocks.png

CONTINGENCY PLAN:

The code adds two new options "Space X" and "Space Y" - if we do not feel this change is appropriate, changing those values to "0" will essentially mimic the old behaviour. The options code in this case is autogenerated and the same for all other options - well tested.

TESTING PLAN:

We need testers on different screen resolutions (the code should work for different resolutions) to make sure that the expo view is visually correct on their screen resolution.

DIFF:

 + float xoffset = ((vpSize.x () * sx) / ((float) screen->width ()) * optionGetXOffset ()) * sigmoidProgress (expoCam);
41 + float yoffset = ((vpSize.y () * sy) / ((float) screen->height ()) * optionGetYOffset ()) * sigmoidProgress (expoCam);
42 + float xadjs = 1.0f - ((float) optionGetXOffset () / (float) screen->width ()) * sigmoidProgress (expoCam);
43 + float yadjs = 1.0f - ((float) optionGetYOffset () / (float) screen->height ()) * sigmoidProgress (expoCam);
44 +
45 /* translate expo to center */
46 - sTransform.translate (vpSize.x () * sx * -0.5,
47 - vpSize.y () * sy * 0.5, 0.0f);
48 + sTransform.translate (vpSize.x () * sx * -0.5 + xoffset,
49 + vpSize.y () * sy * 0.5 - yoffset, 0.0f);
50 + sTransform.scale (xadjs, yadjs, 1.0f);

(See: https://code.launchpad.net/~unity-team/compiz/plugins-main-trunk.fixes-2011-03-04/+merge/56919)

Martin Pitt (pitti) wrote :

The change seems relatively harmless to me. However, I fail to see where https://code.launchpad.net/~unity-team/compiz/plugins-main-trunk.fixes-2011-03-04/+merge/56919 actually sets the default offsets? I thought the point was to basically move the empty space on the right to the left where the launcher is, so certainly we'd need some default values here?

OK if we can land this for beta-2.

Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-04-11
Changed in unity:
milestone: none → 3.8.8
status: New → Fix Committed
importance: Undecided → Wishlist
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
Changed in compiz-plugins-main (Ubuntu):
status: New → Fix Committed
importance: Undecided → Wishlist
Changed in unity (Ubuntu):
importance: Undecided → Wishlist
Changed in compiz:
status: New → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Sam Spilsbury (smspillaz) wrote :

Right, the default values would be 64 and 28

Didier Roche (didrocks) on 2011-04-14
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.8.8-0ubuntu1

---------------
unity (3.8.8-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Empty desktop after login (LP: #687660)
    - compiz crashed with SIGSEGV in nux::Area::InitiateResizeLayout()
      (LP: #757709)
    - compiz crashed on initial load of Java Citrix Client/Inkscape in
      PrivateWindow::processMap() (LP: #758307)
    - Sometimes dragging down from the panel just stops working (LP: #750155)
    - Ensure Unity prioritises icon loading from Unity-icon-theme
      (LP: #750471)
    - text truncated in Dash. Empty search from Applications or Files lense
      returns “Your search did not” due to cut off label (LP: #757362)
    - should list PlacesGroup.cpp in POTFILES.in (LP: #757663)
    - Launcher intellhide stuck after edge reveal (LP: #757810)
    - unity-preferences doesn't load translations (LP: #759682)
    - dynamic quicklists are not working (LP: #729074)
    - with second monitor, first monitor does not show nautilus
      application/global menu when displaying desktop (LP: #743149)
    - Launcher - The Workspace, File Lens, App Lens and Trash Launcher icons
      need to be rendered correctly (LP: #745555)
    - the launcher background gets dimmed after icons dnd (LP: #747304)
    - Numpad 'Enter' does not work on unity launcher when navigating through
      keyboard (LP: #760003)
    - Launcher shouldn't hover when being in the dash (LP: #760770)
    - Launcher displays key shortcuts while holding Super while the dash is
      open but the shortcuts are unfunctional (LP: #760728)
    - Running/active indicators point to space between launcher icons for
      folded icons (LP: #703067)
    - user-trash.svg and user-trash-full.svg not lens grayscale versions
      (LP: #741804)
    - code-cleanup: unregistered any established ubus-interests (LP: #757588)
    - dropdown box in places search bar does not resize when font size changes
      (LP: #759763)
    - [FFE] Centered layout for expo plugin (LP: #754689)
    - Unity launcher icons tooltips do not disappear when swiching workspaces
      (LP: #744795)
    - Dash - Update Dash scroll bar (LP: #750374)
    - Letters cut off at the end in the applications window (LP: #753083)
  * debian/control:
    - build-dep on grail/geis with version bumped
  * 01_dont_dep_on_latest_geis_grail.patch:
    - not needed anymore
 -- Didier Roche <email address hidden> Thu, 14 Apr 2011 22:03:42 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz-plugins-main - 0.9.4+bzr20110406-0ubuntu2

---------------
compiz-plugins-main (0.9.4+bzr20110406-0ubuntu2) natty; urgency=low

  * debian/patches/00_bzr_fix_centered_expo.patch:
    - from upstream bzr, fix Centered layout for expo plugin (LP: #754689)
 -- Didier Roche <email address hidden> Tue, 19 Apr 2011 11:40:24 +0200

Changed in compiz-plugins-main (Ubuntu):
status: Fix Committed → Fix Released
Omer Akram (om26er) wrote :

It seems this bug was not fixed in Natty. The fix got missed due to some reason.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers