Letters cut off at the end in the applications window

Bug #753083 reported by Rajeev Nair on 2011-04-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nux
Fix Released
Undecided
Nico van der Walt
Unity
Fix Released
Undecided
Nico van der Walt
nux (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Low
Nico van der Walt

Bug Description

Binary package hint: unity

The last letters in the top right corner of applications and files and folders dash is cut off partially .For example open the applications menu at the top right 'all applications' has the n and s cut off.

Happens when you maximise the dash or keep it normal position.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.2-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.41-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,shift,gnomecompat,place,grid,regex,vpswitch,snap,animation,session,mousepoll,workarounds,move,expo,resize,ezoom,wall,switcher,fade,scale,unityshell]
CompositorRunning: compiz
Date: Thu Apr 7 05:12:59 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 fglrx, 8.840, 2.6.38-7-generic, x86_64: installed
 fglrx, 8.840, 2.6.38-8-generic, x86_64: installed
GraphicsCard:
 ATI Technologies Inc Juniper [Radeon HD 5750 Series] [1002:68be] (prog-if 00 [VGA controller])
   Subsystem: Hightech Information System Ltd. Device [1787:2287]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta 1 amd64 (20110329.1)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Beta 1 amd64 (20110329.1)
InstallationMedia__: Ubuntu 11.04 "Natty Narwhal" - Beta 1 amd64 (20110329.1)
JockeyStatus: xorg:fglrx - ATI/AMD proprietary FGLRX graphics driver (Proprietary, Enabled, In use)
MachineType: Gigabyte Technology Co., Ltd. GA-MA785GM-US2H
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=5978d552-57fe-4695-8ab8-76d41760d500 ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-8.41-generic 2.6.38.2
ProcVersionSignature__: Ubuntu 2.6.38-8.41-generic 2.6.38.2
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/22/2010
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F9
dmi.board.name: GA-MA785GM-US2H
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF9:bd03/22/2010:svnGigabyteTechnologyCo.,Ltd.:pnGA-MA785GM-US2H:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-MA785GM-US2H:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-MA785GM-US2H
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz 1:0.9.4+bzr20110406-0ubuntu1
version.fglrx-installer: fglrx-installer N/A
version.ia32-libs: ia32-libs 20090808ubuntu11
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.1-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu6
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu6

Related branches

Rajeev Nair (rajeev) wrote :
Omer Akram (om26er) wrote :

can you please attach a screenshot to show the problem?

Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
Rajeev Nair (rajeev) wrote :

I am attaching a pic.

Nico van der Walt (nicovdw) wrote :

Hi Rajeev, can you upgrade to Unity 3.8.4 and see if the problem persists? It should be fixed with the upgrade.

Rajeev Nair (rajeev) wrote :

Iam using this version, my system is fully up to date.

Rajeev Nair (rajeev) wrote :

updated to unity 3.8.6.

Still the same.With an ugly drop down menu when you click on 'all applications'.

Omer Akram (om26er) on 2011-04-12
Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
importance: Undecided → Low
status: Incomplete → Confirmed
Nico van der Walt (nicovdw) wrote :

I managed to replicate the problem by setting the font size to something other than the default of 11. The text displays correctly after selecting another entry from the dropdown box and then selecting the original entry (All Applications).

Changed in unity:
assignee: nobody → Nico van der Walt (nicovdw)
Changed in unity (Ubuntu):
assignee: nobody → Nico van der Walt (nicovdw)
Changed in nux:
assignee: nobody → Nico van der Walt (nicovdw)
Changed in nux:
status: New → In Progress
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Didier Roche (didrocks) on 2011-04-13
Changed in nux (Ubuntu):
status: New → In Progress
Didier Roche (didrocks) on 2011-04-13
Changed in nux:
status: In Progress → Fix Committed
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in nux (Ubuntu):
status: In Progress → Fix Committed
Changed in unity:
milestone: none → 3.8.8
Didier Roche (didrocks) on 2011-04-14
Changed in nux:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 0.9.44-0ubuntu1

---------------
nux (0.9.44-0ubuntu1) natty; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in nux::WindowCompositor::RenderTopViews()
      (LP: #754461)
    - compiz crashed with SIGSEGV in nux::Area::InitiateResizeLayout()
      (LP: #757709)
    - Add ATI Radeon Mobility 7500 to compiz blacklist (LP: #760687)
    - Letters cut off at the end in the applications window (LP: #753083)
 -- Didier Roche <email address hidden> Thu, 14 Apr 2011 22:02:48 +0200

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.8.8-0ubuntu1

---------------
unity (3.8.8-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Empty desktop after login (LP: #687660)
    - compiz crashed with SIGSEGV in nux::Area::InitiateResizeLayout()
      (LP: #757709)
    - compiz crashed on initial load of Java Citrix Client/Inkscape in
      PrivateWindow::processMap() (LP: #758307)
    - Sometimes dragging down from the panel just stops working (LP: #750155)
    - Ensure Unity prioritises icon loading from Unity-icon-theme
      (LP: #750471)
    - text truncated in Dash. Empty search from Applications or Files lense
      returns “Your search did not” due to cut off label (LP: #757362)
    - should list PlacesGroup.cpp in POTFILES.in (LP: #757663)
    - Launcher intellhide stuck after edge reveal (LP: #757810)
    - unity-preferences doesn't load translations (LP: #759682)
    - dynamic quicklists are not working (LP: #729074)
    - with second monitor, first monitor does not show nautilus
      application/global menu when displaying desktop (LP: #743149)
    - Launcher - The Workspace, File Lens, App Lens and Trash Launcher icons
      need to be rendered correctly (LP: #745555)
    - the launcher background gets dimmed after icons dnd (LP: #747304)
    - Numpad 'Enter' does not work on unity launcher when navigating through
      keyboard (LP: #760003)
    - Launcher shouldn't hover when being in the dash (LP: #760770)
    - Launcher displays key shortcuts while holding Super while the dash is
      open but the shortcuts are unfunctional (LP: #760728)
    - Running/active indicators point to space between launcher icons for
      folded icons (LP: #703067)
    - user-trash.svg and user-trash-full.svg not lens grayscale versions
      (LP: #741804)
    - code-cleanup: unregistered any established ubus-interests (LP: #757588)
    - dropdown box in places search bar does not resize when font size changes
      (LP: #759763)
    - [FFE] Centered layout for expo plugin (LP: #754689)
    - Unity launcher icons tooltips do not disappear when swiching workspaces
      (LP: #744795)
    - Dash - Update Dash scroll bar (LP: #750374)
    - Letters cut off at the end in the applications window (LP: #753083)
  * debian/control:
    - build-dep on grail/geis with version bumped
  * 01_dont_dep_on_latest_geis_grail.patch:
    - not needed anymore
 -- Didier Roche <email address hidden> Thu, 14 Apr 2011 22:03:42 +0200

Changed in nux (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Rajeev Nair (rajeev) wrote :

Hi Nico

This is not yet fixed for me.Its the same.'All applications' and each section in the drop down is truncated .

Nico van der Walt (nicovdw) wrote :

Hi Rajeev, can you please test this again. It should be fixed after upgrading to Unity 3.8.10 and libnux 0.9.46. There was a further issue with font sizes larger than 12.

Rajeev Nair (rajeev) wrote :

I tested with this latest versions but still the same.

Also what is this font size you mention about? Is is something adjustable by end user?

Ill try deleting the .compiz folders in home to see if that does anything.

Rajeev Nair (rajeev) wrote :

OK this worked.i deleted all the .compiz and .compiz1 folders from inside the .config file and also the .compiz folder in home.

Now looks ok.Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers