Ubuntu

[RS880] graphical corruption in launcher (Solid grey rectangles over icon text and window borders)

Reported by Martin Pool on 2011-04-06
76
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Unity
Medium
Unassigned
xserver-xorg-driver-ati
Incomplete
Medium
unity (Ubuntu)
Medium
Unassigned
Natty
Undecided
Unassigned
xserver-xorg-video-ati (Ubuntu)
Medium
Unassigned
Natty
Low
Unassigned

Bug Description

Binary package hint: unity

on current natty, clicking the Ubuntu button in the top left shows a window with graphical corruption as shown in the attached screenshot. sometimes there are solid grey rectangles over the icon text too.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.2-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.41-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,scale,session,unityshell]
CompositorRunning: compiz
DRM.card0.DVI.D.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1920x1200 1600x1200 1680x1050 1280x1024 1280x1024 1152x864 1024x768 1024x768 800x600 800x600 640x480 640x480 720x400
 edid-base64: AP///////wAQrDCgUzE0MBMTAQOAOiR46un1rFEwtCURUFSlSwCBgKlAcU+zAAEBAQEBAQEBKDyAoHCwI0AwIDYARmwhAAAaAAAA/wBSSzUxNDk1ODA0MVMKAAAA/ABERUxMIDI3MDlXCiAgAAAA/QA4TB5TEQAKICAgICAgAHU=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
Date: Wed Apr 6 13:21:21 2011
DistUpgraded: Log time: 2010-12-21 12:35:39.044742
DistroCodename: natty
DistroVariant: ubuntu
EcryptfsInUse: Yes
GraphicsCard:
 ATI Technologies Inc RS880 [Radeon HD 4290] [1002:9714] (prog-if 00 [VGA controller])
   Subsystem: Giga-byte Technology Device [1458:d000]
MachineType: Gigabyte Technology Co., Ltd. GA-890GPA-UD3H
ProcEnviron:
 LANGUAGE=en_AU:en
 PATH=(custom, user)
 LANG=en_AU.UTF-8
 SHELL=/bin/zsh
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-2.6.38-8-generic root=/dev/mapper/vg_main-natty_64 ro clock=hpet quiet splash rootdelay=10 vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-8.41-generic 2.6.38.2
ProcVersionSignature__: Ubuntu 2.6.38-8.41-generic 2.6.38.2
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2010-12-21 (105 days ago)
XorgConf:
 Section "Device"
  Identifier "Configured Video Device"
  Option "SWCursor" "on"
 EndSection
dmi.bios.date: 05/04/2010
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F7c
dmi.board.name: GA-890GPA-UD3H
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF7c:bd05/04/2010:svnGigabyteTechnologyCo.,Ltd.:pnGA-890GPA-UD3H:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-890GPA-UD3H:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-890GPA-UD3H
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz 1:0.9.4git20110322-0ubuntu5
version.ia32-libs: ia32-libs 20090808ubuntu11
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.1-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu6
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu6

Martin Pool (mbp) wrote :
Alex Launi (alexlauni) wrote :

this looks like another ati driver bug.

Changed in unity:
assignee: nobody → Jay Taoko (jaytaoko)
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Jay Taoko (jaytaoko) wrote :

This is a driver bug. We get many similar bugs on systems that combines and AMD GPU and the open source radeon driver. Just to confirm this, please, try the fglrx driver.

Martin Pool (mbp) wrote :

I don't get this precise type of corruption using fglrx (it was intermittent) but I do get a much worse case of bug 760405, and general flickering on the screen.

bugbot (bugbot) on 2011-04-17
tags: added: corruption
Bryce Harrington (bryce) on 2011-04-20
summary: - graphical corruption in launcher
+ graphical corruption in launcher (Solid grey rectangles over icon text
+ and window borders)
Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Confirmed
summary: - graphical corruption in launcher (Solid grey rectangles over icon text
- and window borders)
+ [RS880] graphical corruption in launcher (Solid grey rectangles over
+ icon text and window borders)
Otus (jan-varho) wrote :

I get similar corruption with open radeon drivers and 4850. White or grey shapes on top of the "check email" text and icon and sometimes other icons. Intermittent.

Otus (jan-varho) wrote :
Download full text (3.5 KiB)

Forwarding this bug from Ubuntu reporter Martin Pool:
http://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/752157

[Problem]
On RS880 solid grey rectangles appear over icon text and window borders in some applications in a compositing environment, namely Unity's launcher. Unity developers are able to reproduce this and say it is a video driver / mesa issue.

[Original Description]
on current natty, clicking the Ubuntu button in the top left shows a window with graphical corruption as shown in the attached screenshot. sometimes there are solid grey rectangles over the icon text too.

DistroRelease: Ubuntu 11.04
Package: unity 3.8.2-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.41-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,scale,session,unityshell]
CompositorRunning: compiz
DRM.card0.DVI.D.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1920x1200 1600x1200 1680x1050 1280x1024 1280x1024 1152x864 1024x768 1024x768 800x600 800x600 640x480 640x480 720x400
 edid-base64: AP///////wAQrDCgUzE0MBMTAQOAOiR46un1rFEwtCURUFSlSwCBgKlAcU+zAAEBAQEBAQEBKDyAoHCwI0AwIDYARmwhAAAaAAAA/wBSSzUxNDk1ODA0MVMKAAAA/ABERUxMIDI3MDlXCiAgAAAA/QA4TB5TEQAKICAgICAgAHU=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
Date: Wed Apr 6 13:21:21 2011
DistUpgraded: Log time: 2010-12-21 12:35:39.044742
DistroCodename: natty
DistroVariant: ubuntu
EcryptfsInUse: Yes
GraphicsCard:
 ATI Technologies Inc RS880 [Radeon HD 4290] [1002:9714] (prog-if 00 [VGA controller])
   Subsystem: Giga-byte Technology Device [1458:d000]
MachineType: Gigabyte Technology Co., Ltd. GA-890GPA-UD3H
ProcEnviron:
 LANGUAGE=en_AU:en
 PATH=(custom, user)
 LANG=en_AU.UTF-8
 SHELL=/bin/zsh
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-2.6.38-8-generic root=/dev/mapper/vg_main-natty_64 ro clock=hpet quiet splash rootdelay=10 vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-8.41-generic 2.6.38.2
ProcVersionSignature__: Ubuntu 2.6.38-8.41-generic 2.6.38.2
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2010-12-21 (105 days ago)
XorgConf:
 Section "Device"
  Identifier "Configured Video Device"
  Option "SWCursor" "on"
 EndSection
dmi.bios.date: 05/04/2010
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F7c
dmi.board.name: GA-890GPA-UD3H
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF7c:bd05/04/2010:svnGigabyteTechnologyCo.,Ltd.:pnGA-890GPA-UD3H:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-890GPA-UD3H:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-890GPA-UD3H
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz 1:0.9.4git20110322-0ubuntu5
version.ia32-libs: ia32-libs 20090808ubuntu11
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.1-0ubuntu3
version.libgl1-mesa-dri-experi...

Read more...

Bryce Harrington (bryce) wrote :

Martin Pool - I've forwarded this bug upstream to http://bugs.freedesktop.org/show_bug.cgi?id=36442 - please subscribe yourself to this bug, in case they need further information or wish you to test something. Thanks ahead of time!

@Jay, would appreciate it if you'd sub to it as well.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Triaged

Created attachment 45885
corruption.png

Created attachment 45886
unity-corruption.png

This shows the corruption on text.

I have reproduced this particular corruption myself on an RV770 when running unity and using the dash.

Created attachment 45887
BootDmesg.txt

Created attachment 45889
CurrentDmesg.txt

Created attachment 45890
XorgLog.txt

Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
status: Unknown → Confirmed

I'm the upstream reporter of this. I can't characterize when it happens but it is fairly frequent. Let me know if you want more information.

This is most likely a 3D driver bug. Are you using r600c or r600g?

Possibly related to bug 36441.

Martin's on r600g (Ubuntu defaults to this now)

OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD RS880
OpenGL version string: 2.1 Mesa 7.10.1

Same with me:

OpenGL renderer string: Gallium 0.4 on AMD RV770
OpenGL version string: 2.1 Mesa 7.10.2

Bryce Harrington (bryce) on 2011-04-29
Changed in xserver-xorg-video-ati (Ubuntu):
importance: Undecided → Medium
Bryce Harrington (bryce) on 2011-05-03
tags: added: oneiric
Bryce Harrington (bryce) wrote :

[I've marked this bug for inclusion in our oneiric bug queue. While technically this bug has not been re-confirmed against oneiric, I feel it is worth continued development attention. We will need to ask that it be re-confirmed once oneiric is further along, perhaps once we get closer to alpha.]

Schmankerl (schmankerl) wrote :

Same on ATI Mobility HD3650 with open source radeon driver. White stripes appears sometimes near the ubuntu lauchner icon and other icons... and sometimes the complete top panel is nearly white instead of dark gray (black). In a few cases my unity did not start up and I had to shutdown via power button. I don`t want to use fglrx driver :-(

kemi242 (kemi242) wrote :

I have this problem on my AMD Radeon HD4830. I installed fglrx, the problem is gone, but Compiz effects became slow and sluggish, and overall boot time became longer, so I switched back to the open source driver. I hope it gets fixed.

Evan Huus (eapache) wrote :

Just upgraded to Oneiric (I know, I'm crazy), and this bug has disappeared. A little poking around indicates that the open-source ati stack in Oneiric has switched to gallium by default instead of mesa, which is probably why I'm not seeing this anymore.

I don't know if that switch is one we're keeping (or if it just got in by accident during debian import), but if someone can confirm it then we can at least close the oneiric task for this bug.

My card is an HD2600XT.

Bryce Harrington (bryce) wrote :

eapache, thanks that's interesting. Actually, we (quite deliberately) switched to the gallium driver in natty. So I'm curious if you were able to reproduce it on natty with the gallium driver or only with classic?

@Martin, it would be helpful if you could download and boot an oneiric ISO and confirm eapache's findings that the issue is solved there. We've not put in new mesa or -radeon quite yet so this kind of surprises me, but it does have a new kernel and several other X components, so it's possible one of those changes fixed the issue.

Evan Huus (eapache) wrote :

I did see this consistently on my natty install, however I got to natty from lucid by way of maverick, so I don't know where my graphics stack was at that point (didn't do anything fancy with it though, so presumably it went to Gallium and I didn't notice).

Since that box is oneiric now, it's too late to check, though I've got the natty iso somewhere around here. Is it worth booting a natty liveCD and seeing if I can reproduce it there?

Bryce Harrington (bryce) wrote :

"Is it worth booting a natty liveCD and seeing if I can reproduce it there?"

Probably not; we're no where near identifying what package was bugged, let alone have a patch identified, so at this point a backport to natty is looking unlikely. However, I'll open a natty task in case anyone would like to do the legwork of chasing down the patch and proposing it for an SRU. (First isolate which package contains the fix by selectively upgrading packages to the oneiric versions, then do a git bisect on that package to pinpoint the patch that fixed it; then see the StableReleaseUpdates wiki page for directions on how to file SRUs.)

Since we've not heard from Martin, I'm going to go ahead and assume your findings are true that this is fixed in oneiric and close out this bug report; if anyone does see the bug in oneiric please open a new report (ubuntu-bug xorg) so we have updated logs and such. (Reference this bug report if you're certain it's the same issue.)

Bryce Harrington (bryce) wrote :

As per comments, believed fixed in oneiric. Leaving natty task, but additional analysis is needed to identify the fix still.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Triaged → Fix Released
Changed in xserver-xorg-video-ati (Ubuntu Natty):
importance: Undecided → Low
Jay Taoko (jaytaoko) wrote :

This was a driver bug. I can't reproduce it on Oneiric for at least 2 months now.

Changed in unity:
status: Confirmed → Invalid

I also have not seen this for a month or more.
On Sep 14, 2011 1:36 AM, "Jay Taoko" <email address hidden> wrote:
> This was a driver bug. I can't reproduce it on Oneiric for at least 2
> months now.
>
> ** Changed in: unity
> Status: Confirmed => Invalid
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/752157
>
> Title:
> [RS880] graphical corruption in launcher (Solid grey rectangles over
> icon text and window borders)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/752157/+subscriptions
>

Didier Roche (didrocks) on 2011-09-30
Changed in unity:
status: Invalid → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu Natty):
status: New → Confirmed
Changed in xserver-xorg-video-ati (Ubuntu Natty):
status: New → Confirmed
Omer Akram (om26er) on 2012-02-05
Changed in xserver-xorg-video-ati (Ubuntu Natty):
status: Confirmed → Won't Fix
Changed in unity (Ubuntu Natty):
status: Confirmed → Won't Fix

Is this still an issue with newer ubuntu with updated mesa and all ?

Changed in xserver-xorg-driver-ati:
status: Confirmed → Incomplete
Omer Akram (om26er) wrote :

Thanks for the bug report. Is that still an issue in Ubuntu 12.04?

Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Christian Mariucci (cmariucci) wrote :

In Ubuntu 12.04, with an ati hd4200 igp, I don't have anymore this issue. I'm using open drivers.

Omer Akram (om26er) wrote :

thanks for the quick response. Closing.

Changed in unity:
status: Incomplete → Invalid
assignee: Jay Taoko (jaytaoko) → nobody
Changed in unity (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.