should not wait the key unpress to display lenses / super wait to be released to show dash/places

Bug #747323 reported by Sebastien Bacher on 2011-04-01
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Sam Spilsbury
compiz (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: unity

Using 3.8.2 if you open a place with the keyboard it only display when you unpress the key, it's confusing if you keep your finger on the modifier key

Related branches

Changed in unity (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Didier Roche (didrocks) on 2011-04-01
summary: - should not way the key unpress to display lenses
+ should not wait the key unpress to display lenses
Changed in unity:
assignee: nobody → Didier Roche (didrocks)
importance: Undecided → Low
milestone: none → 3.8.4
status: New → Confirmed

Unfortunately, the branch didn't fix the problem, and created other regressions (the SUPER-<x> shortcuts were all broken).

Didier Roche (didrocks) wrote :

It's a compiz issue first, assigning to sam to reflect what should be done.

Changed in unity:
assignee: Didier Roche (didrocks) → Sam "SmSpillaz" Spilsbury (smspillaz)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.4+bzr20110406-0ubuntu1

---------------
compiz (1:0.9.4+bzr20110406-0ubuntu1) natty; urgency=low

  * new upstream bzr tarball:
    - display/size problems with xterm (LP: #748137)
    - fix crashes on tcl/tk applications (LP: #741074, #747439)
    - fix grab on compose keys (LP: #747323)
    - resync stack at regular interval to avoid invisible windows
      (LP: #723014, #743011, #736876, #740465, #684590)
    - fix weird order in alt + tab (LP: #175874)
    - fix crash in gitk (LP: #743011, #741074)
    - avoid compiz detection by fglrx driver (LP: #740298)
    - Wrong window moves (LP: #741656, #743634)
    - Unity Grid is broken for multi-monitor setups (LP: #709221)
    - Feature Freeze Exception: Animation for Grid Plugin Previews (LP: #744104)
    - unity-window-decorator crashed with SIGSEGV in gdk_window_get_events()
      (LP: #725284)
    - fix xterm (LP: #692463)
    - start the decorator on a secondary screen (LP: #730495)
  * debian/patches/090_git_fix_new_invisible_windows.patch,
    debian/patches/100_bump_core.h.patch:
    - upstreamed
  * debian/patches/01_unity_window_decorator.patch
    debian/patches/085_add_grid_plugin.patch:
    - in bzr upstream tarball
 -- Didier Roche <email address hidden> Wed, 06 Apr 2011 19:37:45 +0200

Changed in compiz (Ubuntu):
status: New → Fix Released
Didier Roche (didrocks) on 2011-04-07
Changed in unity:
milestone: 3.8.4 → 3.8.6
Sam Spilsbury (smspillaz) wrote :

Right, implicit keyboard grab fiasco. The action only gets terminated when you release the key in this case. However the upstream change was rejected because it is too risky, so I'm not sure what to do about this one.

I'm pretty sure the design here is supposed to be this:

<super> - show launcher regardless
<super> - held, show launcher, do NOT show dash or places, show shortcuts
<super> - press and release, do NOT show shortcuts, show dash and places

Changed in unity:
milestone: 3.8.6 → backlog
Didier Roche (didrocks) on 2011-04-21
summary: - should not wait the key unpress to display lenses
+ should not wait the key unpress to display lenses / super wait to be
+ released to show dash/places
Sebastien Bacher (seb128) wrote :

it works in Oneiric

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Changed in unity:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers