All unity windows are invisible (panel, launcher, dash)

Bug #745996 reported by Chase Douglas on 2011-03-30
186
This bug affects 36 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Neil J. Patel
unity (Ubuntu)
High
Jason Smith
Natty
High
Neil J. Patel
Oneiric
High
Jason Smith

Bug Description

This is due to having improper settings in ~/.drirc. Deleting the file allows Unity to work correctly.

Original bug report:
--------------------

When running unity, I can open a terminal and launch applications that are displayed just fine. However, all the unity windows are invisible. I can't see the panel or launcher, for example, but I can still interact with them by clicking on them.

I have tried a package in didrocks' ppa that includes the stack attack hack, but it doesn't seem to have made any difference.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.6.8-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1366x768
 edid-base64: AP///////wAw5GkCAAAAAAATAQSQFg14Cr9FlVhSiiglUFQAAAABAQEBAQEBAQEBAQEBAQEBvBtWhFAAFjAwIDUA330AAAAbvBtWhFAAFjAwIDUA330AAAAbAAAA/gBSS0RZM4AxMDFXSDEKAAAAAAAAQTOZAQAAAAEBCiAgADU=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Wed Mar 30 15:45:55 2011
DistUpgraded: Log time: 2011-03-28 19:48:22.905341
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 hid-magicmouse-dkms, 1.0, 2.6.37-8-generic, i686: installed
 hid-magicmouse-dkms, 1.0, 2.6.38-7-generic, i686: installed
 hid-magicmouse-dkms, 1.0, 2.6.37-9-generic, i686: installed
 psmouse, 1.0, 2.6.36-020636rc5-generic, i686: installed
GraphicsCard:
 Intel Corporation N10 Family Integrated Graphics Controller [8086:a011] (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:041a]
   Subsystem: Dell Device [1028:041a]
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Alpha i386 (20100405)
InstallationMedia_: Ubuntu-Netbook 10.04 "Lucid Lynx" - Alpha i386 (20100405)
InstallationMedia__: Ubuntu-Netbook 10.04 "Lucid Lynx" - Alpha i386 (20100405)
MachineType: Dell Inc. Inspiron 1012
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-generic root=UUID=3c709a23-d79e-4eda-9014-8e0593c2d2ba ro intel_idle.max_cstate=0 quiet splash usbcore.autosuspend=1 vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-7.39-generic 2.6.38
ProcVersionSignature__: Ubuntu 2.6.38-7.39-generic 2.6.38
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-03-29 (1 days ago)
XorgConf:
 #Section "InputClass"
 # MatchIsTouchpad "true"
 # Identifier "Multitouch Touchpad"
 # Driver "multitouch"
 #EndSection
dmi.bios.date: 02/22/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A06
dmi.board.name: 0D3J9P
dmi.board.vendor: Dell Inc.
dmi.board.version: A06
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A06
dmi.modalias: dmi:bvnDellInc.:bvrA06:bd02/22/2010:svnDellInc.:pnInspiron1012:pvrA06:rvnDellInc.:rn0D3J9P:rvrA06:cvnDellInc.:ct8:cvrA06:
dmi.product.name: Inspiron 1012
dmi.product.version: A06
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.4git20110322-0ubuntu5
version.libdrm2: libdrm2 2.4.23-1ubuntu5
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu11
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu6

Chase Douglas (chasedouglas) wrote :
Didier Roche (didrocks) wrote :

Seems to be an important invisible window case as Chase can still click on them and the X tree shows they are there.

The stackattack doesn't workaround it, so setting in the important list. Note it can be a painting issue with Nux as well

Changed in unity:
importance: Undecided → High
milestone: none → 3.8.4
tags: added: unity unity-priority
David Barth (dbarth) wrote :

It's a rendering issue it seems, because:
- windows are there (in xwininfo)
- the stackattack workaround doesn't change anything, so it's not a stacking problem
- clicks and other events prove the window behaves properly

Alex Launi (alexlauni) on 2011-03-31
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
David Barth (dbarth) wrote :

Assigning to Jason - the-invisible-windows-bug-exterminator - Smith. Good hunting!

Changed in unity:
assignee: nobody → Jason Smith (jassmith)
Jason Smith (jassmith) wrote :

I would like to remind the world that chases system is a special form of screwy (I had the chance to help him debug it). Until we get a second confirmation to me this sounds like driver FBO failure.

Jason Smith (jassmith) wrote :

Waiting for comfirmation from non-chase person

Changed in unity:
status: Confirmed → Incomplete
Richard Merren (richard-merren) wrote :

I am seeing this as well. Can't see a side panel, only the drop shadow for top panel. I can still click the invisible top and get menus (e.g. power, wifi connections, etc.). What info do you need to confirm it is the same issue?

Travis Larson (tlarson) wrote :

I upgraded from 10.10 to Natty beta yesterday and I'm having this same issue. I'm running a ThinkPad T60 with an Intel GMA 950. Is there any other info I can provide?

Bálint Magyar (balintm) wrote :

I have the same problem with a GMA-950 after upgrading from 10.10 to the Natty beta.

Compiz update today has resolved this problem for me. All panels are now visible and work fine. For the first time since installing the Beta a few days ago I have 3D Unity working properly.

Travis Larson (tlarson) wrote :

Unfortunately, the latest updates have not fixed this problem for me. Did you have to do anything special or just upgrade and reboot?

Just upgrade and reboot. I also had a few Margaritas at dinner. With salt. That may have helped as well.

Didier Roche (didrocks) wrote :

Sorry Jason, it's just not Chase's system then ;)

Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
importance: Undecided → High
Bálint Magyar (balintm) wrote :

The compiz update did not fix this on my system.

Didier Roche (didrocks) on 2011-04-07
Changed in unity:
milestone: 3.8.4 → 3.8.6
moragos (moragos) wrote :

i have the same problem.
updated from 10.10 to 11.04 last night.

today's compiz update didn't fix the issue. i also tried removing and reinstalling the nvidia drivers.

i'm using a HP pavillion laptop dv6183ea. GeForce Go 7400.

if there is any info i can provide to help - let me know.

Jason Smith (jassmith) wrote :

This appears to be an incantation of the stacking issue. One or both of the input windows is being stacked under the desktop window. Hopefully sams compiz fixes will resolve this in the next upload.

Mace (xmacex) wrote :

I also have been using the "Ubuntu classic" desktop because of this bug since 1st April. I'm marking my own bug (https://bugs.launchpad.net/unity/+bug/753245, includes a screenshot) as a duplicate of this.

Didier Roche (didrocks) on 2011-04-11
Changed in unity:
milestone: 3.8.6 → 3.8.8
David Barth (dbarth) wrote :

@Jason: at this stage, and considering how many windows are impacted, it feels more like a nux painting problem. Similar to what we had in the dash with certain chipsets at some point.

Changed in unity:
importance: High → Critical

Bug #755403 had been marked as a duplicate of the present one, but IMHO in error (I get nothing "invisible" I could interact with using my mouse).

Also, some above tell updates helped. Not in my case :-\

Jason Smith (jassmith) wrote :

Chase has just confirmed that on his system the latest ISO from a clean install has resolved the issue. Maybe we have a PPA conflict issue here?

Bálint Magyar (balintm) wrote :

Thanks Jason, after that comment I've tried to narrow the cause of the problem and have boiled it down to $HOME/.drirc which I have created with driconf at some point in time. Removing it fixes this bug for me on my system running on GMA-950 with the open source intel video driver.

I have attached the problematic config for further investigation.

Mace (xmacex) wrote :

Hey that solved for me too, awesome! I regrettably did take a look into the $HOME/.drirc -file, but didn't spare the file for sharing here. I'm sorry about that! I've got GMA-950 too, on an Asus EeePC 901. Thanks!!

Download full text (4.5 KiB)

" <option name="fragment_shader" value="false" />"

That would do it.

On Wed, Apr 13, 2011 at 5:43 PM, Mace <email address hidden> wrote:
> Hey that solved for me too, awesome! I regrettably did take a look into
> the $HOME/.drirc -file, but didn't spare the file for sharing here. I'm
> sorry about that! I've got GMA-950 too, on an Asus EeePC 901. Thanks!!
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/745996
>
> Title:
>  All unity windows are invisible (panel, launcher, dash)
>
> Status in Unity:
>  Confirmed
> Status in “unity” package in Ubuntu:
>  Confirmed
>
> Bug description:
>  Binary package hint: unity
>
>  When running unity, I can open a terminal and launch applications that
>  are displayed just fine. However, all the unity windows are invisible.
>  I can't see the panel or launcher, for example, but I can still
>  interact with them by clicking on them.
>
>  I have tried a package in didrocks' ppa that includes the stack attack
>  hack, but it doesn't seem to have made any difference.
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 11.04
>  Package: unity 3.6.8-0ubuntu3
>  ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
>  Uname: Linux 2.6.38-7-generic i686
>  Architecture: i386
>  CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
>  CompositorRunning: compiz
>  DRM.card0.LVDS.1:
>   status: connected
>   enabled: enabled
>   dpms: On
>   modes: 1366x768
>   edid-base64: AP///////wAw5GkCAAAAAAATAQSQFg14Cr9FlVhSiiglUFQAAAABAQEBAQEBAQEBAQEBAQEBvBtWhFAAFjAwIDUA330AAAAbvBtWhFAAFjAwIDUA330AAAAbAAAA/gBSS0RZM4AxMDFXSDEKAAAAAAAAQTOZAQAAAAEBCiAgADU=
>  DRM.card0.VGA.1:
>   status: disconnected
>   enabled: disabled
>   dpms: Off
>   modes:
>   edid-base64:
>  Date: Wed Mar 30 15:45:55 2011
>  DistUpgraded: Log time: 2011-03-28 19:48:22.905341
>  DistroCodename: natty
>  DistroVariant: ubuntu
>  DkmsStatus:
>   hid-magicmouse-dkms, 1.0, 2.6.37-8-generic, i686: installed
>   hid-magicmouse-dkms, 1.0, 2.6.38-7-generic, i686: installed
>   hid-magicmouse-dkms, 1.0, 2.6.37-9-generic, i686: installed
>   psmouse, 1.0, 2.6.36-020636rc5-generic, i686: installed
>  GraphicsCard:
>   Intel Corporation N10 Family Integrated Graphics Controller [8086:a011] (prog-if 00 [VGA controller])
>     Subsystem: Dell Device [1028:041a]
>     Subsystem: Dell Device [1028:041a]
>  InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Alpha i386 (20100405)
>  InstallationMedia_: Ubuntu-Netbook 10.04 "Lucid Lynx" - Alpha i386 (20100405)
>  InstallationMedia__: Ubuntu-Netbook 10.04 "Lucid Lynx" - Alpha i386 (20100405)
>  MachineType: Dell Inc. Inspiron 1012
>  ProcEnviron:
>   LANGUAGE=en_US:en
>   LANG=en_US.UTF-8
>   SHELL=/bin/bash
>  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-generic root=UUID=3c709a23-d79e-4eda-9014-8e0593c2d2ba ro intel_idle.max_cstate=0 quiet splash usbcore.autosuspend=1 vt.handoff=7
>  ProcVersionSignature_: Ubuntu 2.6.38-7.39-ge...

Read more...

Chase Douglas (chasedouglas) wrote :

I can confirm that this is an issue with my ~/.drirc file as well. I can't remember exactly why I have the file, but I'm guessing it was to enable a bit of hardware acceleration for Flash.

Changed in unity (Ubuntu):
status: Confirmed → Invalid
Changed in unity:
status: Confirmed → Invalid
description: updated
Chase Douglas (chasedouglas) wrote :

I also added a line about this issue to the release notes for Natty.

Travis Larson (tlarson) wrote :

Thank you. It's now working for me. I think I made the .drirc setting while trying to get Braid working from the Humble Indie Bundle 2.

moragos (moragos) wrote :

i don't seem to have ~/.drirc file (or at least i can't find it).
i searched my home folder and my entire pc.

Emil Soleyman (emilsoleyman) wrote :

I have a Lenovo Z61T laptop with Intel 945GM video card and I am still running into this issue with the latest updates. I, too, don't have any ~/.drirc file in the home directory. I am running into this issue even with a newly generated user and home directory.

Please let me know if you require any logs, screenshot, or debugging.

Pete Graner (pgraner) on 2011-04-25
Changed in unity (Ubuntu Natty):
status: Invalid → Confirmed
Changed in unity (Ubuntu Oneiric):
status: New → Confirmed
importance: Undecided → High
Changed in unity (Ubuntu Natty):
assignee: nobody → Jason Smith (jassmith)
Changed in unity (Ubuntu Oneiric):
assignee: nobody → Jason Smith (jassmith)
Changed in unity (Ubuntu Natty):
milestone: none → natty-updates
Changed in unity (Ubuntu Oneiric):
milestone: none → ubuntu-11.10
Didier Roche (didrocks) on 2011-04-26
Changed in unity:
status: Invalid → Confirmed
Didier Roche (didrocks) on 2011-04-29
Changed in unity:
milestone: 3.8.8 → 3.8.14
Didier Roche (didrocks) wrote :

@everyone still having this bug:
Can you try to remove this file from your filesystem: ~/.drirc
Then logout, and login again?

Emil Soleyman (emilsoleyman) wrote :

My home directory does not have the ~/.drirc file.

Arnaud Fonce (arnaud-fonce) wrote :

Neither do mine. I don't have this file in my home directory.

glazs (l-admin-rock-su) wrote :

No! It's not critical bug! Unity is bug!

And this is critical https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/761616 =)

Jason Smith (jassmith) wrote :

Can you guys post your glxinfo outputs?

moragos (moragos) wrote :

how do i get it?

i tried running "glxinfo" in the console, but it doesn't work.

Omer Akram (om26er) wrote :
Download full text (4.5 KiB)

it also tells you to install meta-utils with the command "sudo apt-get
install mesa-utils" try that and then get glxinfo.

On Tue, May 17, 2011 at 7:09 PM, moragos <email address hidden> wrote:
> how do i get it?
>
> i tried running "glxinfo" in the console, but it doesn't work.
>
> --
> You received this bug notification because you are subscribed to unity.
> https://bugs.launchpad.net/bugs/745996
>
> Title:
>  All unity windows are invisible (panel, launcher, dash)
>
> Status in Unity:
>  Confirmed
> Status in “unity” package in Ubuntu:
>  Confirmed
> Status in “unity” source package in Natty:
>  Confirmed
> Status in “unity” source package in Oneiric:
>  Confirmed
>
> Bug description:
>  This is due to having improper settings in ~/.drirc. Deleting the file
>  allows Unity to work correctly.
>
>  Original bug report:
>  --------------------
>
>  When running unity, I can open a terminal and launch applications that
>  are displayed just fine. However, all the unity windows are invisible.
>  I can't see the panel or launcher, for example, but I can still
>  interact with them by clicking on them.
>
>  I have tried a package in didrocks' ppa that includes the stack attack
>  hack, but it doesn't seem to have made any difference.
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 11.04
>  Package: unity 3.6.8-0ubuntu3
>  ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
>  Uname: Linux 2.6.38-7-generic i686
>  Architecture: i386
>  CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
>  CompositorRunning: compiz
>  DRM.card0.LVDS.1:
>   status: connected
>   enabled: enabled
>   dpms: On
>   modes: 1366x768
>   edid-base64: AP///////wAw5GkCAAAAAAATAQSQFg14Cr9FlVhSiiglUFQAAAABAQEBAQEBAQEBAQEBAQEBvBtWhFAAFjAwIDUA330AAAAbvBtWhFAAFjAwIDUA330AAAAbAAAA/gBSS0RZM4AxMDFXSDEKAAAAAAAAQTOZAQAAAAEBCiAgADU=
>  DRM.card0.VGA.1:
>   status: disconnected
>   enabled: disabled
>   dpms: Off
>   modes:
>   edid-base64:
>  Date: Wed Mar 30 15:45:55 2011
>  DistUpgraded: Log time: 2011-03-28 19:48:22.905341
>  DistroCodename: natty
>  DistroVariant: ubuntu
>  DkmsStatus:
>   hid-magicmouse-dkms, 1.0, 2.6.37-8-generic, i686: installed
>   hid-magicmouse-dkms, 1.0, 2.6.38-7-generic, i686: installed
>   hid-magicmouse-dkms, 1.0, 2.6.37-9-generic, i686: installed
>   psmouse, 1.0, 2.6.36-020636rc5-generic, i686: installed
>  GraphicsCard:
>   Intel Corporation N10 Family Integrated Graphics Controller [8086:a011] (prog-if 00 [VGA controller])
>     Subsystem: Dell Device [1028:041a]
>     Subsystem: Dell Device [1028:041a]
>  InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Alpha i386 (20100405)
>  InstallationMedia_: Ubuntu-Netbook 10.04 "Lucid Lynx" - Alpha i386 (20100405)
>  InstallationMedia__: Ubuntu-Netbook 10.04 "Lucid Lynx" - Alpha i386 (20100405)
>  MachineType: Dell Inc. Inspiron 1012
>  ProcEnviron:
>   LANGUAGE=en_US:en
>   LANG=en_US.UTF-8
>   SHELL=/bin/bash
>  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-generic root=UUID=3c709a23-d79e-4e...

Read more...

moragos (moragos) wrote :
magowiz (magowiz) wrote :

glxinfo as normal user :
name of display: :0
Errore di segmentazione

sudo glxinfo:
name of display: :0

Emil Soleyman (emilsoleyman) wrote :
Jason Smith (jassmith) wrote :

Emil you are running xorg-edgers mesa still. Hopefully a re-install or reverting back those packages will resolve the issue for you.

David Barth (dbarth) wrote :

Jason: so is this bug still critical, or is it in fact "invalid"?

Emil: please can you report whether this solved your problem?

Changed in unity:
milestone: 3.8.14 → 3.8.16
kenjo (ken-kenjo) wrote :

I got the same problem. after upgrade i only got a few icons on the
desktop I guess nautilus and the top I got a shadow and a few ghost
icons that works but is not visible.

Creating a new user and using that account it all works so it's some
configuration issue for my user.

tried to remove .gnome* .gconf and so on but nothing I did had any
effect.

Now I have installed fedora 15 instead so I'm not going to be able to do
any testing.

On Tue, 2011-05-31 at 08:22 +0000, David Barth wrote:
> Jason: so is this bug still critical, or is it in fact "invalid"?
>
> Emil: please can you report whether this solved your problem?
>
> ** Changed in: unity
> Milestone: 3.8.14 => 3.8.16
>

Jason Smith (jassmith) wrote :

This bug appears to be a user configuration issue. I am not saying this is not a problem, it is just not a bug we can action in the unity source. Leaving the distro bugs open.

Changed in unity:
status: Confirmed → Invalid
Didier Roche (didrocks) on 2011-06-08
Changed in unity:
status: Invalid → Confirmed
David Barth (dbarth) wrote :

The status of this bug is weird. It sounds like it cannot be reproduced outside of the reporters system, and has been qualified as a user configuration issue.
Didier: is it /really/ confirmed, or is that unify tagging it as such?

Until further evidence of the issue, test cases and logs are provided, I don't think it it an SRU target anymore.

Changed in unity:
assignee: Jason Smith (jassmith) → nobody
importance: Critical → Medium
milestone: 3.8.16 → none
status: Confirmed → Incomplete
assignee: nobody → Jason Smith (jassmith)
Changed in unity (Ubuntu Natty):
milestone: natty-updates → none
Didier Roche (didrocks) on 2011-06-20
Changed in unity:
status: Incomplete → Confirmed
arpanaut (johnmac) wrote :

This bug is affecting me, both on the live desktop iso since July 4, and an HDD install since I updated it on about the same date.
I can access things in the top panel and the launcher, except BFB, applications, and folders.
Also zeitgeist crashes within 15-20 seconds of getting to the desktop. That bug is reported too.
All was well until Updates and new daily iso around July 3-4.

David Barth (dbarth) wrote :

@arapanaut: i'm not denying that you may have issue with our software, but in this state i don't have enough information to know what the problem is.

1. Can you check the original reporter workaround, ie deleting your ~/.drirc
2. If that's unrelated, can you file another bug stating more clearly the version of the software (Natty, Oneiric) and package versions that are affected
3. Can you reproduce the problem and if so what are the different steps to be able to reproduce?

Thanks

Changed in unity (Ubuntu Oneiric):
status: Confirmed → Incomplete
Changed in unity (Ubuntu Natty):
status: Confirmed → Incomplete
Changed in unity:
status: Confirmed → Incomplete
Brad Figg (brad-figg) on 2011-09-02
tags: added: rls-mgr-o-tracking
Stephan Frank (sfrank) wrote :

I am affected as well by this bug. My system is an upgrade from 11.04 with the fglrx driver (though I don't think the gfx driver matters for this problem). A second account is running unity without problems. So far I have removed all config directories (.compiz* .gconf* .metacity .gnome2*; .drirc does not exist) that I can think of which may affect the observed behaviour, but so far no luck. Anything you want me to try? Does unity store its data somewhere else I didn't think of?

The main difference between the two accounts I can think of is that the working one never ran unity while the non-working one ran unity 11.04 once. Though this may as well be a red herring for this bug.

Activating the compiz/unity ppa also didn't help.

Neil J. Patel (njpatel) wrote :

Hi, for the people still getting this, and who do not have a ~/.drirc, could you please check whether or not you have a /etc/drirc? If so, could you rename it temporarily and see if that fixes it?

@Stephan: In the session where it doesn't work, try doing `unity --reset` from a terminal and see what happens (seems like you're suffering from a slightly different issue).

Stephan Frank (sfrank) wrote :

Hi Neil,

please find attached the log file for the unity reset as well as the
xsession-errors file which contains some errors, but I don't know
whether they are relevant or how to resolve them.

Kind regards,
Stephan

Changed in unity (Ubuntu Oneiric):
status: Incomplete → Confirmed
David Barth (dbarth) on 2011-09-16
Changed in unity:
assignee: Jason Smith (jassmith) → Neil J. Patel (njpatel)
Changed in unity (Ubuntu Natty):
assignee: Jason Smith (jassmith) → Neil J. Patel (njpatel)
Changed in unity:
milestone: none → 4.18.0
moragos (moragos) wrote :

I just wanted to notify that the problem was solved to me.
I did not have any of the drirc folders. Nor any of the suggested solution solved my problem.

My guess is one of updates fixed the issue, but I have no idea which. (i haven't checked the issue is fixed for a while)

Stephan Frank (sfrank) wrote :

With the changes that came in through the unity/compiz ppa today my
problems have been solved as well. Many thanks for your effort.

Jason Smith (jassmith) wrote :

Marking fixed due to user comments, please re-open if confirmed still valid

Changed in unity:
status: Incomplete → Fix Released
Changed in unity (Ubuntu Oneiric):
status: Confirmed → Fix Released
Changed in unity (Ubuntu Natty):
status: Incomplete → Won't Fix
Matti Laakso (matti-laakso) wrote :

This not fixed. I got hit by it today, but logging out and back in made everything visible again. I have neither ~/.drirc nor /etc/drirc.

Matti Laakso (matti-laakso) wrote :

There's some error in .xsession-errors, otherwise logs seem clean to me.

Sebastian Mitterle (mathume) wrote :

Confirmed. I have the same problem.
Config:
Ubuntu 11.10
Session: Unity 2d
Launcher: Cairo-Dock, Metacity compositing on
Maximus: no_maximize true

Symptom: Panel, Cairo-Dock disappear but seem to be present (mouse clicks open applications/menues).
Happens always after restoring maximized Thunderbird.
Don't have .drirc either.

Sebastian Mitterle (mathume) wrote :

Confirmed. I have the same problem.
Config:
Ubuntu 11.10
Session: Unity 2d
Launcher: Cairo-Dock, Metacity compositing on
Maximus: no_maximize true

Symptom: Panel, Cairo-Dock disappear but seem to be present (mouse clicks open applications/menues).
Happens always after restoring maximized Thunderbird.
Don't have .drirc either.

Attached .xsession-errors (useful?)

Bálint Magyar (balintm) wrote :

Please file a new bug with "ubuntu-bug unity-2d" as this problem was related to Unity, not Unity 2D.

Mindaugas Jakutis (la-mj) wrote :

I ran into this one as well with oneiric live cd (i386) on my old desktop running nvidia gf fx5600.

The live cd installer loads and looks ok but after chosing to test ubuntu from cd instead, unity loads and everything goes haywire. Only the top right indicators, window title on the top left and the sidebar shadow are visible. If I hover over the (what should be) sidebar launchers their titles are displayed with a tooltip. Windows and controls are there, cand be interacted with but are invisible. Installer is unusable as well.

Both Ubuntu and Ubuntu 2D sessions affected. No .drirc in sight (again, it's the official live cd)

If you choose to install right away instead, all goes well. Since I chose to install updates and 3rd party software, nvidia-96 was installed and the problem disappeared at first boot. Changing to nvidia-173-updates introduced no problems as far as I can tell.

To post a comment you must log in.