Ubuntu

Mouse edge + button doesn't work

Reported by jeanphilippe.green@gmail.com on 2011-04-15
216
This bug affects 46 people
Affects Status Importance Assigned to Milestone
Unity
Medium
Unassigned
compiz (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: compiz

In Ubuntu 11.04 beta2 with the unity interface:

I tried to set up the scale plugin to activate when middle-clicking in the top left corner, but it doesn't work. Just having a hot corner works though, but that's not what I want. The problem doesn't only occur in the scale plugin bu also all other plugins I've tried to customize through ccsm.

glazs (l-admin-rock-su) wrote :

Yes, all edges / sides click not working, using 10.04b2 x64.
Unity / Classic not working both,
Resetting compiz settings not helped.

glazs (l-admin-rock-su) on 2011-04-18
Changed in compiz (Ubuntu):
status: New → Incomplete
status: Incomplete → Confirmed
glazs (l-admin-rock-su) wrote :

using 11.04b2 x64 i mean

Michael Zhou (zhoumotongxue008) wrote :

Same here, pure edge works but not edge+mouse.

CarloBaldassi (carlobaldassi) wrote :

Confirming this (exactly as described above) with 11.04 32-bit final.

BryanFRitt (bryanfritt) wrote :

Sounds like it's the same bug as this:
http://bugs.compiz.org/show_bug.cgi?id=18

@BryanFRitt
Yes it does.

Also, it doesn't work with Unity2D with Compiz enabled (no surprise there)

This really bothers me, but I guess it won't be fixed anytime soon since it only affects the slightly more advanced users, not the "human beings".

BryanFRitt (bryanfritt) wrote :

Reverting Compiz 0.9.2.1*, fixed this mouse edge + button problem(and others, like - window movement smoothness, grid plugin, some shortcuts, etc...), in K/Ubuntu 11.04 (at least for me)

*I modified script I found to compile this.
*It's possible that going to an earlier version might reintroduce some other bugs, like invisible windows, etc...
http://smspillaz.wordpress.com/2011/04/17/death-to-all-things-invisible/

Boogeyman (boogeyman79) wrote :

Also affecting Ubuntu Classic x64

Chethan S. (chethan) wrote :

Affects me too in Ubuntu 11.04 64-bit for ring switcher. I tried with right edge + mouse click. Tried other edges too, but doesn't work!

Franko Burolo (fburolo) wrote :

Same here! And it is an Ubuntu Natty 64 system, too... Fact is that we are using a development (unstable) version of Compiz: http://wiki.compiz.org/. I guess that Unity is not compatible with Compiz 0.8.8 -- the latest stable release. This is just one of the many Compiz-related bugs I have experienced in Natty... :-/

same here also...

Same problem, I try to downgrade to compiz 0.8.8, it's not possible without losing Unity. So a workaround, is removing Unity and installing by dpkg -i *.deb, all the packages for the version 0.8.8 available for maverick. Kind. http://ppa.launchpad.net/compiz/ppa/ubuntu/pool/main

Mauricio Sica (mp-sica) wrote :

Same problem (11.04 with gnome or unity). "Expo edge" works fine, but "Expo button" dosen't

frado (frado65) wrote :

I've the same problem with 11.04 64bit, it is very annoying to me.

algoban (algoban) wrote :

Hi

I upgrade today and i have the same problem. Actually for me compiz is almost useless because is the main feature I use to move through workspaces.

cornbread (corn13read) wrote :

I would go back to ubuntu 10.10 but my hardware isn't supported... This is a major damper on my usability!

cornbread (corn13read) wrote :

Just downgrade compiz by following this simple guide:
http://www.webupd8.org/2011/05/how-to-downgrade-to-compiz-086-in.html

Until this bug is resolved:
http://bugs.compiz.org/show_bug.cgi?id=18

Marcos Diaz (marcos-diaz) wrote :

I confirm this bug. My workflow is seriosly damaged until I can use my Compiz bindings again, so I go back to Gnome for now, I hope this will be fixed before next Ubuntu version.

I'm sorry to hear that there is no solution to this problem. it is the first
time that the solution (for me) was downloading the ubuntu distro. I'll wait
for the imrpovements in 11.10.

The fix will be upcoming in oneric

On Thu, Jun 2, 2011 at 1:14 AM, Mauricio Sica <email address hidden> wrote:
> I'm sorry to hear that there is no solution to this problem. it is the first
> time that the solution (for me) was downloading the ubuntu distro. I'll wait
> for the imrpovements in 11.10.
>
> --
> You received this bug notification because you are a member of compiz
> packagers, which is subscribed to compiz in Ubuntu.
> https://bugs.launchpad.net/bugs/761616
>
> Title:
>  Mouse edge + button doesn't work
>
> _______________________________________________
> Mailing list: https://launchpad.net/~compiz
> Post to     : <email address hidden>
> Unsubscribe : https://launchpad.net/~compiz
> More help   : https://help.launchpad.net/ListHelp
>

--
Sam Spilsbury

Marcos Diaz (marcos-diaz) wrote :

No way to launch an update to Natty? some kind of workaround? common guys!

Marcos Diaz (marcos-diaz) wrote :

The bug seems to be in compiz itself, not unity... (https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/754948) anyway I need this feature back or I'll die.

Sam Spilsbury (smspillaz) wrote :

Perhaps we can provide a backport if time permits

On Sun, Jun 5, 2011 at 5:55 PM, Marcos Diaz <email address hidden> wrote:
> The bug seems to be in compiz itself, not unity...
> (https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/754948) anyway I
> need this feature back or I'll die.
>
> --
> You received this bug notification because you are a member of compiz
> packagers, which is subscribed to compiz in Ubuntu.
> https://bugs.launchpad.net/bugs/761616
>
> Title:
>  Mouse edge + button doesn't work
>
> _______________________________________________
> Mailing list: https://launchpad.net/~compiz
> Post to     : <email address hidden>
> Unsubscribe : https://launchpad.net/~compiz
> More help   : https://help.launchpad.net/ListHelp
>

--
Sam Spilsbury

Changed in compiz (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
milestone: none → oneiric-alpha-2
Changed in unity:
importance: Undecided → Medium
status: New → Confirmed
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
milestone: none → alpha2
CarloBaldassi (carlobaldassi) wrote :

I am trying the 1-line patch from here:
http://bugs.compiz.org/show_bug.cgi?id=18#c10
and it seems to work.

cornbread (corn13read) wrote :

how do i apply the patch?

Didier Roche (didrocks) on 2011-07-05
Changed in unity:
milestone: 4.2.0 → 4.4.0
Martin Pitt (pitti) on 2011-07-07
Changed in compiz (Ubuntu):
milestone: oneiric-alpha-2 → oneiric-alpha-3
Didier Roche (didrocks) on 2011-07-21
Changed in unity:
milestone: 4.4.0 → 4.6.0
Didier Roche (didrocks) on 2011-08-01
Changed in unity:
milestone: 4.6.0 → 4.8.0
Ross Brunton (ross-brunton) wrote :

I am getting this in 11.10 64bit after a lot of updates, it worked fine before.

Andrea Azzarone (andyrock) wrote :

I can no longer reproduce this bug.

Works well now for me. Anybody still seeing this bug? Otherwise we should close it.

Omer Akram (om26er) wrote :

Closing the bug as there have been two comments regarding of it not being an issue anymore

Changed in unity:
milestone: 4.8.0 → none
Changed in compiz (Ubuntu):
milestone: oneiric-alpha-3 → none
Changed in unity:
assignee: Sam Spilsbury (smspillaz) → nobody
Changed in compiz (Ubuntu):
assignee: Sam Spilsbury (smspillaz) → nobody
Changed in unity:
status: Confirmed → Invalid
Changed in compiz (Ubuntu):
status: Confirmed → Invalid
glazs (l-admin-rock-su) wrote :

Sorry, but Unity panel eats left edge click. Left edge click is impossible.

Changed in compiz (Ubuntu):
status: Invalid → Incomplete
Changed in unity:
status: Invalid → Incomplete
Denis (denis-sokolov) wrote :

The bug is still here.
I am not running Unity. 11.04 with Gnome 2.
Nothing has changed - all four edges don't react to the bindings.
I have update-upgraded, restarted X, cleared bindings and set them again - no result.

glazs (l-admin-rock-su) wrote :

Denis (denis-sokolov), you need to install fresh version of compiz, or old, but stable. I using 0.8, and have much less problems.

@glazs
I just tried left edge click. Works for me on Ubuntu 11.10.

Franko Burolo (fburolo) wrote :

Yes, the issue is sloved in Oneiric, but it is true that the Unity launcher is in the way. Clickin on the left edge works, but at the same time the launcher starts the app you accidentally clicked near...

Omer Akram (om26er) wrote :

closing the bug since there have been two confirmations for the fix. feel free to report any other bugs you may find.

Changed in unity:
status: Incomplete → Invalid
Changed in compiz (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.