Unity launcher icons tooltips do not disappear when switching workspaces

Bug #744795 reported by tankdriver on 2011-03-29
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

Steps to reproduce:
- open (not maximized)application(1) on workspace 1
- open another (not maximized)application(2) on workspace 2
- click on the launcher icon to get back to application(1) and quickly move the mouse away from the launcher

What I expected to happen:
- tooltipp of the last clicked Launcher Icon disappears quickly.

What happened instead:
- tooltipp of the last clicked Launcher Icon does not disappear and stays on top forever until the mouse is moved to the Launcher or to the top panel.

This "bug" appeared with a daily-live live session.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.6.8-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
DRM.card0.DP.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.DP.2:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI.A.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1366x768
 edid-base64: AP///////wAw5AECAAAAAAATAQOAHxF4CohFlVpWjSgjUFQAAAABAQEBAQEBAQEBAQEBAQEBVh1WxlAAIDAwIDUANq4QAAAZAAAAAAAAAAAAAAAAAAAAAAAAAAAA/gBMRyBEaXNwbGF5CiAgAAAA/ABMUDE0MFdIMi1UTEExADk=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Tue Mar 29 07:12:03 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
GdmLog1:

GdmLog2:

GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Device [1025:022a]
   Subsystem: Acer Incorporated [ALI] Device [1025:022a]
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110328.1)
LiveMediaBuild_: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110328.1)
LiveMediaBuild__: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110328.1)
MachineType: Acer Aspire 4810T
ProcEnviron:
 LANGUAGE=de_DE:en
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz acpi_backlight=vendor quiet splash -- debian-installer/language=de console-setup/layoutcode?=de
ProcVersionSignature_: Ubuntu 2.6.38-7.39-generic 2.6.38
ProcVersionSignature__: Ubuntu 2.6.38-7.39-generic 2.6.38
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/13/2010
dmi.bios.vendor: INSYDE
dmi.bios.version: V1.35
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Aspire 4810T
dmi.board.vendor: Acer
dmi.board.version: Base Board Version
dmi.chassis.type: 1
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvrV1.35:bd04/13/2010:svnAcer:pnAspire4810T:pvrV1.35:rvnAcer:rnAspire4810T:rvrBaseBoardVersion:cvnChassisManufacturer:ct1:cvrChassisVersion:
dmi.product.name: Aspire 4810T
dmi.product.version: V1.35
dmi.sys.vendor: Acer
version.compiz: compiz 1:0.9.4git20110322-0ubuntu5
version.libdrm2: libdrm2 2.4.23-1ubuntu5
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu11
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu6

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
status: New → Confirmed
Didier Roche (didrocks) wrote :

Hey tankdriver , I think I fixed it with the beta2 release version, can you check and reopen if it's not the case?

Changed in unity:
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Fix Released

I have unity 3.8.6-0ubuntu1 (and compiz 1:0.9.4+bzr20110411-0ubuntu1) installed and i still can reproduce this bug.
(tried "unity --reset" command and guest session too)

Now I will wait until natty Beta 2 is officially out and check again from a live-session or fresh install.

Another thought: Could this bug be related to bug #356702 (Tooltips stick when switching desktops (Compiz)) ??? , because I came across this bug in older ubuntu releases and its really quite the same behavior.

summary: - Unity launcher icons tooltipps do not disappear when swiching workspaces
+ Unity launcher icons tooltips do not disappear when swiching workspaces

I checked todays daily-live. the bug is still there.

Changed in unity (Ubuntu):
status: Fix Released → Confirmed
Changed in unity:
status: Fix Released → Confirmed
Didier Roche (didrocks) wrote :

This time, just fixed in trunk! Should be there with unity 3.8.8. Do not hesitate to reopen it if it's not the case (I tried to reproduce it 10 times after the fix and I couldn't ;))

Changed in unity:
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Changed in unity:
milestone: none → 3.8.8
Didier Roche (didrocks) on 2011-04-14
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.8.8-0ubuntu1

---------------
unity (3.8.8-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Empty desktop after login (LP: #687660)
    - compiz crashed with SIGSEGV in nux::Area::InitiateResizeLayout()
      (LP: #757709)
    - compiz crashed on initial load of Java Citrix Client/Inkscape in
      PrivateWindow::processMap() (LP: #758307)
    - Sometimes dragging down from the panel just stops working (LP: #750155)
    - Ensure Unity prioritises icon loading from Unity-icon-theme
      (LP: #750471)
    - text truncated in Dash. Empty search from Applications or Files lense
      returns “Your search did not” due to cut off label (LP: #757362)
    - should list PlacesGroup.cpp in POTFILES.in (LP: #757663)
    - Launcher intellhide stuck after edge reveal (LP: #757810)
    - unity-preferences doesn't load translations (LP: #759682)
    - dynamic quicklists are not working (LP: #729074)
    - with second monitor, first monitor does not show nautilus
      application/global menu when displaying desktop (LP: #743149)
    - Launcher - The Workspace, File Lens, App Lens and Trash Launcher icons
      need to be rendered correctly (LP: #745555)
    - the launcher background gets dimmed after icons dnd (LP: #747304)
    - Numpad 'Enter' does not work on unity launcher when navigating through
      keyboard (LP: #760003)
    - Launcher shouldn't hover when being in the dash (LP: #760770)
    - Launcher displays key shortcuts while holding Super while the dash is
      open but the shortcuts are unfunctional (LP: #760728)
    - Running/active indicators point to space between launcher icons for
      folded icons (LP: #703067)
    - user-trash.svg and user-trash-full.svg not lens grayscale versions
      (LP: #741804)
    - code-cleanup: unregistered any established ubus-interests (LP: #757588)
    - dropdown box in places search bar does not resize when font size changes
      (LP: #759763)
    - [FFE] Centered layout for expo plugin (LP: #754689)
    - Unity launcher icons tooltips do not disappear when swiching workspaces
      (LP: #744795)
    - Dash - Update Dash scroll bar (LP: #750374)
    - Letters cut off at the end in the applications window (LP: #753083)
  * debian/control:
    - build-dep on grail/geis with version bumped
  * 01_dont_dep_on_latest_geis_grail.patch:
    - not needed anymore
 -- Didier Roche <email address hidden> Thu, 14 Apr 2011 22:03:42 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Bernhard (b.a.koenig) wrote :

Problem is still there for me in unity 3.8.12. Sometimes tooltips do not disappear and stick. I cannot give steps to reproduce as it seems to happen randomly. It's usually connected to a workspace switch though as described by the bug reporter. I will reopen.

Bernhard (b.a.koenig) wrote :

Actually, I don't have the rights to reopen the bug.

summary: - Unity launcher icons tooltips do not disappear when swiching workspaces
+ Unity launcher icons tooltips do not disappear when switching workspaces
Bruno Santos (bsantos) wrote :

Does anyone else has this on 12.10? I wish we could disable the tooltips altogether...

Aditya Kashi (aditya-kashi) wrote :

I still experience this bug even in Ubuntu 16.04!! This is one persistent issue.

mickEDK (mickedk) wrote :

Same here. An annoying feature wherein the tag text obscures what I need to see.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers