Windows that reparent away from the root before they are mapped can cause other windows to become invisible (and compiz to crash)

Bug #743011 reported by Kalle Valo on 2011-03-26
206
This bug affects 41 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Sam Spilsbury
unity (Ubuntu)
Critical
Sam Spilsbury

Bug Description

Binary package hint: unity

I started gitk and compiz crashed.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: unity 3.6.8-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
Architecture: amd64
CrashCounter: 1
Date: Sat Mar 26 11:01:14 2011
ExecutablePath: /usr/bin/compiz
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x43bef0 <_ZN10CompWindow2idEv>: mov 0x58(%rdi),%rax
 PC (0x0043bef0) ok
 source "0x58(%rdi)" (0x00000058) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 CompWindow::id() ()
 CompScreen::handleEvent(_XEvent*) ()
 PrivateCompositeScreen::handleEvent(_XEvent*) () from /usr/lib/compiz/libcomposite.so
 CompScreen::handleEvent(_XEvent*) ()
 PrivateGLScreen::handleEvent(_XEvent*) () from /usr/lib/compiz/libopengl.so
Title: compiz crashed with SIGSEGV in CompWindow::id()
UpgradeStatus: Upgraded to natty on 2011-02-04 (50 days ago)
UserGroups: adm admin cdrom dialout dip fax floppy fuse libvirtd lpadmin plugdev sambashare sudo tape video
XsessionErrors:
 (nautilus:2229): Gtk-WARNING **: Change Desktop Background: missing action Change Desktop Background
 (nautilus:2229): Gtk-WARNING **: Ubuntu Documentation: missing action Ubuntu Documentation
 (nautilus:2229): Gtk-WARNING **: Change Desktop Background: missing action Change Desktop Background
 (nautilus:2229): Gtk-WARNING **: Ubuntu Documentation: missing action Ubuntu Documentation
 (nautilus:2229): GConf-CRITICAL **: gconf_value_free: assertion `value != NULL' failed

Kalle Valo (kvalo) wrote :
Kalle Valo (kvalo) on 2011-03-26
Changed in unity (Ubuntu):
importance: Undecided → Critical

Gitk is doing some fun things with its window. Investigating.

summary: - compiz crashed with SIGSEGV in CompWindow::id()
+ Launching gitk causes invisible window then crash
Changed in unity (Ubuntu):
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
milestone: none → ubuntu-11.04-beta-1
visibility: private → public
summary: - Launching gitk causes invisible window then crash
+ Windows that reparent away from the root before they are mapped can
+ cause other windows to become invisible (and compiz to crash)
Changed in unity:
importance: Undecided → Critical
status: New → Fix Committed
Changed in unity (Ubuntu):
status: New → Fix Committed
Changed in unity:
milestone: none → 3.8
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
tags: removed: need-amd64-retrace
Gary M (garym) wrote :

This bug is currently reported against unity, but duplicate bug #743932 happened for me in a "classic" gnome desktop session. And the "related branch" on this bug seems to be for compiz.

Omer Akram (om26er) wrote :

the linked branch is for compiz ;)

Kate Stewart (kate.stewart) wrote :

Not a blocker for beta-1, but needs to be fixed in update shortly after. Adjusting milestone to reflect discussions.

Changed in unity (Ubuntu):
milestone: ubuntu-11.04-beta-1 → ubuntu-11.04
Kate Stewart (kate.stewart) wrote :

need this fixed by beta-2 timeframe.

Changed in unity (Ubuntu):
milestone: ubuntu-11.04 → ubuntu-11.04-beta-2
Neil J. Patel (njpatel) on 2011-03-31
Changed in unity:
milestone: 3.8 → 3.8.2
Didier Roche (didrocks) on 2011-04-01
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package unity - 3.8.2-0ubuntu1

---------------
unity (3.8.2-0ubuntu1) natty; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in std::_List_node_base::_M_hook()
      (LP: #711916)
    - New window tracking system breaks in the case where windows try to
      restack relative to destroyed windows that were never mapped
      (LP: #723014)
    - does not display icons until hovered (LP: #726033)
    - Unity Launcher has black spaces where icons should be (LP: #729353)
    - compiz crashed with SIGSEGV in sigc::internal::signal_emit0<void,
      sigc::nil>::emit() (LP: #729715)
    - compiz crashed with SIGSEGV in SimpleLauncherIcon::OnIconThemeChanged()
      (LP: #741652)
    - compiz crashed with SIGSEGV in free() (LP: #738864)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #741674)
    - compiz crashed with SIGSEGV in free() (LP: #742300)
    - Unity can't get touch the touch initialization signals from GEIS
      (LP: #742555)
    - Windows that reparent away from the root before they are mapped can
      cause other windows to become invisible (and compiz to crash)
      (LP: #743011)
    - compiz crashed with SIGSEGV in gdk_cairo_set_source_pixbuf()
      (LP: #744231)
    - [dash] Keyboard navigation not implemented as specified (LP: #608132)
    - xterms broken in unity (LP: #692463)
    - Unity opens application menu on Alt+F10 shortcut (LP: #722674)
    - First four items in Dash begin "Find" "Find" "Find" "Find" (LP: #729002)
    - Increase the size of the top left Launcher reveal area from 1px to a
      slightly larger triangle that comes out of the top left corner
      (LP: #736034)
    - Add a test case for invisible windows regressions (LP: #736876)
    - Re-sync with xquerytree to avoid stacking order issues (LP: #740465)
    - Keyboard navigation: quicklist not opening for Trash launcher item
      (LP: #741793)
    - Wrong window moves (LP: #741656)
    - compiz crashed with SIGSEGV in
      SimpleLauncherIcon::ActivateLauncherIcon() (LP: #742110)
    - Combo in the search bar did not disappear after the places was closed
      (LP: #742712)
    - Expo doesn't quit reliably when using keynav or shortcut (LP: #744196)
    - Make the BFB icon turn blue when an application goes urgent
      (LP: #744973)
    - Launcher - increase "launcher reveal %" for 'Fade and slide' launcher
      reveal transition to 65% (LP: #745602)
    - Arrows do not fade out with rest of launcher durring DND (LP: #746811)
    - Don't create windows over the launcher (LP: #688816)
    - Launcher - Indicate which application is currently focused with a
      glowing Launcher icon (LP: #676604)
    - Unity Grid is broken for multi-monitor setups (LP: #709221)
    - dynamic quicklists are not working (LP: #729074)
    - When windows open for the first time they should not hide the launcher
      (LP: #723878)
    - it is still possible to quit unity from the panel (LP: #733725)
    - Selection does not fit small icons in Unity Dash (LP: #735746)
    - Unmounting media gives no error when failed (LP: #737633)
    - ATI/fglrx workaround patch (LP: #740298)
    - "Files & Folders" tooltip say...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Michal Matyska (michal-matyska) wrote :

I suggest to unduplicate bug #743932 ... I'm getting compiz crashed every time gitk (and other apps using Tcl/Tk) starts - using Ubuntu Classic not unity. That's also reason, why unity-3.8.2 didn't help me.

Maxim Dobriakov (closer-main) wrote :

I have installed unity 3.8.2 and restarted comp. After that I run gitk and unity crash appear again. So, unity 3.8.2 didn't fix it.

This is information about crash from kern.log:

Apr 1 23:25:58 coreduo kernel: [ 86.641417] show_signal_msg: 30 callbacks suppressed
Apr 1 23:25:58 coreduo kernel: [ 86.641421] compiz[1298]: segfault at 2c ip 0807ffe7 sp bfdd11fc error 4 in compiz[8048000+6c000]

Didier Roche (didrocks) on 2011-04-04
Changed in unity:
status: Fix Released → Fix Committed
milestone: 3.8.2 → 3.8.4
Didier Roche (didrocks) on 2011-04-07
Changed in unity:
status: Fix Committed → Fix Released
Peter Dietz (pdietz84) wrote :

I run gnome, 11.04, beta2, "Ubuntu Classic", and typing "gitk" from a git repo causes the screen to flash, and then flicker back but messed up, and the system is frozen. I've installed all updates before trying this.

I've noticed that if I manually change Tk/wish to 8.5, running gitk no longer crashes. However, returning it back to the default, and running gitk will cause the crash.
Changing to tk8.5:
sudo apt-get install tk8.5
sudo update-alternatives --config wish
## select /usr/bin/wish8.5 from the list.

So, I'm hoping someone more qualified than me can check on this.
Also, I'm not sure which bug is most relevant to post in, since they are all so similar.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers