Dragging the launcher with right mouse button is confusing as menu pops up

Bug #735031 reported by Friedrich on 2011-03-14
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Andrea Azzarone
unity (Ubuntu)
Low
Unassigned
Natty
Low
Unassigned

Bug Description

=== Test case ===

1. Install unity 3.8.16 from natty-proposed
2. Restart unity (logout/login or compiz --replace)
3. Right-click on launcher but don't let go of the right mouse button (keep it pressed)
4. Drag mouse down like you were dragging the launcher
5. Launcher should not drag, you should just get the QL menu opened

===

Binary package hint: unity

If I pull down the application panel from Unity, the context menu pop up. (like right click on a starter)

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.6.4-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
Uname: Linux 2.6.38-6-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Ist ein Verzeichnis: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 270.29 Wed Feb 23 16:18:35 PST 2011
 GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-5ubuntu2)
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,compiztoolbox,vpswitch,grid,mousepoll,imgpng,gnomecompat,water,move,regex,snap,wall,place,resize,shift,animation,workarounds,expo,session,ezoom,staticswitcher,fade,scale,ring,unityshell]
CompositorRunning: compiz
Date: Mon Mar 14 20:08:14 2011
DistUpgraded: Log time: 2011-03-08 22:09:20.913845
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 270.29, 2.6.38-6-generic, x86_64: installed
 nvidia-current, 270.29, 2.6.38-5-generic, x86_64: installed
 vboxhost, 4.0.4, 2.6.38-6-generic, x86_64: installed
GraphicsCard:
 nVidia Corporation GF106 [GeForce 450 GTS] [10de:0dc4] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: CardExpert Technology Device [10b0:0801]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110302)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110302)
InstallationMedia__: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110302)
JockeyStatus: xorg:nvidia_current - Beschleunigter Grafiktreiber von NVIDIA (Proprietär, Aktiviert, In Benutzung)
MachineType: System manufacturer System Product Name
ProcEnviron:
 LANGUAGE=de_DE:en
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-6-generic root=UUID=e50277c8-2f8f-4cdf-b807-fc1deb2b5087 ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
ProcVersionSignature__: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-03-08 (5 days ago)
dmi.bios.date: 08/24/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1005
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: M4A87TD/USB3
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1005:bd08/24/2010:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM4A87TD/USB3:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.4-0ubuntu4
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu1
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu11
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu5

Related branches

Friedrich (friedrich-waack) wrote :
Omer Akram (om26er) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

Changed in unity (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Paul Sladen (sladen) wrote :

Friedrich: it would probably be useful if you could post a screenshot too showing the issue, as I'm still not completely clear what it is that you're seeing.

You can take a screenshot with the 'PrintScreen' key, or if that isn't working because of the exact situation with 'Gimp's Acquire->From Screenshot... function and the delay timer if necessary.

Friedrich (friedrich-waack) wrote :

I don't know how to produce this bug, but I've made a screenshot.

Alex Launi (alexlauni) wrote :

When dragging the entire launcher, the long press timer doesn't get reset, and the quicklist is shown. This should be fairly easy to fix. The fixer can look at the code where an individual icon is dragged, so looking at that code and applying it to where the launcher drag code is should be a fair fix.

Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
status: Incomplete → Triaged
tags: added: bitesize
Changed in unity:
importance: Undecided → Low
Andrea Azzarone (azzar1) wrote :

@Alex Launi: I don't understand! When we have a right mouse down the quicklist is shown immediately... For me there could be two solutions:

1) Hide any quicklist when dragging the entire launcher
2) Show the quicklist after a timeout

To reproduce this bug:
right click on a launcher icon and drag it. The quicklist is not hidden!

Andrea Azzarone (azzar1) on 2011-06-03
Changed in unity:
status: Triaged → In Progress
assignee: nobody → Andrea Azzarone (andyrock)
Didier Roche (didrocks) on 2011-06-06
Changed in unity (Ubuntu):
status: Triaged → In Progress
Neil J. Patel (njpatel) on 2011-06-09
Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-06-09
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Neil J. Patel (njpatel) on 2011-06-16
summary: - If you pull down the application panel, the context menu pop up
+ Dragging the launcher with right mouse button is confusing as menu pops
+ up
Changed in unity:
milestone: none → 3.8.16
description: updated
Changed in unity (Ubuntu Natty):
importance: Undecided → Low
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.8.16-0ubuntu1

---------------
unity (3.8.16-0ubuntu1) oneiric; urgency=low

  * New upstream version:
    - Unable to load icon text-x-preview at size 48 in a loop (lp: #794556)
    - Display garbled upon restoring original resolution (lp: #795454)
    - Display garbled upon connecting external displays (lp: #795458)
    - Panel disappears after resolution change (lp: #795459)
    - Dragging the launcher with right mouse button is
      confusing as menu pops up (lp: #735031)
    - In a double monitor setup the Unity top panel in the second screen is
      cut at the right (lp: #750481)
    - Launcher tooltips sometimes don´t show (lp: #769335)
    - Menu key should open quicklist for the selected item in the launcher
      (lp: #750778)
    - unity is spamming ~/.xsession-errors when windows are closed
      (lp: #767642)
    - Dash button ignores transparency when clicked. (lp: #767733)
 -- Sebastien Bacher <email address hidden> Thu, 16 Jun 2011 18:10:09 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released

Accepted unity into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

The new version work as described, setting the bug verified.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.8.16-0ubuntu1~natty1

---------------
unity (3.8.16-0ubuntu1~natty1) natty-proposed; urgency=low

  * New upstream version:
    - Unable to load icon text-x-preview at size 48 in a loop (lp: #794556)
    - Display garbled upon restoring original resolution (lp: #795454)
    - Display garbled upon connecting external displays (lp: #795458)
    - Panel disappears after resolution change (lp: #795459)
    - Dragging the launcher with right mouse button is
      confusing as menu pops up (lp: #735031)
    - In a double monitor setup the Unity top panel in the second screen is
      cut at the right (lp: #750481)
    - Menu key should open quicklist for the selected item in the launcher
      (lp: #750778)
    - unity is spamming ~/.xsession-errors when windows are closed
      (lp: #767642)
    - Dash button ignores transparency when clicked. (lp: #767733)
  * Revert commit for bug #769335, to fix a launcher autohidding issue
 -- Sebastien Bacher <email address hidden> Fri, 17 Jun 2011 12:22:35 +0200

Changed in unity (Ubuntu Natty):
status: Fix Committed → Fix Released
Omer Akram (om26er) on 2011-07-18
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers