Cannot open a window that starts iconified

Bug #732997 reported by Michael Terry
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Compiz Core
High
Sam Spilsbury
Unity
Fix Released
High
Sam Spilsbury
compiz (Ubuntu)
High
Sam Spilsbury
unity (Ubuntu)
Undecided
Sam Spilsbury

Bug Description

Binary package hint: unity

Disclaimer: this may actually be a compiz bug.

Working on a program that wanted to start minimized, I ran into problems in unity. Calling gtk_window_iconify followed by gtk_widget_show *should* start the window minimized. But in unity, it never appears.

I had to show first, then iconify, which looks bad (a quick window appears, then disappears).

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.6.2-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
Uname: Linux 2.6.38-6-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
Date: Thu Mar 10 19:51:01 2011
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_GB.utf8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature_: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2010-09-28 (163 days ago)

Related branches

Revision history for this message
Michael Terry (mterry) wrote :
Revision history for this message
Alex Launi (alexlauni) wrote :

Can you provide a test case?

Changed in unity:
importance: Undecided → Low
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Revision history for this message
Michael Terry (mterry) wrote :

This test case should show just an iconified window (i.e. no window should be visible, but I should see an icon in the launcher). Instead, it shows an uniconified window.

Run like: vala --pkg=gtk+-2.0 no-extra-show.vala

Revision history for this message
Michael Terry (mterry) wrote :

Here's a simple way to workaround the problem, by adding a show() before the iconify() call, but it has the side-effect of flashing a window on the screen.

Run like: vala --pkg=gtk+-2.0 extra-show.vala

Revision history for this message
Sven Baars (sbte) wrote :

This bug affects emesene and causes conversation windows to never appear. In Natty, one could still access them through Alt+Tab, but in Oneiric, they're simply unreachable. This basically makes emesene useless in Oneiric.

I'm sending a dirty hack for this right now for emesene, but this should really be fixed in unity/compiz.

Jorge Castro (jorge)
Changed in unity (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in unity:
milestone: none → 4.16.0
Didier Roche (didrocks)
tags: added: didrocks-oneiric-list
Neil J. Patel (njpatel)
Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
importance: Low → Medium
Neil J. Patel (njpatel)
Changed in unity:
importance: Medium → High
Didier Roche (didrocks)
Changed in unity:
milestone: 4.16.0 → 4.18.0
Changed in unity:
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Changed in compiz-core:
status: New → Fix Committed
assignee: nobody → Sam Spilsbury (smspillaz)
importance: Undecided → High
milestone: none → 0.9.5.96
Didier Roche (didrocks)
Changed in unity:
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 4.18.0-0ubuntu1

---------------
unity (4.18.0-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - Screen corruption when resuming from suspend/hibernate (LP: #676166)
    - unity-panel-service crashed with SIGSEGV in bamf_factory_view_for_path()
      (LP: #764024)
    - Dash and launcher appear underneath windows (LP: #805087)
    - unity-panel-service crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #811401)
    - [Oneric] unity-panel-service crashed with SIGSEGV in getenv()
      (LP: #817691)
    - compiz crashed with SIGSEGV in unity::FilterBar::RemoveFilter()
      (LP: #845732)
    - crash on closing a window (LP: #856015)
    - Cannot open a window that starts iconified (LP: #732997)
    - Launcher - When useing Alt F1 launcher keyboard navigation, Launcher
      should not scroll until top or bottom of Launcher is reached
      (LP: #765749)
    - Stacking problem when switching between apps with multiple windows
      (LP: #802527)
    - Pull panel to de-maximize window occasionally not working in a secondary
      screen (LP: #802651)
    - Window under Dash gets focused if it opened later (LP: #830730)
    - Clickable areas of previously active window remains on 'Show Desktop'
      (LP: #836325)
    - A minimized window 'remains' behind on the desktop if
      /apps/compiz-1/plugins/unityshell/screen0/options/show_minimized_windows
      is set to true (LP: #847967)
    - a11y support on Unity is broken (LP: #851103)
    - compiz crashed with SIGSEGV in dee_model_get_tag() (LP: #840758)
    - crash when looping paint list in preparePaint (on closing windows)
      (LP: #853807)
    - Alt-Tab should not preview windows at excessively large sizes
      (LP: #854740)
    - Clicking on a tweet/message link sometimes does not work (LP: #790565)
    - Dragging a launcher icon makes it squashed (LP: #855761)
    - unable to unminimize gedit windows where more than one window where one
      has a dialog open (LP: #856030)
    - (oneiric) alt-tab UX doesn't work well on multi-monitor (LP: #855364)
    - Launcher shows on the primary monitor instead of the left most monitor
      (LP: #857668)
    - Keynav - pressing down key causes launcher items to jump up and down
      (LP: #858469)
    - Windows creep cross the screen with ALT+TAB (LP: #722830)
    - Minimize animation flickr when for maximized apps (LP: #737125)
    - All unity windows are invisible (panel, launcher, dash) (LP: #745996)
    - Dash "See 97 more results" has ~1 second of latency (LP: #731158)
    - Windows cannot be dragged down from panel if banshee closed to sound
      menu (LP: #781215)
    - no menu bar on top, compositing bug? (LP: #806358)
    - Launcher - a spread can accidentally be triggered during the 'dragging
      and dropping behind the Launcher' interaction (LP: #832988)
    - Impossible to navigate between panel menus when the mouse cursor is over
      the panel (LP: #834065)
    - Pressing alt on maximized window does show menu but not window controls
      (LP: #836274)
    - Application name drawn under Dash controls when window opens under Dash
      (LP: #838176)
    - Start ...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
David Barth (dbarth)
Changed in compiz (Ubuntu):
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → ubuntu-11.10
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.6-0ubuntu1

---------------
compiz (1:0.9.6-0ubuntu1) oneiric; urgency=low

  * New upstream release 0.9.6:
   - Windows which are marked transients of docks should be treated like docks (LP: #860397)
   - Applications which create multiple windows that are transients of each other can be given invalid stack positions (LP: #858625)
   - race condition in configureXWindow causes unpredicatable window geometry changes (LP: #860304)
   - invisible window when a window is mapped but not yet drawn on by the process mapping it (LP: #860286)
   - resizing bugs with xterm (LP: #854725)
   - Cannot open a window that starts iconified (LP: #732997)
   - maximized windows fail to update their input extents when undecorated (LP: #853734)
   - Clicking on a tweet/message link sometimes does not work (LP: #790565)
   - crash on closing a window (LP: #856015)
   - Windows move to 0,0 on compiz restarts (LP: #858629)
   - windows that are decorated while resizing can cause incorrect resize results (LP: #860306)
   - remove transient window handling from unity-window-decorator (LP: #856096)
 -- Didier Roche <email address hidden> Wed, 28 Sep 2011 14:15:21 +0200

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Sven Baars (sbte) wrote :

This bug is still not fixed for emesene, because it uses multiple windows. I attached a test showing the problem:

if one window is shown, the other (iconified) window won't pop up if you click on the launcher entry.

This means that emesene is still useless in Oneiric with the default settings.

Changed in compiz-core:
milestone: 0.9.5.96 → 0.9.7.0
Changed in compiz-core:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers