Ubuntu

F10 is captured even if gnome-terminal setting is explictly set to not capture

Reported by Natalia Bidart on 2011-02-28
576
This bug affects 127 people
Affects Status Importance Assigned to Milestone
Unity
Medium
Unassigned
unity (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: appmenu-gtk

When disabling the capture of the F10 key in gnome-terminal as per http://ubuntuone.com/p/fJV/, I expect that pressing that key will send the event to the program running in the terminal (like midnight commander).

Right now, F10 is captured no matter what and the gnome-terminal menu is opened instead.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: appmenu-gtk 0.1.94-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Mon Feb 28 13:27:59 2011
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: appmenu-gtk

Natalia Bidart (nataliabidart) wrote :
Michael Terry (mterry) on 2011-02-28
Changed in appmenu-gtk (Ubuntu):
assignee: nobody → Michael Terry (mterry)
Michael Terry (mterry) wrote :

This appears to be because the unity compiz plugin now intercepts F10 instead of GTK+. I'll have to ask why that is.

Michael Terry (mterry) wrote :

As a workaround, you can use ccsm (unity plugin) or gconf-editor (/apps/compiz-1/plugins/unityshell) to tell unity not to intercept F10.

Michael Terry (mterry) on 2011-03-04
affects: appmenu-gtk (Ubuntu) → unity (Ubuntu)
Changed in unity (Ubuntu):
assignee: Michael Terry (mterry) → nobody
Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
Neil J. Patel (njpatel) wrote :

F10 was wrong to capture in the first place, as we're getting into capturing app-level keys. I'm going to change the default for global focus on the panel to Alt+F10, but F10 will still work for toolkits that support it (i.e. Gtk).

Changed in unity:
importance: Undecided → High
milestone: none → 3.6.2
status: New → Triaged
Didier Roche (didrocks) on 2011-03-04
Changed in unity (Ubuntu):
status: New → Triaged
Neil J. Patel (njpatel) on 2011-03-07
Changed in unity:
milestone: 3.6.2 → 3.6.4
Didier Roche (didrocks) on 2011-03-10
Changed in unity:
milestone: 3.6.4 → 3.6.6
Dylan McCall (dylanmccall) wrote :

Neil, Alt-F10 is used for maximizing a window. Wouldn't something like Super-F10 line up with the convention established in the launcher?

Neil J. Patel (njpatel) on 2011-03-17
Changed in unity:
milestone: 3.6.6 → 3.6.8
Didier Roche (didrocks) on 2011-03-24
Changed in unity:
milestone: 3.6.8 → 3.8
Didier Roche (didrocks) on 2011-03-28
Changed in unity:
milestone: 3.8 → 3.8.2
Didier Roche (didrocks) on 2011-04-01
Changed in unity:
milestone: 3.8.2 → 3.8.4
Didier Roche (didrocks) on 2011-04-07
Changed in unity:
milestone: 3.8.4 → 3.8.6
Didier Roche (didrocks) on 2011-04-11
Changed in unity:
milestone: 3.8.6 → 3.8.8
David Barth (dbarth) wrote :

There is a workaround, the priority is downgraded to medium. SRU target or later.

Changed in unity:
importance: High → Medium
Didier Roche (didrocks) on 2011-04-14
Changed in unity:
milestone: 3.8.8 → 3.8.10
Didier Roche (didrocks) on 2011-04-19
Changed in unity:
milestone: 3.8.10 → 3.8.12
David Barth (dbarth) on 2011-04-22
Changed in unity:
milestone: 3.8.12 → backlog
Didier Roche (didrocks) wrote :

They key can changed in ccsm, (in the unity plugin page). The keygrab issue is something to fix for oneiric (as for the super key issue).

Changed in unity:
assignee: Neil J. Patel (njpatel) → nobody
Changed in unity (Ubuntu):
importance: Undecided → Medium
gstoychev (gssatcc-hotmail) wrote :

And it's not fixed in oneiric

Felix Haller (felixhaller) wrote :

confirmed...

Denis Larka (denis-larka) wrote :

+1.
problem still exist plus described workarounds doesn't work!

Jiri Vaclavovic (jvaclavovic) wrote :

Workaround: Install and run Compiz configuration settings manager, select Ubuntu Unity plugin and change (remove) key to open the first panel menu

That doesn't work when one is using unity-2d. I don't have a working workaround right now...

I can also confirm that there is no way to disable wrong F10 behaviour in Unity 2D.

I wish people were thinking before implementing Unity -bugs- features.

As a developer using Unity 2D, this is an *EXTREMELY* annoying bug - it seriously hampers my ability to debug a program when my OS has apparently hard-coded my preferred "step-over" key mapping to "show first menu".

If anyone has discovered a workaround for this, please tell, otherwise perhaps the importance should be upgraded back to 'high'?

My workaround (after seeing that this bug is going to be ignored like most of the bugs I watch/contribute to): Switch to Gnome Classis. Not only does the F10 key work but the system is *way* more responsive. Unity is a failure.

Also still in 12.04, naturally.

Funny thing... with the latest updates in 12.04, F10 now also opens the pop up context menu in the terminal (the one you get when you right-click on the mouse). If you're looking to eliminate that strange bug, look here in post #8:

https://bbs.archlinux.org/viewtopic.php?id=129872

thom (tsk) wrote :

Indeed it does.

b.t.w. I think that the message that "this bug report is a duplicate of bug #878492" is slightly off:
I think the duplicate status is wrong

bug #878492 is about the philosophical question if it's right or wrong to use plain F-keys for the OS in the vincinity of a terminal emulator....well, although I agree, I don't have any problem with that as long as I can bypass it , so my problem is not in bug #878492

The bug we are discussing HERE is about the fact that something isn't working the way it is designed to do:
let's resume shall we ?

1) in Gnome-terminal you can switch off (bypass) F-keys so traditional programs like "htop" and "mc" are usable.
2) in Ubuntu 11.10 (11.04?) this didn't work anymore, at least not for F10 (so "killall -SIGTERM mc" to exit)
3) bug: Compiz-config-settings-manager overruled gnome-terminal with F10 setting
     workaround: switch F-10 off in ccsm
4) In Ubuntu 12.04 another bug appeard which did the same but in different way...
5) bug: gtk3.0 is acting up.....reason unknown....does anyone know which GTK project to contact about this ?
    workaround [thank you Joost, it works !! :-) ]: cut and paste the following in a terminal and press enter

mkdir -p ~/.config/gtk-3.0
cat<<EOF > ~/.config/gtk-3.0/gtk.css

@binding-set NoKeyboardNavigation {
     unbind "<shift>F10"
}

* {
     gtk-key-bindings: NoKeyboardNavigation
}

EOF

Alex Vorona (alex-vorona) wrote :

Same problem with F10 on 12.04 - same solution from Joost worked.

malheum (maxheise) wrote :

Bug is present in 12.04 AMD64 as of 19.04.2012

Seriously, in a stable release ?

Oleg (jumpercc) wrote :

workaround with ~/.config/gtk-3.0/gtk.css works perfectly - thankyou

Paolo Donadeo (paolo.donadeo) wrote :

Workaround from thom worked for me too (thanks!), but it's a shame...

ftoledo (ftoledo) wrote :

Workaround from thom worked for me on 12.04

Marius (nkts) wrote :

Well, I thing this bug is related to gnome-terminal. I use mc a lot, and it's very annoying to exit from it. But still exist in 12.04. tsk work a round works. Big thanks Thom!

Kevin (kkd) wrote :

thom's workaround works for me, but remember to close _all_ active terminal windows to get the change in effect.

vladzarubin (viz-bk) wrote :

Thanks, thom! Works perfectly on 12.04 32 bit.

Sergios (linuxmangr) wrote :

I comfirm is worked with :
workaround with ~/.config/gtk-3.0/gtk.css
Thanks for solution.

Workaround does NOT work with GNOME 3 under Ubuntu 12.04 LTS 32 bit. Instead, it triggers GNOME Terminal's context menu (the menu that opens when right-clicking on the terminal window).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers