small memory leak in unity-panel-service per use of global menu

Bug #722972 reported by Doug McMahon on 2011-02-22
90
This bug affects 24 people
Affects Status Importance Assigned to Milestone
DBus Menu
Fix Released
Undecided
Unassigned
Unity
Fix Released
Undecided
Unassigned
Unity Foundations
Undecided
Chris Coulson
indicator-appmenu (Ubuntu)
Undecided
Unassigned
libdbusmenu (Ubuntu)
Undecided
Chris Coulson
unity (Ubuntu)
High
Chris Coulson

Bug Description

Binary package hint: unity

Every use of the global menu increases memory used by unity-panel-service by about 1MB per use
If desired can provide log

It's also been reported and seen here that in the Classic login each use of the global menu does about the same for indicator-applet-appmenu

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.4.4-0ubuntu2 [modified: usr/share/compiz/unityshell.xml]
ProcVersionSignature: Ubuntu 2.6.38-4.31-generic 2.6.38-rc5
Uname: Linux 2.6.38-4-generic i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,vpswitch,resize,move,place,session,mousepoll,fade,gnomecompat,workarounds,cube,expo,regex,scale,switcher,rotate,scaleaddon,unityshell]
CompositorRunning: compiz
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Tue Feb 22 00:32:54 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
GraphicsCard:
 nVidia Corporation G70 [GeForce 7800 GS] [10de:00f5] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: Device [19f1:1fa4]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
MachineType: alienware alienware
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-4-generic root=UUID=b6b70e8e-15d5-4586-ab14-296274f29264 ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-4.31-generic 2.6.38-rc5
Renderer: Unknown
SourcePackage: unity
dmi.bios.date: 01/29/2004
dmi.bios.vendor: Intel Corp.
dmi.bios.version: BZ87510A.86A.0091.P21.0401291113
dmi.board.name: D875PBZ
dmi.board.vendor: Intel Corporation
dmi.board.version: AAC26680-205
dmi.chassis.type: 2
dmi.chassis.vendor: alienware
dmi.chassis.version: alienware
dmi.modalias: dmi:bvnIntelCorp.:bvrBZ87510A.86A.0091.P21.0401291113:bd01/29/2004:svnalienware:pnalienware:pvr:rvnIntelCorporation:rnD875PBZ:rvrAAC26680-205:cvnalienware:ct2:cvralienware:
dmi.product.name: alienware
dmi.sys.vendor: alienware
version.compiz: compiz 1:0.9.2.1+glibmainloop4-0ubuntu11
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu6
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-1ubuntu9
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu4

Related branches

Doug McMahon (mc3man) wrote :
Changed in unity (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Eric Appleman (erappleman) wrote :

Confirming on classic desktop.

indicator-applet-appmenu had grown to use 786MB of RAM over the course of 3 days.

Didier Roche (didrocks) on 2011-02-24
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
Chris Coulson (chrisccoulson) wrote :

Some of these leaks are in dbusmenu (branch pushed for those), although I think some of the remaining leaks are in unity + various indicators too

Changed in libdbusmenu (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
Ted Gould (ted) on 2011-03-10
Changed in dbusmenu:
status: New → Fix Committed
milestone: none → 0.3.101
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libdbusmenu - 0.3.101-0ubuntu1

---------------
libdbusmenu (0.3.101-0ubuntu1) natty; urgency=low

  * New upstream release.
    ∘ Add helper to get cached menuitem from widget
    ∘ Have the GTK Dbusmenu Client handle theme directories (LP: #727325)
    ∘ Fix a bunch of memory leaks (LP: #722972)
    ∘ Handle _ in menuitems more correctly when parsing (LP: #621301)
    ∘ Protect from NULL layout_props (LP: #729722)
    ∘ Remove the property from the hashtable before signaling that
      it's been changed (LP: #725603)
    ∘ Wrap emitted properties in a variant
    ∘ Fix enum templates so they can be included by other programs
      without error
    ∘ Setting the cached menu item (LP: #723463) (LP: #729128) (LP: #729194)
 -- Ted Gould <email address hidden> Thu, 10 Mar 2011 11:12:50 -0600

Changed in libdbusmenu (Ubuntu):
status: New → Fix Released
Chris Coulson (chrisccoulson) wrote :

Closing the unity task and reopening the libdbusmenu one. The other bug leaks are also there too.

Changed in unity (Ubuntu):
status: Confirmed → Invalid
Changed in libdbusmenu (Ubuntu):
status: Fix Released → Triaged
Eric Appleman (erappleman) wrote :

Yup. Still getting 100+ MB memory leaks with the appmenu.

Didier Roche (didrocks) on 2011-03-16
Changed in unity (Ubuntu):
status: Invalid → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libdbusmenu - 0.3.102-0ubuntu1

---------------
libdbusmenu (0.3.102-0ubuntu1) natty; urgency=low

  * New upstream release.
    ∘ Remove child items when they're removed by GTK
    ∘ Adding opened and closed events for menu visibility
    ∘ Handle empty image types
    ∘ Remove critical warning on parser menuitem check (LP: #733918)
    ∘ Fix dependencies in pkgconfig files (LP: #733263)
    ∘ Handle NULL labels (LP: #733688)
    ∘ Fix memory leaks from variants (LP: #722972)
 -- Ted Gould <email address hidden> Wed, 16 Mar 2011 14:08:13 -0500

Changed in libdbusmenu (Ubuntu):
status: Triaged → Fix Released
Ted Gould (ted) on 2011-03-16
Changed in unity-foundations:
assignee: nobody → Chris Coulson (chrisccoulson)
Sebastien Bacher (seb128) wrote :

is that still an issue?

pablomme (pablomme) wrote :

unity-panel-service consistently uses 31 MiB of memory on my system, so I would say the issue is gone.

pablomme (pablomme) wrote :

...hence all tasks should be closed.

Changed in unity:
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Changed in indicator-appmenu (Ubuntu):
status: New → Fix Released
Regular User (dot.ru) wrote :

unity-panel-service is taking ~120mb of ram right now. This wasn't happening before (I do monitor my system resources regularly). I'm on a laptop and it's been up for 15hrs. For the record, I enabled the old system tray functionality right after installing the system a couple of weeks ago, don't know if this has anything to do with this issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers