Compiz won't allow Desktop Cube plugin to load with unity

Bug #711561 reported by Erik B. Andersen on 2011-02-01
336
This bug affects 74 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Fix Released
Wishlist
Didier Roche
unity (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: compiz

The cooperation of Compiz and Unity is great.

However, if you try to load the Desktop cube plugin, it asks you if you want to disable the Desktop wall plugin. If you say yes, it wants to disable the Unity plugin (which I'm guessing is a bad idea on a Unity desktop).

IIRC, the Desktop Cube plugin once ran with unity. I remember running a daily image a while a go (at least a month) and enabling the Desktop Cube, alongside with Unity.

I'm really hoping that Compiz's signature (the Desktop Cube) won't go away.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: compiz 1:0.9.2.1+glibmainloop4-0ubuntu7
ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
Uname: Linux 2.6.37-12-generic x86_64
Architecture: amd64
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x800 1024x768 800x600 640x480 720x400 640x400 640x350
 edid-base64:
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Tue Feb 1 14:57:40 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
GraphicsCard: Subsystem: Hewlett-Packard Company Device [103c:30b7]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110127)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Hewlett-Packard Presario F500 (GF606UA#ABA)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-12-generic root=UUID=f1add3f0-0a81-4f8c-ac34-9dd6917e8bfb ro quiet splash vt.handoff=7
SourcePackage: compiz
UnitySupportTest:

dmi.bios.date: 12/05/2007
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.1F
dmi.board.name: 30D3
dmi.board.vendor: Quanta
dmi.board.version: 65.3A
dmi.chassis.type: 10
dmi.chassis.vendor: Quanta
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.1F:bd12/05/2007:svnHewlett-Packard:pnPresarioF500(GF606UA#ABA):pvrRev1:rvnQuanta:rn30D3:rvr65.3A:cvnQuanta:ct10:cvrN/A:
dmi.product.name: Presario F500 (GF606UA#ABA)
dmi.product.version: Rev 1
dmi.sys.vendor: Hewlett-Packard
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
version.xserver-xorg: xserver-xorg 1:7.5+6ubuntu8
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.13.2+git20110124.fadee040-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu1

Related branches

Erik B. Andersen (azendale) wrote :
Travis Watkins (amaranth) wrote :

The unityshell plugin has a dependency on wall so this would need to be changed there. I suspect this is by design but I've reassigned to unity for further input.

affects: compiz (Ubuntu) → unity (Ubuntu)
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
importance: Undecided → Medium
David Barth (dbarth) on 2011-02-03
Changed in unity (Ubuntu):
status: Confirmed → Opinion
importance: Medium → Wishlist
Changed in unity:
status: New → Incomplete
David Barth (dbarth) wrote :

For the moment, we want to get the experience right with the wall workspace switcher.

I'm requesting a validation of the design approach, ie would the Unity Shell UX be consistent with a Cube workspace switcher.

Didier Roche (didrocks) on 2011-02-21
Changed in unity:
status: Incomplete → Opinion

Compiz cube i one of the features that attracted many people to ubuntu. Whe shouldn't abandon it. Expo plugin works well with the cube, it could work with the workspace switcher.

PEIGNOT Kévin (kpeignot) wrote :

Yes, a lot of people come and tried Linux thanks to this plugin !!!!

Avery (docaltmed) wrote :

Incorrect categorization. Loss of functionality is not an "opinion."

yoghurt_lx (tank) wrote :

"Wishlist" and "Opinion" is a loss of functions now called ?
The Cube is an important eye candy and feature which has brought many new users to Linux and Ubuntu.

Casey J Peter (caseyjp1) wrote :

I'm in agreement that this isn't "opinion". Personally I DO use the cube and have set up my work flow around it.
Playing with unity on my netbook, I'm quickly discovering that I WISH I had the cube instead of the current switching utility.
My 2 cents on this one. As for the desktop, choice is paramount, and taking away the option of a different method of workplace switching, especially the CUBE, seems to me more restrictive than should be. Of course I'm not a code jockey, but as a long time user of compiz, it surprised me to see this change.

Changed in unity (Ubuntu):
status: Opinion → Confirmed
Changed in unity:
status: Opinion → Confirmed
Jorge Castro (jorge) wrote :

I'm tagging this bitesize if someone wants to take a stab at this. Right now enabling the cube is breaking the wall, which is what we enable by default, this is why it's conflicting when you try to turn the cube on.

If someone wants to submit a fix that enables Unity to run the cube WITHOUT breaking the wall then that would be great.

tags: added: bitesize
Download full text (3.7 KiB)

Well, the wall and cube plugins conflict already. The greater problem
here is that we want some kind of viewport switcher to be handy

On Mon, Mar 7, 2011 at 10:32 PM, Jorge O. Castro <email address hidden> wrote:
> I'm tagging this bitesize if someone wants to take a stab at this. Right
> now enabling the cube is breaking the wall, which is what we enable by
> default, this is why it's conflicting when you try to turn the cube on.
>
> If someone wants to submit a fix that enables Unity to run the cube
> WITHOUT breaking the wall then that would be great.
>
> ** Tags added: bitesize
>
> --
> You received this bug notification because you are a member of Unity
> Bugs, which is subscribed to unity in ubuntu.
> https://bugs.launchpad.net/bugs/711561
>
> Title:
>  Compiz won't allow Desktop Cube plugin to load with unity
>
> Status in Ayatana Design:
>  New
> Status in Unity:
>  Confirmed
> Status in “unity” package in Ubuntu:
>  Confirmed
>
> Bug description:
>  Binary package hint: compiz
>
>  The cooperation of Compiz and Unity is great.
>
>  However, if you try to load the Desktop cube plugin, it asks you if
>  you want to disable the Desktop wall plugin. If you say yes, it wants
>  to disable the Unity plugin (which I'm guessing is a bad idea on a
>  Unity desktop).
>
>  IIRC, the Desktop Cube plugin once ran with unity. I remember running
>  a daily image a while a go (at least a month) and enabling the Desktop
>  Cube, alongside with Unity.
>
>  I'm really hoping that Compiz's signature (the Desktop Cube) won't go
>  away.
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 11.04
>  Package: compiz 1:0.9.2.1+glibmainloop4-0ubuntu7
>  ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
>  Uname: Linux 2.6.37-12-generic x86_64
>  Architecture: amd64
>  DRM.card0.LVDS.1:
>   status: connected
>   enabled: enabled
>   dpms: On
>   modes: 1280x800 1024x768 800x600 640x480 720x400 640x400 640x350
>   edid-base64:
>  DRM.card0.VGA.1:
>   status: disconnected
>   enabled: disabled
>   dpms: Off
>   modes:
>   edid-base64:
>  Date: Tue Feb  1 14:57:40 2011
>  DistUpgraded: Fresh install
>  DistroCodename: natty
>  DistroVariant: ubuntu
>  GraphicsCard:   Subsystem: Hewlett-Packard Company Device [103c:30b7]
>  InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110127)
>  Lsusb:
>   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
>   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
>  MachineType: Hewlett-Packard Presario F500 (GF606UA#ABA)
>  PackageArchitecture: all
>  ProcEnviron:
>   LANGUAGE=en_US:en
>   LANG=en_US.UTF-8
>   LC_MESSAGES=en_US.utf8
>   SHELL=/bin/bash
>  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-12-generic root=UUID=f1add3f0-0a81-4f8c-ac34-9dd6917e8bfb ro quiet splash vt.handoff=7
>  SourcePackage: compiz
>  UnitySupportTest:
>
>  dmi.bios.date: 12/05/2007
>  dmi.bios.vendor: Hewlett-Packard
>  dmi.bios.version: F.1F
>  dmi.board.name: 30D3
>  dmi.board.vendor: Quanta
>  dmi.board.version: 65.3A
>  dmi.chassis.type: 10
>  dmi.chassis.vendor: Quanta
>  dmi.chassis.version: N/A
>  dmi.modalias: dmi:bvnHewlett-Packard:bvrF.1F:bd12/05/2007:svnHewlett-Packard:pnPresarioF500(GF606UA#ABA)...

Read more...

John Lea (johnlea) wrote :

The cube is a great compiz feature, however to limit scope the Unity design team is not currently designing Unity interactions with the cube in mind (or testing all Unity interactions with the cube). Ensuring that the cube plays well with Unity would be a great community project however it is not something we have time to focus on atm. Marked invalid on 'Ayatana Design' for this reason.

Changed in ayatana-design:
status: New → Won't Fix
Didier Roche (didrocks) on 2011-03-07
Changed in unity:
status: Confirmed → Won't Fix
Changed in unity (Ubuntu):
status: Confirmed → Won't Fix
Joe Bubba (joebubba360) wrote :

This is terribly sad. Loss of the compiz cube is a MAJOR loss of functionality.
By not designing functions and features around it from the start, the developers have made a huge mistake.

I personally will have to stay with 10.10 until this oversight is corrected. I suspect many others will have to do the same.
This is NOT the way to grow Ubuntu's user base by taking away things people really like and use a lot.
Adding new features is great, but not at the expense of taking away things that have already proven their popularity.

Sam Spilsbury (smspillaz) wrote :
Download full text (4.0 KiB)

On Thu, Mar 10, 2011 at 9:34 PM, Joe Bubba <email address hidden> wrote:
> This is terribly sad. Loss of the compiz cube is a MAJOR loss of functionality.
> By not designing functions and features around it from the start, the developers have made a huge mistake.
>
> I personally will have to stay with 10.10 until this oversight is corrected. I suspect many others will have to do the same.
> This is NOT the way to grow Ubuntu's user base by taking away things people really like and use a lot.
> Adding new features is great, but not at the expense of taking away things that have already proven their popularity.

It is easy to re-add it - just edit the metadata file to remove the dep on Wall.

The reason we are depending on wall at the moment is because of design
considerations - we simply don't have the resources to support
everything at the moment.

>
> --
> You received this bug notification because you are a member of Unity
> Bugs, which is subscribed to unity in ubuntu.
> https://bugs.launchpad.net/bugs/711561
>
> Title:
>  Compiz won't allow Desktop Cube plugin to load with unity
>
> Status in Ayatana Design:
>  Won't Fix
> Status in Unity:
>  Won't Fix
> Status in “unity” package in Ubuntu:
>  Won't Fix
>
> Bug description:
>  Binary package hint: compiz
>
>  The cooperation of Compiz and Unity is great.
>
>  However, if you try to load the Desktop cube plugin, it asks you if
>  you want to disable the Desktop wall plugin. If you say yes, it wants
>  to disable the Unity plugin (which I'm guessing is a bad idea on a
>  Unity desktop).
>
>  IIRC, the Desktop Cube plugin once ran with unity. I remember running
>  a daily image a while a go (at least a month) and enabling the Desktop
>  Cube, alongside with Unity.
>
>  I'm really hoping that Compiz's signature (the Desktop Cube) won't go
>  away.
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 11.04
>  Package: compiz 1:0.9.2.1+glibmainloop4-0ubuntu7
>  ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
>  Uname: Linux 2.6.37-12-generic x86_64
>  Architecture: amd64
>  DRM.card0.LVDS.1:
>   status: connected
>   enabled: enabled
>   dpms: On
>   modes: 1280x800 1024x768 800x600 640x480 720x400 640x400 640x350
>   edid-base64:
>  DRM.card0.VGA.1:
>   status: disconnected
>   enabled: disabled
>   dpms: Off
>   modes:
>   edid-base64:
>  Date: Tue Feb  1 14:57:40 2011
>  DistUpgraded: Fresh install
>  DistroCodename: natty
>  DistroVariant: ubuntu
>  GraphicsCard:   Subsystem: Hewlett-Packard Company Device [103c:30b7]
>  InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110127)
>  Lsusb:
>   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
>   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
>  MachineType: Hewlett-Packard Presario F500 (GF606UA#ABA)
>  PackageArchitecture: all
>  ProcEnviron:
>   LANGUAGE=en_US:en
>   LANG=en_US.UTF-8
>   LC_MESSAGES=en_US.utf8
>   SHELL=/bin/bash
>  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-12-generic root=UUID=f1add3f0-0a81-4f8c-ac34-9dd6917e8bfb ro quiet splash vt.handoff=7
>  SourcePackage: compiz
>  UnitySupportTest:
>
>  dmi.bios.date: 12/05/2007
>  dmi.bios.vendor: Hewlett-Packard
>  dmi.b...

Read more...

Omer Akram (om26er) wrote :
Download full text (3.9 KiB)

Joe, its not an issue in the gnome session so you can update to natty
without loosing the cube ;)

On Thu, Mar 10, 2011 at 6:34 PM, Joe Bubba <email address hidden>wrote:

> This is terribly sad. Loss of the compiz cube is a MAJOR loss of
> functionality.
> By not designing functions and features around it from the start, the
> developers have made a huge mistake.
>
> I personally will have to stay with 10.10 until this oversight is
> corrected. I suspect many others will have to do the same.
> This is NOT the way to grow Ubuntu's user base by taking away things people
> really like and use a lot.
> Adding new features is great, but not at the expense of taking away things
> that have already proven their popularity.
>
> --
> You received this bug notification because you are a member of Unity
> Bugs, which is subscribed to unity in ubuntu.
> https://bugs.launchpad.net/bugs/711561
>
> Title:
> Compiz won't allow Desktop Cube plugin to load with unity
>
> Status in Ayatana Design:
> Won't Fix
> Status in Unity:
> Won't Fix
> Status in “unity” package in Ubuntu:
> Won't Fix
>
> Bug description:
> Binary package hint: compiz
>
> The cooperation of Compiz and Unity is great.
>
> However, if you try to load the Desktop cube plugin, it asks you if
> you want to disable the Desktop wall plugin. If you say yes, it wants
> to disable the Unity plugin (which I'm guessing is a bad idea on a
> Unity desktop).
>
> IIRC, the Desktop Cube plugin once ran with unity. I remember running
> a daily image a while a go (at least a month) and enabling the Desktop
> Cube, alongside with Unity.
>
> I'm really hoping that Compiz's signature (the Desktop Cube) won't go
> away.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: compiz 1:0.9.2.1+glibmainloop4-0ubuntu7
> ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
> Uname: Linux 2.6.37-12-generic x86_64
> Architecture: amd64
> DRM.card0.LVDS.1:
> status: connected
> enabled: enabled
> dpms: On
> modes: 1280x800 1024x768 800x600 640x480 720x400 640x400 640x350
> edid-base64:
> DRM.card0.VGA.1:
> status: disconnected
> enabled: disabled
> dpms: Off
> modes:
> edid-base64:
> Date: Tue Feb 1 14:57:40 2011
> DistUpgraded: Fresh install
> DistroCodename: natty
> DistroVariant: ubuntu
> GraphicsCard: Subsystem: Hewlett-Packard Company Device [103c:30b7]
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110127)
> Lsusb:
> Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> MachineType: Hewlett-Packard Presario F500 (GF606UA#ABA)
> PackageArchitecture: all
> ProcEnviron:
> LANGUAGE=en_US:en
> LANG=en_US.UTF-8
> LC_MESSAGES=en_US.utf8
> SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-12-generic
> root=UUID=f1add3f0-0a81-4f8c-ac34-9dd6917e8bfb ro quiet splash vt.handoff=7
> SourcePackage: compiz
> UnitySupportTest:
>
> dmi.bios.date: 12/05/2007
> dmi.bios.vendor: Hewlett-Packard
> dmi.bios.version: F.1F
> dmi.board.name: 30D3
> dmi.board.vendor: Quanta
> dmi.board.version: 65.3A
> dmi.chassis.type: 10
> dmi.chas...

Read more...

downward (invisioslice) wrote :

I'm starting the campaign "Save the Cheerleader, save the cube!"

Save compiz cube clicking "this bug affects me too" here: http://is.gd/iYQKPG YOU CAN SAVE THE COMPIZ CUBE!!!

downward (invisioslice) wrote :

I'm starting the campaign "Save the Cheerleader, save the cube!" Save compiz cube clicking "this bug affects me too" here: http://is.gd/iYQKPG ONLY YOU CAN SAVE THE COMPIZ CUBE!!!

COPY PASTE TO twitter AND identica

downward (invisioslice) wrote :

Sorry this is the twitter AND identica copy paste :P

Save the Cheerleader, save the Cube! clicking "this bug affects me too" here: http://is.gd/iYQKPG YOU CAN SAVE THE COMPIZ CUBE!!!

Sorry for the inconvenience.

Why not just modify the cube to work like the KDE Cube does?
In KDE you can switch to a workspace using the expo equivalent if you want, or you can switch to lower workspaces (for example in a 2x2 or 4x4 grid) with the Cube. It just shows an animation going up or down when switching to a lower workspace.

With a bit of tweaking the compiz cube could easily do this, not so? (I have not yet looked at the code, so I might be wrong? If it is a simple fix, I would even take a stab at it :-P

 i got the cube running with wall and unity

on the compiz config settings manager (ccsm) disable auto sort plugins
add cube and so on manualy
the unity plugin has to be more at the end than the cube
the wall has to be above the cube

start the gnome-panel from a terminal, set 4 Desktops in one row to get a cube.

i uploaded my compiz config settings here :
http://ubuntuone.com/p/hSx/

and made a Video on YT to show how to set up :
http://www.youtube.com/watch?v=pjhFz-wv6Qw

hope this helps you

Maxim Levitsky (maximlevitsky) wrote :

OK, I bought some popcorn.
Lets the ubuntu/gnome contest of who pisses of most users begin....
Really, I am not trolling, just mad at attitude the devs.
Sorry for trollish comment though

Didier Roche (didrocks) wrote :

After talking with seb128, we decided to make unity depends on "largedesktop" which will enable people wanting to use the cube to use it. However, the ws switcher icon isn't integrated to it and will be ineffective.

Of course, that won't change the default which is wall.

Changed in unity:
status: Won't Fix → Fix Committed
importance: Undecided → Wishlist
Changed in unity (Ubuntu):
status: Won't Fix → Fix Committed
Changed in unity:
assignee: nobody → Didier Roche (didrocks)
milestone: none → 3.8.4
Didier Roche (didrocks) wrote :

(Note that cube hasn't be well-tested by our team with unity, we don't support that configuration)

Sebastien Bacher (seb128) wrote :

Ok, I've asked didrocks to include that change in the next upload, the rational being that:

- ccsm is not included in the default Ubuntu installation, users have to find it, install it and use it
- the cube doesn't really break unity
- we prefer to deal with issues due to users who tweaked their config in an official way rather than having to deal with users who run random commands found on the internet or installed a ppa version

In summary we can't really stop users to turn on the cube if that's what they want so we better give them an easy enough way to do it rather than push them to break their system on the way

Didier Roche (didrocks) on 2011-04-07
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package unity - 3.8.4-0ubuntu1

---------------
unity (3.8.4-0ubuntu1) natty; urgency=low

  * New upstream release.
    - [fglrx] compiz crashed with SIGSEGV in nux::IOpenGLSurface::UnlockRect()
      (LP: #685682)
    - SIGSEGV in g_atomic_int_get (LP: #688803)
    - unity-panel-service crashed with SIGSEGV in bamf_factory_view_for_path()
      (LP: #717684)
    - New window tracking system breaks in the case where windows try to
      restack relative to destroyed windows that were never mapped
      (LP: #723014)
    - Numpad 'Enter' doesn't work on highlighted items in dash, places-files and
      places-apps (LP: #741615)
    - compiz crashed with SIGSEGV in free() (LP: #738864)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #741674)
    - compiz crashed with SIGSEGV in CompWindow::id() (LP: #742028)
    - Windows that reparent away from the root before they are mapped can
      cause other windows to become invisible (and compiz to crash)
      (LP: #743011)
    - compiz crashed with SIGABRT in raise() (LP: #743414)
    - compiz crashed with SIGSEGV in g_object_get_qdata() (LP: #742905)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #748033)
    - compiz crashed with SIGSEGV in CompScreen::dpy() (LP: #751372)
    - compiz crashed with SIGABRT in __kernel_vsyscall() (LP: #744867)
    - unity-window-decorator crashed with SIGSEGV in gdk_window_get_events()
      (LP: #725284)
    - Missing icons in app launcher (LP: #728393)
    - Multiple quick clicks on launcher icon with multiple windows completely
      crashes Unity (LP: #731790)
    - Add a test case for invisible windows regressions (LP: #736876)
    - Re-sync with xquerytree to avoid stacking order issues (LP: #740465)
    - Wrong window moves (LP: #741656)
    - compiz crashed with SIGSEGV in g_cclosure_marshal_VOID__VOID()
      (LP: #742280)
    - panel superposition (LP: #742859)
    - unity-window-decorator doesn't start on secondary X session
      (LP: #730495)
    - Unity Launcher stops autohiding and is not responsive (LP: #744325)
    - dash categories dropdown menu leaves "ghost" on desktop (LP: #746800)
    - new dialogs open close enough of the launcher to make hide (LP: #747302)
    - dnd from the application place to the launcher works only once
      (LP: #747316)
    - compiz crashed with SIGSEGV in CompWindow::id() while opening tcl/tk
      interface of R (LP: #747439)
    - minimize animates window fading to the top left corner (ubuntu symbol)
      (LP: #747765)
    - Spread - Clicking on a app icon to spread the windows must always show
      all the windows, regardless of whether or not some of the windows are
      minimised (LP: #750349)
    - Launcher - Show visual de-coupling of Launcher app icons (LP: #751196)
    - unity-window-decorator crashed with SIGSEGV in event_filter_func()
      (LP: #748317)
    - Pressing Super-W to switch windows also presents Dash (LP: #753453)
    - Don't create windows over the launcher (LP: #688816)
    - Unity Grid is broken for multi-monitor setups (LP: #709221)
    - F10 key does not move focus to indicators when on the desktop.
      (LP: #727548)
    - dynamic ...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Alan Bell (alanbell) wrote :

the dependency was removed here
https://code.launchpad.net/~alanbell/unity/removelargedesktopdependency/+merge/93687
because you can't switch between the largedesktop providing plugins without removing unity. If you have both wall and cube disabled unity still works fine, just the switcher does nothing as you might expect.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers