Autohide option should be more like Intellihide

Bug #685861 reported by Pete Goodall on 2010-12-06
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Fix Released
Wishlist
Unassigned
unity (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: unity

Having the auto-hide option is very handy, but intellihide always seemed to work better. The only reason I want auto-hide is so I can have back those 58 (or so) pixels occupied by the launcher.
 * On my 1024x600 screen I can have a full 1024 pixels for my web browser
 * If the only window in view doesn't need the full width (say and empathy chat window) I want the launcher still there for quick access.
 * It makes it easier to see at a glance what apps are running and switch between apps
 * Helps w/ workspace switcher as I don't have to go into the upper-left corner then down to workspace switcher
 * Unity doesn't change modes if I switch to a larger external monitor where most (if not all) windows don't need to be maximised

Basically, I want the launcher visible unless I need that space.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.2.2-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.37-7.19-generic 2.6.37-rc3
Uname: Linux 2.6.37-7-generic i686
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,unityshell,mousepoll,scale,gnomecompat,expo,move,wall,place,vpswitch,ezoom,resize,staticswitcher]
Date: Mon Dec 6 11:21:50 2010
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101122)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101122)
MachineType: Acer AO531h
PciDisplay: 00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GME Express Integrated Graphics Controller [8086:27ae] (rev 03) (prog-if 00 [VGA controller])
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-7-generic root=UUID=336bec37-d633-41f7-94c8-841a195be808 ro quiet splash
ProcVersionSignature_: Ubuntu 2.6.37-7.19-generic 2.6.37-rc3
RelatedPackageVersions:
 xserver-xorg 1:7.5+6ubuntu3b1
 libgl1-mesa-glx 7.9+repack-1ubuntu3
 libdrm2 2.4.22-2ubuntu1
 xserver-xorg-video-intel 2:2.13.901-2ubuntu1
 xserver-xorg-video-ati 1:6.13.2-1ubuntu2
SourcePackage: unity
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
dmi.bios.date: 12/22/2009
dmi.bios.vendor: Acer
dmi.bios.version: v0.3304
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.vendor: Acer
dmi.board.version: Base Board Version
dmi.chassis.type: 1
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAcer:bvrv0.3304:bd12/22/2009:svnAcer:pnAO531h:pvr1:rvnAcer:rn:rvrBaseBoardVersion:cvnChassisManufacturer:ct1:cvrChassisVersion:
dmi.product.name: AO531h
dmi.product.version: 1
dmi.sys.vendor: Acer
glxinfo: Error: [Errno 2] No such file or directory
system: distro = Ubuntu, architecture = i686, kernel = 2.6.37-7-generic

Related branches

Pete Goodall (pgoodall) wrote :
Didier Roche (didrocks) on 2010-12-06
Changed in unity (Ubuntu):
status: New → Incomplete
importance: Undecided → Wishlist
Changed in unity:
status: New → Incomplete
importance: Undecided → Wishlist

 status confirmed

I think intelli-hide is the plan of record.

Changed in ayatana-design:
status: New → Confirmed
Didier Roche (didrocks) wrote :

Thanks, I couldn't find it anymore.
I was thinking it was but always nice to have second confirmation :)

Changed in unity (Ubuntu):
status: Incomplete → Triaged
Changed in unity:
status: Incomplete → Triaged
Jason Smith (jassmith) wrote :

For your please Mr. Goodall, I have implemented intellhide. It's not flawless yet I am sure, but has no obvious bugs I found.

Jason Smith (jassmith) wrote :

That would have been so much more smooth if I learned to spell the word "pleasure". Oh well.

Didier Roche (didrocks) on 2010-12-07
Changed in unity:
milestone: none → 3.2.4
status: Triaged → Fix Committed
Changed in ayatana-design:
status: Confirmed → Fix Released
Neil J. Patel (njpatel) on 2010-12-09
Changed in unity:
milestone: 3.2.4 → 3.2.8
milestone: 3.2.8 → 3.2.6
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.2.6-0ubuntu1

---------------
unity (3.2.6-0ubuntu1) natty; urgency=low

  [ Didier Roche ]
  * New upstream release:
   - Autohide option should be more like Intellihide (LP: #685861)
   - Add an unity binary (LP: #599716)
   - Dock icons disappearing on reopen (all programs) (LP: #687466)
   - Application with .desktop file containing "icon=/absolute/path" doesn't
     have an icon in unity panel (LP: #683444)
   - Indicators are mis-aligned (LP: #646740)
   - Navigating between indicator gives focus back to other dialogs during
     transition (LP: #637143)
   - Migration script should dump a lot of migrated items for debugging
     (LP: #687721)
   - Add desktop action support to launcher quicklists (LP: #687403)
   - Rendering of Quicklist radio-button-item still way off (LP: #684048)
   - Clicking on a launcher icon does not raise most recent window (LP: #677577)
   - Quicklist menu item testing - Part 2 (LP: #676040)
   - Panel does not behave like a menu bar (keyboard scrubbing) (LP: #686655)
   - Separated menus: no keyboard shortcuts for menus (LP: #684060)
   - No installation instructions in source (LP: #683792)
   - Unity plugin should depend on "Desktop Wall" plugin (LP: #683211)
   - Network indicator shows up on the left-hand side of the panel (LP: #680545)
   - Scrubbing menu items or indicators in panel prematurely ends (LP: #677601)
   - fix trash icon not being updated (LP: #683241)
  * Revert source 3, it's breaking daily build and hudson
  * remove the patch as well, fixed upstream
  * debian/control, debian/unity.install, debian/unity-common.install:
    - add unity-common package and move some files there
    - install the new perf bootchart there as well
  * debian/unity.install:
    - install new unity binary
  * debian/control:
    - dep on latest nux
    - recommends nux-tools
  * debian/libunity3.symbols:
    - updated to include the new symbols

  [ Sebastien Bacher ]
  * debian/source_unity.py:
    - reassign crashes due to the indicators to the right source directly
 -- Didier Roche <email address hidden> Thu, 09 Dec 2010 19:57:14 +0100

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Didier Roche (didrocks) on 2010-12-10
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers