SEGSEGV in nux::ResourceData::GetResourceIndex() const ()

Bug #682345 reported by Hernando Torque on 2010-11-28
78
This bug affects 12 people
Affects Status Importance Assigned to Milestone
BAMF
Critical
Didier Roche
Nux
Fix Released
Undecided
Unassigned
Unity
Fix Released
Critical
Didier Roche
bamf (Ubuntu)
Undecided
Unassigned
nux (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

Starting compiz with the unity plugin enabled results in a segmentation fault. Same if the plugin gets activated after starting compiz without it (via ccsm).

Before the crash I can see the top panel, the launcher bar with workspace switcher and trash launcher icons and then it dies.

Console output and backtrace attached (bt, bt full, thread apply bt full).

Using Nvidia's BLOB 260.19.21-0ubuntu1, no interesting PPAs (GNOME3, xorg-edgers) enabled.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.2.0-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.37-6.17-generic 2.6.37-rc3
Uname: Linux 2.6.37-6-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
CompizPlugins: No value set for `/apps/compiz/general/allscreens/options/active_plugins'
Date: Sun Nov 28 13:24:27 2010
Lsusb:
 Bus 002 Device 003: ID 0ea0:6803 Ours Technology, Inc. OTI-6803 Flash Disk
 Bus 002 Device 002: ID 046d:c048 Logitech, Inc.
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 003: ID 058f:6362 Alcor Micro Corp. Flash Card Reader/Writer
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
PciDisplay: 05:00.0 VGA compatible controller [0300]: nVidia Corporation NV43 [GeForce 6600 GT] [10de:0140] (rev a2) (prog-if 00 [VGA controller])
ProcEnviron:
 LANGUAGE=en_US.utf8
 PATH=(custom, no user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-6-generic root=UUID=025c4231-b78a-48bf-93e9-d20c5b5ce8e3 ro crashkernel=384M-2G:64M,2G-:128M quiet splash bootchart=disable acpi_enforce_resources=lax vga=792
ProcVersionSignature_: Ubuntu 2.6.37-6.17-generic 2.6.37-rc3
RelatedPackageVersions:
 xserver-xorg 1:7.5+6ubuntu3b1
 libgl1-mesa-glx 7.9+repack-1ubuntu2
 libdrm2 2.4.22-2ubuntu1
 xserver-xorg-video-intel 2:2.13.0-1ubuntu1
 xserver-xorg-video-ati 1:6.13.2-1ubuntu2
SourcePackage: unity
UdevDb: Error: [Errno 2] No such file or directory
dmi.bios.date: 03/29/2006
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: LP NF4 Series
dmi.board.vendor: DFI Corp,LTD
dmi.board.version: 1.0
dmi.chassis.type: 3
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd03/29/2006:svn:pn:pvr:rvnDFICorp,LTD:rnLPNF4Series:rvr1.0:cvn:ct3:cvr:
system: distro = Ubuntu, architecture = i686, kernel = 2.6.37-6-generic

Hernando Torque (htorque) wrote :
Hernando Torque (htorque) wrote :
Hernando Torque (htorque) wrote :

Seems to be caused by those missing .desktop files in "com.canonical.Unity.Launcher favorites". I used "gsettings set" to replace the list of favorites without the tow missing files and now Unity starts fine.

Alex Launi (alexlauni) wrote :

I just moved my cheese.desktop and confirmed that unity does indeed crash if a favorite is missing.

Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Neil J. Patel (njpatel) on 2010-12-01
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
importance: Undecided → Critical
milestone: none → 3.2.6
status: Confirmed → Triaged
tags: added: iso-testing
Michael Terry (mterry) wrote :

For me, with the default Live CD, I'm hitting this bug with ubuntuone-control-panel-gtk.desktop being the missing .desktop file. Here's the default favorites as of now:

['ubiquity-gtkui.desktop', 'nautilus.desktop', 'firefox.desktop', 'ubuntuone-control-panel-gtk.desktop', 'tomboy.desktop', '/home/ubuntu/Desktop/examples.desktop']

The only one missing is the ubuntuone one.

Michael Terry (mterry) wrote :

Scratch that. With further testing, my crash is not due to the missing ubuntuone-control-panel-gtk.desktop file, but rather /home/ubuntu/Desktop/examples.desktop. Removing that from my favorites fixes the crash.

Sebastien Bacher (seb128) wrote :

The issue could be fix with lp:~canonical-dx-team/unity/unity.fix-682345, if anybody feels like rebuilding unity

Jay Taoko (jaytaoko) wrote :

The fix here avoids the crash: lp:~canonical-dx-team/unity/unity.fix-682345
This is temporary until a proper correction is made with the favorites.

Hernando Torque (htorque) wrote :

I'm no longer sure this is due to missing desktop files as I just removed that examples.desktop file from the live CD and the warning message was:

WARNING **: Unable to load desktop file: /home/ubuntu/Desktop/examples.desktop

plus:

WARNING **: Unable to load GDesktopAppInfo for 'ubuntuone-control-panel-gtk.desktop' (which is not present on the live CD)

Both files missing, yet Compiz/Unity loaded just fine.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.2.2-0ubuntu2

---------------
unity (3.2.2-0ubuntu2) natty; urgency=low

  * debian/control:
    - Add Vcs-Bzr link
  * debian/source:
    - Use source version 3.0
  * debian/patches/lp682345.patch:
    - Fix crash on startup (LP: #682345)
 -- Robert Ancell <email address hidden> Thu, 02 Dec 2010 10:00:40 +1100

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Hernando Torque (htorque) wrote :

Summary: the crash is caused by having non-application .desktop files in the launcher favorites list.

In my case it was caused by some link type .desktop files in my home dir, which were added to the favorites by the migration script (I didn't run it manually, I swear :-)).

Didier Roche (didrocks) wrote :

I'll do a proper fix with adding support with .desktop type=link

Changed in unity:
assignee: Jason Smith (jassmith) → Didier Roche (didrocks)
milestone: 3.2.6 → 3.2.4
Didier Roche (didrocks) on 2010-12-03
Changed in bamf:
assignee: nobody → Didier Roche (didrocks)
status: New → Triaged
importance: Undecided → Critical
Didier Roche (didrocks) on 2010-12-03
Changed in bamf:
status: Triaged → Fix Committed
Changed in unity:
status: Triaged → Fix Committed
Neil J. Patel (njpatel) on 2010-12-09
Changed in unity:
milestone: 3.2.4 → 3.2.6
Didier Roche (didrocks) on 2010-12-09
Changed in nux:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.2.66-0ubuntu1

---------------
bamf (0.2.66-0ubuntu1) natty; urgency=low

  * New upstream release.
   - Fix the Ubuntu Starter Edition bug (LP: #683623)
   - check that desktop file is currently supported before creating the
     favorite (LP: #682345)
   - unity-panel-service crashed with SIGSEGV in free() (LP: #677580)
 -- Didier Roche <email address hidden> Thu, 09 Dec 2010 19:37:54 +0100

Changed in bamf (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 0.9.10-0ubuntu1

---------------
nux (0.9.10-0ubuntu1) natty; urgency=low

  * New upstream release.
   - Fix SEGSEGV in nux::ResourceData::GetResourceIndex() const ()
     (LP: #682345)
   - Add detection test software
  * debian/rules:
    - bump shlibs for new release
  * debian/nux-tools.install, debian/control:
    - add nux-tools to ship the detection test software
 -- Didier Roche <email address hidden> Thu, 09 Dec 2010 19:56:53 +0100

Changed in nux (Ubuntu):
status: New → Fix Released
Didier Roche (didrocks) on 2010-12-10
Changed in unity:
status: Fix Committed → Fix Released
Changed in nux:
status: Fix Committed → Fix Released
Changed in bamf:
status: Fix Committed → Fix Released
Rajeev Nair (rajeev) wrote :

Hello,

I still have this problem with messages :

** (<unknown>:3253): WARNING **: Unable to load GDesktopAppInfo for 'ubiquity-gtkui.desktop'

** (<unknown>:3253): WARNING **: Unable to load GDesktopAppInfo for 'ubuntuone-control-panel-gtk.desktop'

Adolfo Jayme (fitojb) on 2014-01-11
no longer affects: bamf (Ubuntu Quantal)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers