Scrubbing menu items or indicators in panel prematurely ends

Bug #677601 reported by Michael Terry on 2010-11-19
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Neil J. Patel
unity (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: unity

With new compiz-unity, scrubbing the global menu items of an application or the indicators in the top right will "prematurely end".

Reproduction steps:
1) Click on an indicator
2) Move mouse left and right across rest of indicators

Expected results:
Menus would all open and close like normal

Actual results:
After a few menus open and close like normal, one or two in a row will just look pressed but not open a menu until finally they don't even look pressed anymore. It 'gracefully' ends the scrub. If this sounds bizarre or you can't reproduce, I can try to make a screencast for you.

If I scrub very slowly, everything seems to work fine. It's only when I speed up that it messes up.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.1.4-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.37-5.13-generic 2.6.37-rc2
Uname: Linux 2.6.37-5-generic x86_64
Architecture: amd64
Date: Fri Nov 19 13:53:22 2010
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: unity

Related branches

Michael Terry (mterry) wrote :
Didier Roche (didrocks) wrote :

yeah, I'm getting that as well.

Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity:
importance: Undecided → High
Neil J. Patel (njpatel) wrote :

Yep, figured this out today, will be fixed for next week.

Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
milestone: none → 3.2.6
Adrien Plazas (kekun-plazas) wrote :

I have that problem with the app-menu and the top right menu on Natty Alpha 1.

Didier Roche (didrocks) on 2010-12-06
Changed in unity:
milestone: 3.2.6 → 3.2.4
Neil J. Patel (njpatel) on 2010-12-07
Changed in unity:
status: Triaged → Fix Committed
milestone: 3.2.4 → 3.2.6
Andre Inglis (andre-inglis) wrote :

Happens for me too.

I just want to say that when I drag the mouse across the global menu I'm not doing it fast. Also, if I drag the mouse very slow it seems to work fine, but I would have to drag it much too slow to be productive.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.2.6-0ubuntu1

---------------
unity (3.2.6-0ubuntu1) natty; urgency=low

  [ Didier Roche ]
  * New upstream release:
   - Autohide option should be more like Intellihide (LP: #685861)
   - Add an unity binary (LP: #599716)
   - Dock icons disappearing on reopen (all programs) (LP: #687466)
   - Application with .desktop file containing "icon=/absolute/path" doesn't
     have an icon in unity panel (LP: #683444)
   - Indicators are mis-aligned (LP: #646740)
   - Navigating between indicator gives focus back to other dialogs during
     transition (LP: #637143)
   - Migration script should dump a lot of migrated items for debugging
     (LP: #687721)
   - Add desktop action support to launcher quicklists (LP: #687403)
   - Rendering of Quicklist radio-button-item still way off (LP: #684048)
   - Clicking on a launcher icon does not raise most recent window (LP: #677577)
   - Quicklist menu item testing - Part 2 (LP: #676040)
   - Panel does not behave like a menu bar (keyboard scrubbing) (LP: #686655)
   - Separated menus: no keyboard shortcuts for menus (LP: #684060)
   - No installation instructions in source (LP: #683792)
   - Unity plugin should depend on "Desktop Wall" plugin (LP: #683211)
   - Network indicator shows up on the left-hand side of the panel (LP: #680545)
   - Scrubbing menu items or indicators in panel prematurely ends (LP: #677601)
   - fix trash icon not being updated (LP: #683241)
  * Revert source 3, it's breaking daily build and hudson
  * remove the patch as well, fixed upstream
  * debian/control, debian/unity.install, debian/unity-common.install:
    - add unity-common package and move some files there
    - install the new perf bootchart there as well
  * debian/unity.install:
    - install new unity binary
  * debian/control:
    - dep on latest nux
    - recommends nux-tools
  * debian/libunity3.symbols:
    - updated to include the new symbols

  [ Sebastien Bacher ]
  * debian/source_unity.py:
    - reassign crashes due to the indicators to the right source directly
 -- Didier Roche <email address hidden> Thu, 09 Dec 2010 19:57:14 +0100

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Didier Roche (didrocks) on 2010-12-10
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers