Maximized windows larger than the screen lose decorations

Bug #667009 reported by Andres Muniz on 2010-10-26
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Didier Roche
unity (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gramps

Ubuntu 10.10 netbook.

I was expecting the window to fit within the dimensions of the window and while hitting F11 have the full space. I have reported in in Gramps where you can find most of the screen shots and reporting conversation.

http://www.gramps-project.org/bugs/view.php?id=4247
As a reference:
firefox: file, edit, view, ... menu is not on the top loosing what I belive is called screen real estate. F11 works fine.
Rythom box does show the bar on the top. included in the top bar. Terminal does it fine as well.

Sometimes the top pannel becomes transparent. (which I think is pretty cool) but then it goes away. .

Benny (benny-malengier) wrote :

I think you should not post this in gramps, but instead on
https://bugs.launchpad.net/ubuntu/+source/unity

Andres Muniz (andresmp) wrote :

Agreed, I don't know how to do this. I've put some tags to see if it helps.

tags: added: unity
tags: added: gramps ui
Duncan Lithgow (duncan-lithgow) wrote :

assigned to package unity

affects: gramps (Ubuntu) → unity (Ubuntu)

Please, just file one bug at a time, the firefox one is already done as the case. Subscribing for the gramps issue

summary: - does not dock correcty on unity
+ does not dock correcty on unity (gramps not maximized)
Changed in unity (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Didier Roche (didrocks) on 2010-11-03
Changed in unity:
status: New → Triaged
importance: Undecided → Low
Andres Muniz (andresmp) wrote :

Yes sorry, i'm getting to know this. Firefox, ooo, and others do not dock properly and have already been reported. But if you see the screenshot attached you can see that in the case of gramps the failiure is slightly different: there is an empty dpace across the top and left of the maximuzed window.

Thanks!

Neil J. Patel (njpatel) wrote :

This is caused by the maximised window's size being too large for the screen. It ends up not being decorated (urgh!). I'm keeping this bug as we'll surely run into it for the natty version of Unity.

Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
milestone: none → 3.4
summary: - does not dock correcty on unity (gramps not maximized)
+ Maximized windows larger than the screen lose decorations
Didier Roche (didrocks) on 2011-01-13
Changed in unity:
status: Triaged → Fix Committed
assignee: Neil J. Patel (njpatel) → Didier Roche (didrocks)
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Changed in unity:
milestone: 3.4 → 3.2.10
Didier Roche (didrocks) on 2011-01-14
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.2.12-0ubuntu1

---------------
unity (3.2.12-0ubuntu1) natty; urgency=low

  * New upstream release.
   - Window border doesn't get restored (LP: #691812)
   - When a menu is triggered from Alt+key, app name stays visible on panel
     (LP: #691765)
   - show the launcher on <Super> KeyPress, this will be needed when the
     shortcut will be implemented if we are in intellihide mode
   - Make sure an underscore is correctly placed under the corresponding
     accelerator-key. (LP: #683427)
   - Adding a dummy --replace option for compatibility reason (LP: #692569)
   - Compiz crashed with SIGSEGV in CompWindow::id() (LP: #694945)
   - Tooltip text not vertically centered (LP: #697791)
   - Maximizing a window horizontally or vertically removes the title bar
     (LP: #696780)
   - Mousewheel support for indicators (LP: #681428)
   - Avoid Quicklists being positioned so that they are partially offscreen at
     the bottom screen-edge. (LP: #691114)
   - Migrate awn, docky and cairo-dock dock launchers (LP: #692967)
   - Include manpages, and make them translatable. (LP: #684896)
   - Automaximize windows in Unity with some rules like blacklisting some
     applications, initial window size.
     It fixes also some bugs, like maximized window on first map not
     undecorated (LP: #667009, #669716, #693779, #691741)
   - Update libunity to conform to latest GIO VAPI breakage (LP: #679964)
   - Initial unity-atk module implementation (LP: #701680)
   - Panel autohide when on Quicklist (LP: #683261)
  * debian/control:
    - unity breaks on older bamf version (dbus protocol changed)
    - needs latest and greatest from dee
    - add libatk1.0-dev build-dep
  * CMakeList:
    - distro-patch to avoid building tests right now as building them is failing
      with the current vala/gir stack. THIS NEED TO BE REMOVED.
  * debian/rules:
    - don't --fail-missing as we don't want to install the vapi yet. The gir
      package will come next week.
  * debian/unity-common.install:
    - install the manpages
  * debian/libunity3.symbols:
    - updated
 -- Didier Roche <email address hidden> Fri, 14 Jan 2011 20:47:25 +0100

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions