Ubuntu

'Keep in launcher' item missing for some applications

Reported by James Clemence on 2010-10-10
150
This bug affects 28 people
Affects Status Importance Assigned to Milestone
BAMF
High
Jason Smith
Unity
High
Jason Smith
unity-2d
High
Unassigned
bamf (Ubuntu)
Undecided
Canonical Desktop Experience Team
Declined for Dapper by Brian Murray
Declined for Hardy by Brian Murray
Declined for Jaunty by Brian Murray
Declined for Karmic by Brian Murray
Declined for Lucid by Brian Murray
Natty
Undecided
Canonical Desktop Experience Team
unity (Ubuntu)
Medium
Unassigned
Declined for Dapper by Brian Murray
Declined for Hardy by Brian Murray
Declined for Jaunty by Brian Murray
Declined for Karmic by Brian Murray
Declined for Lucid by Brian Murray
Natty
Medium
Unassigned

Bug Description

Binary package hint: unity

Opening the chromium browser and then right clicking its icon in the unity launcher provides no 'keep in launcher' button, like all the other non-pinned applications. Why is this behaviour inconsistent?

Thanks,

J

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: unity 0.2.46-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
Architecture: i386
Date: Sun Oct 10 17:25:22 2010
InstallationMedia: Ubuntu-Netbook 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: unity

Update: the bug also affects 'homebank' (see duplicate).

James Clemence (jvc26) wrote :
Didier Roche (didrocks) on 2010-10-11
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in unity:
status: New → Triaged
importance: Undecided → High
milestone: none → 0.2-sru
David Barth (dbarth) wrote :

@gordallott: can you clarify on which condition the option may be missing from the quicklist?

Changed in unity:
assignee: nobody → Gord Allott (gordallott)
David Barth (dbarth) wrote :

gord says it should be a bamf issue with the fallback system where bamf doesn't provide a desktop file for an application.

Changed in unity:
assignee: Gord Allott (gordallott) → Jason Smith (jassmith)
Changed in bamf:
assignee: nobody → Jason Smith (jassmith)
importance: Undecided → High
status: New → Triaged
David Barth (dbarth) on 2010-10-11
summary: - Right clicking the chromium icon on the launcher does not allow 'keep in
- launcher' menu item
+ 'Keep in launcher' item missing for some applications
David Barth (dbarth) on 2010-10-11
description: updated
Brandon Konkle (brandon-konkle) wrote :

I'm experiencing this issue also, both with Chromium and Google Chrome. After installing the .deb package, I can use the Unity search or the Applications menu to launch Chromium. Either way, there doesn't seem to be a way to pin to the side-menu. Right-clicking provides the non-verbose name of the application - "Chromium-browser", and the only context option is "Quit". I'm using an HP Mini with an up-to-date UNE 10.10 from the final installer image.

Vish (vish) wrote :

From dup , Homebank also has similar problem

Brandon Konkle (brandon-konkle) wrote :

The latest libunity update resolved the issue for me. Thanks for the hard work! This unity interface is fantastic!

Benjamin Howe (bdhowe) wrote :

I'm still having this issue. I'm using the actual production release of 10.10 Netbook Edition, all updates applied. Asus EeePC 1005HAB.

Osik (stefan-tollkuehn) wrote :

I'm experiencing this bug also on my Asus eeePC 901. Every program I like to add does not show "Keep in launcher".

caseygtr (caseygtr) wrote :

I believe I have found a solution. I installed a package named libunity-dev. The description says: libunity-places is a shared library to be able to interact with the launcher and add places in Unity environment. After installing the package and restarting the system I had the option to "keep in launcher" for icons.

Benjamin Howe (bdhowe) wrote :

The latest round of routine updates solved this issue for me. I did not need to install libunity-dev.

Samuel Mehrbrodt (sam92) wrote :

For Homebank this is solved now.
But I have another program (KomodoEdit) which I installed manually (without deb package) and here I don't have the "Keep in launcher" item.

David Morley (d-morlo) wrote :

I'm still experiencing this issue on a clean updated install of 10.10 production, with both the stable and unstable builds of Google Chrome. I don't particularly want to have to install 130mb+ of dev packages on my netbook, simply in order to get libunity-dev and the icon functioning properly.

Lealcy B. Junior (lealcy) wrote :

I get the same issue with Instantbird. I'm using a fresh install of 10.10.

Alexander Fomichev (a-fom) wrote :

I've noticed that "keep in launcher" was in sub-menu and worked for everything even Chromium until I deleted several pre-installed icons. After that all the new applications have only "quit" item in their sub-menu.
Hope, this can help.

Alexander Fomichev (a-fom) wrote :

I've found a workaround for this issue.
1) Open terminal and type:
sudo dpkg-reconfigure libunity0
2) logout and login again
After that "keep in launcher" option returns back.

Changed in unity (Ubuntu Maverick):
status: New → Triaged
importance: Undecided → High
David Barth (dbarth) wrote :

Jason: can you determine whether there is an easy fix and most important a fix that in bamf/launcher that is also relevant to the new Natty version?

Alexander Sack (asac) wrote :

there are many different storires here in in this bug afaict ... here the few I see:

1. no launcher/.desktop can be found if you just run a random binary you installed on your system
  -> this needs some magic that would create a .desktop file if you click on the "keep in launcher" entry (and then we can display keep in launcher even if no .desktop is found)

2. .desktop file is not in the common search path
  -> at least $HOME/.local/share/applications should be considered ... also we can make the .desktop file handler smart to somehow register the .desktop file or even its location for tracking by bamf

3. application windows - even though they have a .desktop file - cannot be back-mapped to its launcher by bamf. freedesktop startup-notification protocol has the option to add a field "StartupWMClass=" to .desktop file which can be used to better do this ... for this bug i created a separate ticket (bug 693231) and submitted a fix there. This fixes "Keep in Launcher" for firefox dailies, gajim and probably others.

David Barth (dbarth) on 2011-01-07
Changed in unity:
milestone: 0.2-sru → 3.4
Neil J. Patel (njpatel) on 2011-01-18
Changed in unity:
milestone: 3.4 → 3.6
David Barth (dbarth) on 2011-01-21
Changed in unity (Ubuntu Natty):
milestone: none → natty-alpha-3
Sebastien Bacher (seb128) wrote :

lowering the maverick task, unity was only on UNE and the version used is different from the natty one, it has been decided to not spend efforts on fixing the old code but rather to focus on the natty version

Changed in unity (Ubuntu Maverick):
importance: High → Low
Changed in unity-2d:
milestone: none → 3.6
importance: Undecided → High
status: New → Triaged
Jason Smith (jassmith) wrote :

All items now have this option, though it may not always work

Changed in unity:
status: Triaged → Confirmed
Changed in unity-2d:
milestone: 3.6 → 3.8
Didier Roche (didrocks) on 2011-02-21
Changed in unity:
status: Confirmed → Triaged
Didier Roche (didrocks) on 2011-02-21
Changed in bamf (Ubuntu Natty):
status: New → Triaged
Martin Pitt (pitti) wrote :

Not a release blocker, and too late for a3 now.

Changed in unity (Ubuntu Natty):
importance: High → Medium
milestone: natty-alpha-3 → ubuntu-11.04-beta-1
Didier Roche (didrocks) on 2011-03-01
Changed in unity:
milestone: 3.6 → 3.6.2
Changed in unity-2d:
milestone: 3.8 → none
Neil J. Patel (njpatel) on 2011-03-07
Changed in unity:
milestone: 3.6.2 → 3.6.4
Vistaus (djmusic121) wrote :

It still doesn't work for KDE-programs and Firefox Dailys. Using Unity 2D bzr on 11.04

Changed in unity (Ubuntu Natty):
status: Triaged → Confirmed
Omer Akram (om26er) wrote :

Triaged means that this bug report have all the required information to be worked on. setting back as such

Changed in unity (Ubuntu Natty):
status: Confirmed → Triaged
Vistaus (djmusic121) wrote :

Sorry, misunderstood it. But is there being worked on for 11.04 2D?

Didier Roche (didrocks) on 2011-03-10
Changed in unity:
milestone: 3.6.4 → 3.6.6
Neil J. Patel (njpatel) on 2011-03-14
Changed in unity:
assignee: Jason Smith (jassmith) → Gord Allott (gordallott)
Changed in unity (Ubuntu Natty):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)

No idea, Kate, seems like a bug not a feature :-)

Changed in bamf (Ubuntu Natty):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Neil J. Patel (njpatel) on 2011-03-17
Changed in unity:
status: Triaged → Fix Released
assignee: Gord Allott (gordallott) → Jason Smith (jassmith)
Didier Roche (didrocks) on 2011-03-17
Changed in bamf:
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.2.80-0ubuntu1

---------------
bamf (0.2.80-0ubuntu1) natty; urgency=low

  * New upstream release.
    - 'Keep in launcher' item missing for some applications (LP: #657771)
    - can't pin KTouch to the launcher (LP: #693755)
 -- Didier Roche <email address hidden> Thu, 17 Mar 2011 17:51:00 +0100

Changed in bamf (Ubuntu Natty):
status: Triaged → Fix Released
Patrick Dickey (pdickeybeta) wrote :

This still occurs with the Thunderbird Daily "Shredder" builds (not the Firefox Daily "Namarooka" builds though). This is on a clean install of Unity-2d made on 3/20/2011 on Maverick.

Have a great day:)
Patrick.

Changed in unity (Ubuntu Natty):
milestone: ubuntu-11.04-beta-1 → ubuntu-11.04-beta-2
David Barth (dbarth) on 2011-04-08
Changed in unity (Ubuntu Natty):
status: Triaged → Fix Released
assignee: Canonical Desktop Experience Team (canonical-dx-team) → nobody
Olivier Tilloy (osomon) wrote :

On a related note, Unity 2D supports drag’n’drop of custom desktop files to the launcher to add new favorites.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bamf (Ubuntu Maverick):
status: New → Confirmed
Michał Sawicz (saviq) on 2011-09-26
Changed in unity-2d:
status: Triaged → Fix Released
Jani Monoses (jani) wrote :

Does not work for me with gvim in unity-2d in Precise. I only see a Quit menu item added.

no longer affects: unity (Ubuntu Maverick)
no longer affects: bamf (Ubuntu Maverick)
no longer affects: bamf (Ubuntu Quantal)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers