Ubuntu

Comment 15 for bug 603415

While the Compiz Zoom plugin might be appropriate for advanced users, modulo the significant caveats you mentioned, it requires manually configuring Compiz with ccsm, which is not installed by default, and which is beyond the capability of most users. It is therefore not an appropriately general solution for Ubuntu.

In any case, this bug is not about the lack of zoom functionality (which is a problem) but rather that the integration of zoom functionality with the desktop is broken.