Some indicator icons are missing after unlocking the screen

Bug #1635625 reported by Alin Andrei on 2016-10-21
312
This bug affects 61 people
Affects Status Importance Assigned to Milestone
unity (Ubuntu)
High
Alex
Nominated for Vivid by Marco Trevisan (Treviño)
Yakkety
Undecided
Alex

Bug Description

[Impact]
In Ubuntu 16.10, some indicator icons are missing (the indicators still show up, but their icon is missing - screenshot: http://i.imgur.com/TkxiBRi.png ) after unlocking the screen. This occurs with both Skype stable and SkypeForLinux Alpha, Electron applications (like WMail: https://github.com/Thomas101/wmail/releases), Telegram and others.

[Test case]
To reproduce it, simply run one the of apps mentioned above, make sure its AppIndicator icon is visible, then lock the desktop, and unlock it.

[Regression potential]
Indicators in lockscreen with special icons could have a wrong emblem (none of the ones used is known to do so, though).

---

Update: quitting any indicator (including those not affected by this) fixes this issue. Until you lock and then unlock the screen again, then it occurs once more.

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: unity 7.5.0+16.10.20160906.1-0ubuntu1
ProcVersionSignature: Ubuntu 4.8.0-26.28-generic 4.8.0
Uname: Linux 4.8.0-26-generic x86_64
.tmp.unity_support_test.0:

ApportVersion: 2.20.3-0ubuntu8
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,staticswitcher,workarounds,scale,expo,ezoom,dbus]
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Fri Oct 21 15:57:54 2016
DistUpgraded: Fresh install
DistroCodename: yakkety
DistroVariant: ubuntu
GconfCompiz:
 /apps/compiz-1/general:
   /apps/compiz-1/general/screen0:
    /apps/compiz-1/general/screen0/options:
     active_plugins = [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,staticswitcher,workarounds,scale,expo,ezoom,dbus]
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Dell 2nd Generation Core Processor Family Integrated Graphics Controller [1028:0571]
 NVIDIA Corporation GF116M [GeForce GT 555M/635M] [10de:124d] (rev ff) (prog-if ff)
InstallationDate: Installed on 2015-03-11 (590 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20150306)
MachineType: Dell Inc. Dell System XPS L702X
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.8.0-26-generic root=UUID=9694e135-3bc6-4ddc-b9d1-48bbf720a6d5 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/18/2012
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A18
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 0XN71K
dmi.board.vendor: Dell Inc.
dmi.board.version: FAB1
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA18:bd06/18/2012:svnDellInc.:pnDellSystemXPSL702X:pvr:rvnDellInc.:rn0XN71K:rvrFAB1:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: Dell System XPS L702X
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.13.0+16.10.20160818.2-0ubuntu2
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.70-1
version.libgl1-mesa-dri: libgl1-mesa-dri 12.0.3-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 12.0.3-1ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.18.4-1ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.2-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.1-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160706-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-2

Related branches

Alin Andrei (nilarimogard) wrote :
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Eduards Bezverhijs (mjasnik) wrote :

There is similar bug report for this very the same issue: https://bugs.launchpad.net/ubuntu/+source/skype/+bug/1633174

Skype & skypeforlinux is affected for me, as I don't use any other affected software.
I can confirm that guake (python) & keepassx (qt) & clipit (gtk) does not have the problem.

I'll add that 16.04, 14.04 have no issue like this.

Eduards Bezverhijs (mjasnik) wrote :

In addition I tried to update icon cache, which dit not help. Tried for global themes in /usr and in local themes as well.

Changed in unity (Ubuntu):
importance: Undecided → High
Doctor Rover (doctor-rover) wrote :

I confirm this bug for GoldenDict (Qt).

description: updated
Carlo Cannas (carlo94) wrote :

The culprit is revision 4187 (http://bazaar.launchpad.net/~unity-team/unity/trunk/revision/4187): in lockscreen::Controller a new menu::Manager instance is created to handle the lockscreen indicators, then as soon the new LockScreenDBusIndicators instance connects to the new com.canonical.Unity.Panel.Service.LockScreen bus it calls DBusIndicators::Impl::OnIconsPathChanged, which asks the lockscreen panel service for icon paths, but the *lockscreen* panel service is just started and doesn't know any of the new paths needed for the indicators which provide custom icons, so it just reports the default icon theme search paths. An icon_paths_changed signal is emitted which invokes menu::Manager::Impl::IconPathsChanged that sets the search paths for the default GTK icon theme (which is a global shared resource of the process).
After unlocking the screen no signal is sent to recover the proper search paths, so some indicators shows the missing icon.
Maybe a better way to handle this whole indicators icon thing would be to have a different GTK icon theme object for each menu::Manager instance instead of modifying the global default icon theme?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.5.0+17.04.20161107.2-0ubuntu1

---------------
unity (7.5.0+17.04.20161107.2-0ubuntu1) zesty; urgency=medium

  [ Andrea Azzarone ]
  * Properly handle the file manager copy dialog in
    FileManagerLauncherIcon and in StorageLauncherIcon. (LP: #1575452,
    #1609845)
  * Correctly position the force quit dialog when scaling is different
    than 1.0 (LP: #1637991)
  * GnomeSession: Retrieve the session id using dbus if $XDG_SESSION_ID
    is not set

  [ Marco Trevisan (Treviño) ]
  * LockScreenController: ignore icon_paths_changed signal in
    menumanager for Lockscreen (LP: #1635625)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Mon, 07 Nov 2016 23:31:33 +0000

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Maximilian (ma27) wrote :

is it planned to release this change on ubuntu 16.10, too?
According to the unity main page this release is only available in 17.04...

Download full text (4.5 KiB)

It doesn't seem like it is. Shouldn't it be obvious to release the fix
to 16.10 too?

On Tue, Nov 8, 2016 at 11:24 PM, Maximilian
<email address hidden> wrote:
> is it planned to release this change on ubuntu 16.10, too?
> According to the unity main page this release is only available in
> 17.04...
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1638190).
> https://bugs.launchpad.net/bugs/1635625
>
> Title:
> Some indicator icons are missing after unlocking the screen
>
> Status in unity package in Ubuntu:
> Fix Released
>
> Bug description:
> In Ubuntu 16.10, some indicator icons are missing (the indicators
> still show up, but their icon is missing - screenshot:
> http://i.imgur.com/TkxiBRi.png ) after unlocking the screen. This
> occurs with both Skype stable and SkypeForLinux Alpha, Electron
> applications (like WMail:
> https://github.com/Thomas101/wmail/releases), and others.
>
> To reproduce it, simply run one the of apps mentioned above, make
> sure
> its AppIndicator icon is visible, then lock the desktop, and unlock
> it.
>
> Update: quitting any indicator (including those not affected by
> this)
> fixes this issue. Until you lock and then unlock the screen again,
> then it occurs once more.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 16.10
> Package: unity 7.5.0+16.10.20160906.1-0ubuntu1
> ProcVersionSignature: Ubuntu 4.8.0-26.28-generic 4.8.0
> Uname: Linux 4.8.0-26-generic x86_64
> .tmp.unity_support_test.0:
>
> ApportVersion: 2.20.3-0ubuntu8
> Architecture: amd64
> CompizPlugins:
> [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,staticswitcher,workarounds,scale,expo,ezoom,dbus]
> CompositorRunning: compiz
> CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
> CompositorUnredirectFSW: true
> CurrentDesktop: Unity
> Date: Fri Oct 21 15:57:54 2016
> DistUpgraded: Fresh install
> DistroCodename: yakkety
> DistroVariant: ubuntu
> GconfCompiz:
> /apps/compiz-1/general:
> /apps/compiz-1/general/screen0:
> /apps/compiz-1/general/screen0/options:
> active_plugins =
> [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,staticswitcher,workarounds,scale,expo,ezoom,dbus]
> GraphicsCard:
> Intel Corporation 2nd Generation Core Processor Family Integrated
> Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
> Subsystem: Dell 2nd Generation Core Processor Family Integrated
> Graphics Controller [1028:0571]
> NVIDIA Corporation GF116M [GeForce GT 555M/635M] [10de:124d] (rev
> ff) (prog-if ff)
> InstallationDate: Installed on 2015-03-11 (590 days ago)
> InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Alpha amd64
> (20150306)
> MachineType: Dell Inc. Dell System XPS L702X
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.8.0-26-generic
> root=UUID=9694e135-3bc6-4ddc-b9d1-48bbf720a6d5 ro quiet splash
> vt.handoff=7
> SourcePackage: unity
> Upgrad...

Read more...

On the way... https://bileto.ubuntu.com/#/ticket/2192

Install unity from that PPA to get the fix now.

description: updated
Maximilian (ma27) wrote :

thank you :)

Reny (reny1977) wrote :

thanks! ppa https://bileto.ubuntu.com/#/ticket/2192 solved to me!!!

Jatan (uncertainquark) wrote :
Download full text (4.6 KiB)

How long till the official update gets pushed to 16.10?

On Sun, Nov 13, 2016 at 6:53 PM, Reny <email address hidden> wrote:

> thanks! ppa https://bileto.ubuntu.com/#/ticket/2192 solved to me!!!
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1638190).
> https://bugs.launchpad.net/bugs/1635625
>
> Title:
> Some indicator icons are missing after unlocking the screen
>
> Status in unity package in Ubuntu:
> Fix Released
>
> Bug description:
> [Impact]
> In Ubuntu 16.10, some indicator icons are missing (the indicators still
> show up, but their icon is missing - screenshot:
> http://i.imgur.com/TkxiBRi.png ) after unlocking the screen. This occurs
> with both Skype stable and SkypeForLinux Alpha, Electron applications (like
> WMail: https://github.com/Thomas101/wmail/releases), Telegram and others.
>
> [Test case]
> To reproduce it, simply run one the of apps mentioned above, make sure
> its AppIndicator icon is visible, then lock the desktop, and unlock it.
>
> [Regression potential]
> Indicators in lockscreen with special icons could have a wrong emblem
> (none of the ones used is known to do so, though).
>
> ---
>
> Update: quitting any indicator (including those not affected by this)
> fixes this issue. Until you lock and then unlock the screen again,
> then it occurs once more.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 16.10
> Package: unity 7.5.0+16.10.20160906.1-0ubuntu1
> ProcVersionSignature: Ubuntu 4.8.0-26.28-generic 4.8.0
> Uname: Linux 4.8.0-26-generic x86_64
> .tmp.unity_support_test.0:
>
> ApportVersion: 2.20.3-0ubuntu8
> Architecture: amd64
> CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,
> snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,
> session,gnomecompat,animation,fade,staticswitcher,
> workarounds,scale,expo,ezoom,dbus]
> CompositorRunning: compiz
> CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
> CompositorUnredirectFSW: true
> CurrentDesktop: Unity
> Date: Fri Oct 21 15:57:54 2016
> DistUpgraded: Fresh install
> DistroCodename: yakkety
> DistroVariant: ubuntu
> GconfCompiz:
> /apps/compiz-1/general:
> /apps/compiz-1/general/screen0:
> /apps/compiz-1/general/screen0/options:
> active_plugins = [core,composite,opengl,
> compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,
> move,wall,grid,regex,imgpng,session,gnomecompat,animation,
> fade,staticswitcher,workarounds,scale,expo,ezoom,dbus]
> GraphicsCard:
> Intel Corporation 2nd Generation Core Processor Family Integrated
> Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
> Subsystem: Dell 2nd Generation Core Processor Family Integrated
> Graphics Controller [1028:0571]
> NVIDIA Corporation GF116M [GeForce GT 555M/635M] [10de:124d] (rev ff)
> (prog-if ff)
> InstallationDate: Installed on 2015-03-11 (590 days ago)
> InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20150306)
> MachineType: Dell Inc. Dell System XPS L702X
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.8.0-26-generic
> root=UUID=9694e135-3bc6-4ddc-b9d1-48bbf720a6d...

Read more...

Jatan (uncertainquark) wrote :
Download full text (5.0 KiB)

The update isn't out yet to Ubuntu 16.10, while it's fixed for Ubuntu
17.04. It kinda doesn't make sense to not have it pushed to 16.10 since
many people are using it. When is it expected to be pushed to all users?

On Mon, Nov 14, 2016 at 8:59 PM, Jatan Mehta <email address hidden>
wrote:

> How long till the official update gets pushed to 16.10?
>
> On Sun, Nov 13, 2016 at 6:53 PM, Reny <email address hidden> wrote:
>
>> thanks! ppa https://bileto.ubuntu.com/#/ticket/2192 solved to me!!!
>>
>> --
>> You received this bug notification because you are subscribed to a
>> duplicate bug report (1638190).
>> https://bugs.launchpad.net/bugs/1635625
>>
>> Title:
>> Some indicator icons are missing after unlocking the screen
>>
>> Status in unity package in Ubuntu:
>> Fix Released
>>
>> Bug description:
>> [Impact]
>> In Ubuntu 16.10, some indicator icons are missing (the indicators still
>> show up, but their icon is missing - screenshot:
>> http://i.imgur.com/TkxiBRi.png ) after unlocking the screen. This occurs
>> with both Skype stable and SkypeForLinux Alpha, Electron applications (like
>> WMail: https://github.com/Thomas101/wmail/releases), Telegram and others.
>>
>> [Test case]
>> To reproduce it, simply run one the of apps mentioned above, make sure
>> its AppIndicator icon is visible, then lock the desktop, and unlock it.
>>
>> [Regression potential]
>> Indicators in lockscreen with special icons could have a wrong emblem
>> (none of the ones used is known to do so, though).
>>
>> ---
>>
>> Update: quitting any indicator (including those not affected by this)
>> fixes this issue. Until you lock and then unlock the screen again,
>> then it occurs once more.
>>
>> ProblemType: Bug
>> DistroRelease: Ubuntu 16.10
>> Package: unity 7.5.0+16.10.20160906.1-0ubuntu1
>> ProcVersionSignature: Ubuntu 4.8.0-26.28-generic 4.8.0
>> Uname: Linux 4.8.0-26-generic x86_64
>> .tmp.unity_support_test.0:
>>
>> ApportVersion: 2.20.3-0ubuntu8
>> Architecture: amd64
>> CompizPlugins: [core,composite,opengl,compizt
>> oolbox,decor,vpswitch,snap,mousepoll,resize,place,move,
>> wall,grid,regex,imgpng,session,gnomecompat,animation,fade,
>> staticswitcher,workarounds,scale,expo,ezoom,dbus]
>> CompositorRunning: compiz
>> CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
>> CompositorUnredirectFSW: true
>> CurrentDesktop: Unity
>> Date: Fri Oct 21 15:57:54 2016
>> DistUpgraded: Fresh install
>> DistroCodename: yakkety
>> DistroVariant: ubuntu
>> GconfCompiz:
>> /apps/compiz-1/general:
>> /apps/compiz-1/general/screen0:
>> /apps/compiz-1/general/screen0/options:
>> active_plugins = [core,composite,opengl,compizt
>> oolbox,decor,vpswitch,snap,mousepoll,resize,place,move,
>> wall,grid,regex,imgpng,session,gnomecompat,animation,fade,
>> staticswitcher,workarounds,scale,expo,ezoom,dbus]
>> GraphicsCard:
>> Intel Corporation 2nd Generation Core Processor Family Integrated
>> Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
>> Subsystem: Dell 2nd Generation Core Processor Family Integrated
>> Graphics Controller [1028:0571]
>> NVIDIA Corp...

Read more...

Jatan,

It has to go through the SRU process (https://wiki.ubuntu.com/StableReleaseUpdates) and it's already in that direction, so it will take a little.

santhosh (santhoshv) wrote :

I also have this issue. Is it a confirmed one?

Hello Alin, or anyone else affected,

Accepted unity into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity/7.5.0+16.10.20161112-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Yakkety):
status: New → Fix Committed
tags: added: verification-needed
Thomas Krause (krause) wrote :

I tested version 7.5.0+16.10.20161112-0ubuntu1 from yakkety-proposed and this bug is fixed for me.

tags: added: verification-done
removed: verification-needed
Eduardo (ludentico) wrote :

After enabling proposed, installed all new packages and reboot, this bug was also fixed in my case.

Theo Nolte (theo-nolte) wrote :

yes, enabling proposed and rebooting worked for me too.

Download full text (4.7 KiB)

The bug is fixed for me too after the update.

On Wed, Nov 30, 2016 at 1:26 PM, Theo Nolte <email address hidden>
wrote:

> yes, enabling proposed and rebooting worked for me too.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1638190).
> https://bugs.launchpad.net/bugs/1635625
>
> Title:
> Some indicator icons are missing after unlocking the screen
>
> Status in unity package in Ubuntu:
> Fix Released
> Status in unity source package in Yakkety:
> Fix Committed
>
> Bug description:
> [Impact]
> In Ubuntu 16.10, some indicator icons are missing (the indicators still
> show up, but their icon is missing - screenshot:
> http://i.imgur.com/TkxiBRi.png ) after unlocking the screen. This occurs
> with both Skype stable and SkypeForLinux Alpha, Electron applications (like
> WMail: https://github.com/Thomas101/wmail/releases), Telegram and others.
>
> [Test case]
> To reproduce it, simply run one the of apps mentioned above, make sure
> its AppIndicator icon is visible, then lock the desktop, and unlock it.
>
> [Regression potential]
> Indicators in lockscreen with special icons could have a wrong emblem
> (none of the ones used is known to do so, though).
>
> ---
>
> Update: quitting any indicator (including those not affected by this)
> fixes this issue. Until you lock and then unlock the screen again,
> then it occurs once more.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 16.10
> Package: unity 7.5.0+16.10.20160906.1-0ubuntu1
> ProcVersionSignature: Ubuntu 4.8.0-26.28-generic 4.8.0
> Uname: Linux 4.8.0-26-generic x86_64
> .tmp.unity_support_test.0:
>
> ApportVersion: 2.20.3-0ubuntu8
> Architecture: amd64
> CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,
> snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,
> session,gnomecompat,animation,fade,staticswitcher,
> workarounds,scale,expo,ezoom,dbus]
> CompositorRunning: compiz
> CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
> CompositorUnredirectFSW: true
> CurrentDesktop: Unity
> Date: Fri Oct 21 15:57:54 2016
> DistUpgraded: Fresh install
> DistroCodename: yakkety
> DistroVariant: ubuntu
> GconfCompiz:
> /apps/compiz-1/general:
> /apps/compiz-1/general/screen0:
> /apps/compiz-1/general/screen0/options:
> active_plugins = [core,composite,opengl,
> compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,
> move,wall,grid,regex,imgpng,session,gnomecompat,animation,
> fade,staticswitcher,workarounds,scale,expo,ezoom,dbus]
> GraphicsCard:
> Intel Corporation 2nd Generation Core Processor Family Integrated
> Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
> Subsystem: Dell 2nd Generation Core Processor Family Integrated
> Graphics Controller [1028:0571]
> NVIDIA Corporation GF116M [GeForce GT 555M/635M] [10de:124d] (rev ff)
> (prog-if ff)
> InstallationDate: Installed on 2015-03-11 (590 days ago)
> InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20150306)
> MachineType: Dell Inc. Dell System XPS L702X
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.8.0-26-generic
...

Read more...

KenWilson (ken.wilson) wrote :

I also experience this problem with two icons (HP printer & Synology NAS). I have tested the bug fix from the pre-release package and find it works for me.

Current Package:
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-==============-===============================-============-===========================================================
ii unity 7.5.0+16.10.20160906.1-0ubuntu1 amd64 Interface designed for efficiency of space and interaction.

Pre-release Package:
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-==============-=============================-============-===========================================================
ii unity 7.5.0+16.10.20161112-0ubuntu1 amd64 Interface designed for efficiency of space and interaction.

Ken

KenWilson (ken.wilson) wrote :

I have updated my HP Pavilion (laptop) from 16.04 to 16.10. After the update it also experienced this icon issue. I installed the pre-release package and can confirm it has resolved the issue.

Original Package:
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-==============-===============================-============-===========================================================
ii unity 7.5.0+16.10.20160906.1-0ubuntu1 amd64 Interface designed for efficiency of space and interaction.

Pre-release Package:
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-==============-=============================-============-===========================================================
ii unity 7.5.0+16.10.20161112-0ubuntu1 amd64 Interface designed for efficiency of space and interaction.

Ken

Alex (alexvaa) on 2016-12-11
Changed in unity (Ubuntu Yakkety):
assignee: nobody → Alex (alexvaa)
Changed in unity (Ubuntu):
assignee: nobody → Alex (alexvaa)
Ivan (adamapollo) wrote :

is there any way to fix this in 16.10 without installing stuff from other PPA ? thanks

Stilor (stilor) wrote :

Is this ever going to regular 16.10 PPA?

I can confirm that update fixed this bug for me (enabling proposed and reboot). Thanks!!!

Or Schiro (orschiro) wrote :

Dear all,

This is great!

It solved my bug [1] as well on 16.10. :-)

I opened "Software & Updates" > "Developer Options" > enabled Pre-released updates.

Et voila. :-)

-Robert

[1] https://bugs.launchpad.net/ubuntu/+source/indicator-application/+bug/1655712

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.5.0+16.10.20161112-0ubuntu1

---------------
unity (7.5.0+16.10.20161112-0ubuntu1) yakkety; urgency=medium

  [ Marco Trevisan (Treviño) ]
  * LockScreenController: ignore icon_paths_changed signal in
    menumanager for Lockscreen (LP: #1635625)

  [ Andrea Azzarone ]
  * Properly handle the file manager copy dialog in
    FileManagerLauncherIcon and in StorageLauncherIcon. (LP: #1575452,
    LP: #1609845)
  * Correctly position the force quit dialog when scaling is different
    than 1.0 (LP: #1637991)
  * GnomeSession: Retrieve the session id using dbus if $XDG_SESSION_ID
    is not set (LP: #1633749)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Sat, 12 Nov 2016 02:13:01 +0000

Changed in unity (Ubuntu Yakkety):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Reece (reece) wrote :

Still problematic on 18.04.

Workaround: alt-f2, then "r" to restart gnome-shell.

Related reading:
https://bugreports.qt.io/browse/QTBUG-63065
https://github.com/ubuntu/gnome-shell-extension-appindicator/issues/75

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.