Mouse cursor has wrong postition (Ubuntu 16.04)

Bug #1612965 reported by t-nub on 2016-08-13
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
unity (Ubuntu)
High
Unassigned

Bug Description

The mouse cursor in some apps (Chromium, Opera, JOSM and some others) sometimes points at the wrong position. The real point is a little bit lower than the cursor. At the same time, the cursor is working well in the dash menu, panel menus and desktop. It may be bug compiz or unity. Some users before had similar issue on Ubuntu 14.04 (Bug #1306550). After minimize/maximize windows cursor has normal position, but it happens again.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: unity 7.4.0+16.04.20160715-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-31.50-generic 4.4.13
Uname: Linux 4.4.0-31-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia
.proc.driver.nvidia.gpus.0000.01.00.0: Error: [Errno 21] Є каталогом: '/proc/driver/nvidia/gpus/0000:01:00.0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 340.96 Sun Nov 8 22:33:28 PST 2015
 GCC version: gcc version 5.4.0 20160609 (Ubuntu 5.4.0-6ubuntu1~16.04.1)
.tmp.unity_support_test.0:

ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
BootLog:

CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Sat Aug 13 18:47:10 2016
DistUpgraded: Fresh install
DistroCodename: xenial
DistroVariant: ubuntu
DkmsStatus:
 bbswitch, 0.8, 4.4.0-21-generic, x86_64: installed
 bbswitch, 0.8, 4.4.0-31-generic, x86_64: installed
 nvidia-340, 340.96, 4.4.0-21-generic, x86_64: installed
 nvidia-340, 340.96, 4.4.0-31-generic, x86_64: installed
GraphicsCard:
 NVIDIA Corporation GT218 [GeForce 210] [10de:0a65] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. GT218 [GeForce 210] [1043:8343]
InstallationDate: Installed on 2016-07-23 (21 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
MachineType: System manufacturer P5K SE
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-31-generic root=UUID=b57ad7ce-3d93-434d-bf97-59f0698ae48f ro quiet splash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/19/2007
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0401
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5K SE
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0401:bd07/19/2007:svnSystemmanufacturer:pnP5KSE:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5KSE:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: P5K SE
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.12.2+16.04.20160714-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.67-1ubuntu0.16.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.2.0-1ubuntu2.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.2.0-1ubuntu2.1
version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.18.3-1ubuntu2.3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1build2
xserver.bootTime: Sat Aug 13 13:08:31 2016
xserver.configfile: default
xserver.errors: open /dev/fb0: No such file or directory
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.18.3-1ubuntu2.3

t-nub (romanivchenkone) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
importance: Undecided → High
Frank Claessen (f-a-n-claessen) wrote :

Same problem here. The way to provoke this is the following:
Open up some application - f.e. Libreoffice Writer
Do a few mouse clicks - everythin ok
Then go to one of the hot corners
Then back to L-writer - mouse pointer is off.
In LO-writer minimize/maximize window and all is well again

Compiz is the culprit?

t-nub (romanivchenkone) wrote :

Here some information about this bun in 14.04 here:
http://askubuntu.com/questions/469341/ubuntu-14-04-mouse-pointing-problem

This bug appears when Unity setting has been changed in ccsm:
"CompizConfig option Ubuntu Unity Plugin > Switcher > Show live previews of windows in the Switcher. When the option is checked the mouse mismatch doesn't occur"

But, when this option ischecked, hot horner "show desktop" in Unity is not working.

To post a comment you must log in.