compiz crashed with SIGSEGV in unity::dash::PlacesGroup::Draw()

Bug #1569100 reported by David Maillie on 2016-04-12
60
This bug affects 9 people
Affects Status Importance Assigned to Milestone
unity (Ubuntu)
High
Andrea Azzarone

Bug Description

Sorry, can't remember what I was doing when the crash happened....

ProblemType: Crash
DistroRelease: Ubuntu 16.04
Package: compiz-core 1:0.9.12.2+16.04.20160331-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-18.34-generic 4.4.6
Uname: Linux 4.4.0-18-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 361.42 Tue Mar 22 18:10:58 PDT 2016
 GCC version: gcc version 5.3.1 20160407 (Ubuntu 5.3.1-13ubuntu6)
ApportVersion: 2.20.1-0ubuntu1
Architecture: amd64
BootLog:

CrashCounter: 1
CurrentDesktop: Unity
Date: Mon Apr 11 16:26:24 2016
DistUpgraded: Fresh install
DistroCodename: xenial
DistroVariant: ubuntu
DkmsStatus:
 bbswitch, 0.8, 4.4.0-17-generic, x86_64: installed
 bbswitch, 0.8, 4.4.0-18-generic, x86_64: installed
 nvidia-361, 361.42, 4.4.0-17-generic, x86_64: installed
 nvidia-361, 361.42, 4.4.0-18-generic, x86_64: installed
ExecutablePath: /usr/bin/compiz
GraphicsCard:
 NVIDIA Corporation GM107 [GeForce GTX 750 Ti] [10de:1380] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: eVga.com. Corp. GM107 [GeForce GTX 750 Ti] [3842:3751]
InstallationDate: Installed on 2016-03-25 (17 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Beta amd64 (20160323)
MachineType: ASUS All Series
ProcCmdline: compiz
ProcEnviron:
 PATH=(custom, user)
 SHELL=/bin/bash
 LANG=en_CA.UTF-8
 LANGUAGE=en_CA:en
 XDG_RUNTIME_DIR=<set>
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-18-generic root=UUID=4096aa3a-fbf1-488e-8527-61aaa2447c4f ro quiet splash
SegvAnalysis:
 Segfault happened at: 0x4bbbf00: xor %al,(%rax)
 PC (0x04bbbf00) in non-executable VMA region: 0x00f18000-0x0a95c000 rw-p [heap]
 source "%al" ok
 destination "(%rax)" (0x7fdda1c8ec00) ok
SegvReason: executing writable VMA [heap]
Signal: 11
SourcePackage: compiz
StacktraceTop:
 ?? ()
 unity::dash::PlacesGroup::Draw(nux::GraphicsEngine&, bool) () from /usr/lib/x86_64-linux-gnu/compiz/libunityshell.so
 nux::View::ProcessDraw(nux::GraphicsEngine&, bool) () from /usr/lib/x86_64-linux-gnu/libnux-4.0.so.0
 nux::Layout::ProcessDraw(nux::GraphicsEngine&, bool) () from /usr/lib/x86_64-linux-gnu/libnux-4.0.so.0
 nux::ScrollView::DrawContent(nux::GraphicsEngine&, bool) () from /usr/lib/x86_64-linux-gnu/libnux-4.0.so.0
Title: compiz crashed with SIGSEGV in unity::dash::PlacesGroup::Draw()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 08/15/2014
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 2103
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: Z87-A
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr2103:bd08/15/2014:svnASUS:pnAllSeries:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnZ87-A:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: All Series
dmi.product.version: System Version
dmi.sys.vendor: ASUS
version.compiz: compiz 1:0.9.12.2+16.04.20160331-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.67-1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.2.0-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.2.0-1ubuntu1
version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.18.3-1ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1build2
xserver.bootTime: Mon Apr 11 15:56:17 2016
xserver.configfile: default
xserver.errors: open /dev/fb0: No such file or directory
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.18.3-1ubuntu2

Related branches

David Maillie (dmaillie) wrote :

StacktraceTop:
 ?? ()
 unity::dash::PlacesGroup::Draw (this=0x7d98d50, graphics_engine=..., forceDraw=<optimized out>) at /build/unity-6qWUdB/unity-7.4.0+16.04.20160401.1/dash/PlacesGroup.cpp:505
 nux::View::ProcessDraw (this=0x7d98d50, graphics_engine=..., force_draw=<optimized out>) at View.cpp:228
 nux::Layout::ProcessDraw (this=0x16a8800, graphics_engine=..., force_draw=<optimized out>) at Layout.cpp:576
 nux::ScrollView::DrawContent (this=0x164ec70, graphics_engine=..., force_draw=<optimized out>) at ScrollView.cpp:208

Changed in compiz (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
tags: added: compiz-0.9
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
information type: Private → Public
Changed in compiz (Ubuntu):
importance: Medium → High
tags: added: rls-x-incoming
Changed in compiz (Ubuntu):
assignee: nobody → Andrea Azzarone (azzar1)
Andrea Azzarone (azzar1) on 2016-04-15
no longer affects: compiz (Ubuntu)
Changed in unity (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Andrea Azzarone (azzar1)
Andrea Azzarone (azzar1) on 2016-04-15
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.4.0+16.04.20160415-0ubuntu1

---------------
unity (7.4.0+16.04.20160415-0ubuntu1) xenial; urgency=medium

  [ Andrea Azzarone ]
  * Do not use pointers to LazyLoadTextures. (LP: #1569100)
  * Fix unity script crash. (LP: #1566565)
  * LockscreenController: Don't use SetActivate(False) for gnome-
    screensaver to prevent unlocking on tty switch. It will not only
    deactivate the screensaver but also unlock the screen. (LP:
    #1552537)
  * unityshell.xml: Fix typo (LP: #1559427)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Fri, 15 Apr 2016 05:33:08 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
19700904@qq.com (19700904-8) wrote :

sudo add-apt-repository ppa:mamarley/nvidia

Mandip Panta (mandip698) on 2017-12-09
description: updated
Mike Baker (mike-mikebaker) wrote :

I get this error when I hit the DASH button on Launcher.
System was working well then something changed now I can't resolve this problem?
Status indicates 'Fix Released', how do I get to the fix?
Thanks

To post a comment you must log in.