desktop or other past screen contents visible before lockscreen on resume

Bug #1375271 reported by Adam Colligan on 2014-09-29
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
GNOME Screensaver
Invalid
Undecided
Unassigned
Unity
Fix Released
Medium
Andrea Azzarone
7.2
Fix Released
Medium
Unassigned
unity (Ubuntu)
Medium
Andrea Azzarone
Trusty
Undecided
Unassigned

Bug Description

[Impact]

On resume from suspend, screen contents are displayed for a brief time (perhaps 0.5 to 1 sec) before the lock dialog appears.

These screen contents are not always the desktop or open application beneath the lock screen. On at least one occasion, the screen showed content from a full-screen video that had been playing in Firefox some time before the computer had been suspended: neither the video nor its underlying tab were open anymore, so the image(s) was likely part of a buffer somewhere. (Needless to say, if the wrong full-screen video had been watched, depending on the setting, this could be a quite serious issue for some users).

[Test Case]

Suspend and resume the computer (closing the lid or using the session indicator). Since this problem involves a race condition, it is not reliably reproducable at will.

[Regression Potential]

This fix unmaps windows when a suspend or shutdown event occurs: it is possible that the window(s) do not get remapped when a wake event occurs, or the wake even does not get propagated. This does not appear to occur in practice.

[Other Info]

The Ubuntu 14.04 LTS SRU was cherry-picked from upstream Unity where it has been released in the Ubuntu "Vivid Vervet" development release for a couple of months with no apparent regressions.

Related branches

Adam Colligan (adam-p) wrote :
description: updated
Adam Colligan (adam-p) on 2014-09-29
description: updated
description: updated
Marc Deslauriers (mdeslaur) wrote :

What desktop environment are you using?

information type: Private Security → Public
Adam Colligan (adam-p) wrote :

This is stock Ubuntu Unity. Sorry if the gnome screensaver package was a wrong one to add -- I had thought that it was used for lockscreen in unity, and it was involved in the 2011 report.

Changed in compiz:
status: New → Incomplete
status: Incomplete → New
Adam Colligan (adam-p) wrote :

Let me know if there is any specific testing pattern, video recording, or config information I could provide that might help.

Andrea Azzarone (azzar1) on 2014-10-21
Changed in unity:
importance: Undecided → High
assignee: nobody → Andrea Azzarone (andyrock)
milestone: none → 7.3.1
milestone: 7.3.1 → 7.3.2
no longer affects: compiz
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
importance: High → Medium
status: New → In Progress
Changed in unity (Ubuntu):
status: New → In Progress
Changed in unity (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.3.1+15.04.20141128-0ubuntu1

---------------
unity (7.3.1+15.04.20141128-0ubuntu1) vivid; urgency=low

  [ Andrea Azzarone ]
  * Unmap all windows during shutdown. (LP: #1370017, #1375271)
  * Make sure GetScreenGeometry returns the correct value. (LP:
    #1374785)

  [ Marco Trevisan (Treviño) ]
  * Decorated Window: still paint decorations if on transformated
    windows in different workspaces (LP: #1383468)
  * DecoratedWindow: make sure we always set a _NET_FRAME_EXTENTS for
    windows that requested it
  * UnityScreen: when filtering out windows in spread, make sure we
    unscale them (LP: #1316265)
  * PanelMenuView: ensure that proper window tiles and buttons are shown
    at the right place (LP: #1384958, #1384910, #1385285)
  * PanelService: inject special key events back to the root window when
    a menu is opened
  * PanelService: use gdbus to notfy upstart of service start/stop
 -- Ubuntu daily release <email address hidden> Fri, 28 Nov 2014 12:56:28 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in unity:
status: In Progress → Fix Committed
Andrea Azzarone (azzar1) on 2014-12-20
Changed in unity:
milestone: 7.3.2 → 7.3.1
Stephen M. Webb (bregma) wrote :

Attached debdiff between trusty-updates and SRU.

Stephen M. Webb (bregma) on 2014-12-29
description: updated
Chris J Arges (arges) wrote :

Accepted unity into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/7.2.4+14.04.20141217-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed-trusty
tags: added: lockscreen
removed: lock
tags: added: suspend
Adam Colligan (adam-p) wrote :

A form of this regression has now returned with a vengeance; I'm not sure whether to make it into a new bug report or simply to re-open this one, though.

For the past couple of days, resume-from-suspend behavior has frequently been this:

- the lock screen appears at first to have been completely bypassed, and the session appears restored on wakeup

- the cursor is visible on the screen and moves, but the mouse and keyboard cannot actually interact with any objects on the screen

- using ctrl-alt-F(x) to raise a new terminal, then using ctrl-alt-F7 to return to the x session, bringis back the lock screen. Actually logging in to the other session is not necessary, and everything proceeds normally once the lockscreen is brought up.

Changed in gnome-screensaver:
status: New → Invalid

Hi Adam:
I have been using 7.2.4+14.04.20141217-0ubuntu1 for a while now and I'm unable to reproduce the problem you mention in comment #8. However, I'll pay attention and report back if I find any problems!

Also, the updated from -proposed seems to have fixed this bug. The behaviour when suspending/resuming is as smooth as ever for me.

Btw, just in case, I Sandybridge integrated graphics on my laptop.

Hi franglais.125,

If the packages from -proposed resolve this bug then please edit Tags and change verification-needed to verification-done. This is needed to move this version of Unity from -proposed to -main.

Also there are two other bugs that need verification. You can see which ones on this webpage:

http://people.canonical.com/~ubuntu-archive/pending-sru.html

Hi Mateusz,

I was just waiting to see if I got the same problem as Adam at all... So far so good. I just don't want Adam's problem to be propagated. Adam: are you filing a new bug report? Is it ok if I tag it as verification-done?

Also, I saw the other two bugs, but I wasn't initally affected by them. I'll see if I find time later today to have a look.

I made some tests but not on real hardware. I used VirtualBox.

I didn't have any of the problems described in this bug report. I checked with a couple of windowed programs and then with Firefox in fullscreen and the last test was with Evince in fullscreen. When I resumed the only thing that displayed was lockscreen (no view of the desktop or it's past contents).

Adam in his comment didn't specify the version of Unity and I assume he isn't using the version from -proposed.

I've been trying pretty hard to reproduce Adam's problem (comment #8), and this bug in general, when running unity from -proposed.

I tried this with fullscreen Firefox, flash, totem, without a single problem. The only case were the contents were visible when resuming was when having a fullscreen pdf in Firefox (using pdf.js), but the contents were only visible for a split second (maybe 0.1s or something like that).

I'll mark this as verification-done.

tags: added: verification-done-trusty
removed: verification-needed-trusty
Adam Colligan (adam-p) wrote :

I'll file a new bug report when I have a bit of time and put the link in a comment here when it's done.

I've realized now that this new bug as I'm seeing it is actually not contingent on Suspend taking place. If I simply go to menu "Lock", I get a black screen. Moving the mouse or otherwise triggering the unlock screen instead gives an image of the Desktop with no interaction possible except moving the cursor. Going to a different TTY and then back brings up the lock screen.

Adam Colligan (adam-p) wrote :

Okay, new bug filed: bug #1416897 ( https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1416897 ).

That report includes a more in-depth description.

There is also a 1-minute video of the bug in action ( https://launchpadlibrarian.net/196338738/lockscreen_bug_no_audio_20150201.webm ). It gives a synced, side-by-side comparison of what the user sees (cameraphone) versus what the OS thinks is being displayed (SimpleScreenRecorder).

I see, you are actually using 14.10. I'm on 14.04, that's a big difference between our systems.

Good luck with the new bug report! Hopefully it will get fixed soon...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.4+14.04.20141217-0ubuntu1

---------------
unity (7.2.4+14.04.20141217-0ubuntu1) trusty; urgency=medium

  [ Andrea Azzarone ]
  * Share lockscreen password between screens (lp: #1308540)
  * Allow a distinct pam config file for greeter and for lock-screen.
    (lp: #1305440)
  * Add an arrow activator in the lockscreen. (lp: #1332509)
  * Make sure GetScreenGeometry returns the correct value (lp: #1374785).
  * unmapped all windows prior to shutdown (lp: #1370017) (lp: #1375271)

  [ Brandon Schaefer ]
  * fix tooltip for the "Show Desktop / Restore Windows" icon in the Alt-Tab
    switcher (lp: #1237132)
  * Use CONFIG instead of CACHE to store the first_run.stamp (lp: #1328677)

  [ Eleni Maria Stea ]
  * LayoutSystem: make sure the exposed open windows are displayed in the
    preserved order (lp: #1349281).

  [ handsome_feng ]
  * added support for getting the distro name from /etc/os-release
    (lp: #1329584)

  [ Iain Lane ]
  * When grabbing keys, try prefixing "XF86" if the key isn't found. GNOME
    gives us unprefixed keys sometimes (lp: #1302885).

  [ Marco Trevisan (Treviño) ]
  * make the Launcher icon count badge width depend on the text value width
    and scaling (lp: #1353070) (lp: #1354498) (lp: #796527) (lp: #1066971)
    (lp: #1361713)
  * DecoratedWindow: make edges independent from borders and properly update
    them on actions change (lp: #1276177), (lp: #1299741), (lp: #1301776),
    (lp: #1324104), (lp: #1364225), (lp: #1373695)
  * Lockscreen: scale the UI elements based on current monitor scaling
    (lp: #1292218)
  * UnityScreen: when filtering out windows in spread, make sure we unscale
    them (lp: #1316265).
  * PanelMenuView: ensure that proper window tiles and buttons are shown at
    the right place (lp: #1384910) (lp: #1384958) (lp: #1385285)
  * SearchBar, ActionButtons, IconRenderer: include the font scaling when
    scaling textual items (lp: #1332947) (lp: #1361751) (lp: #1362162)
    (lp: #1362346).
  * ApplicationLauncherIcon: make sure we close the dash if DnD is accepted
    and the application window is about to be focused (lp: #1350331).
  * SwitcherView: set progress on icon render args (lp: #1361679).
  * LockScreenController: wait for the primary shield to get the grab
    before setting the session locked (lp: #1368427) (lp: #1371764).
  * added decorations to windows in non-focused workspaces (lp: #1383468)

  [ Stephen M. Webb ]
  * updated the unity(1) manpage to match the actual command (lp: #1059275)
  * bumped package version to match upstream

  [ Marco Trevisan (Treviño) ]
  * Preparing for unity 7.2.4
 -- Ubuntu daily release <email address hidden> Wed, 17 Dec 2014 20:52:10 +0000

Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Stephen M. Webb (bregma) on 2015-02-11
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers