Shortcut overlay cannot be closed by clicking the close button in 14.04

Bug #1313597 reported by Po-Hsu Lin on 2014-04-28
58
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Christopher Townsend
7.2
Fix Committed
Low
Christopher Townsend
unity (Ubuntu)
Low
Christopher Townsend
Nominated for Trusty by Stephen M. Webb
Trusty
Low
Christopher Townsend

Bug Description

[ Impact ]

Due to an input handling race, the first time users log into Unity on their system, the shortcut overlay may not close when clicking the "X" in the corner. This leads to a poor user experience.

[ Test Case ]

1. Remove ~/.config/unity/first_run.stamp.
2. Log into Unity.
3. Shortcut hints overlay should be shown.
4. Click on "X" in the corner.

[ Regression Potential ]

This is a workaround for a race, so some users may never see the race to begin with. That said, no regression should be observed as in worse case, the shortcut hints still cannot be closed.

Debdiff of the SRU is found here: https://bugs.launchpad.net/unity/+bug/886478/+attachment/4401967/+files/unity.7.2.5.debdiff

---------------------------------------------------------------------------

Original Description:

In 14.04, the shortcut overlay would pop-out automatically on first boot.
Although there is a close button on the top-left corner, it cannot be closed by clicking it.

(it could be dismissed by the super key, or open a new window)

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
importance: Undecided → Low
Ro (robert-markula) wrote :

Please reconsider adding a higher priority to this bug. The shortcut overlay is the very first thing users will see on their new ubuntu desktop. Having this broken or not super-polished leaves a very bad first impression ("if not even this works, what can I expect from the rest of the system?").

tags: added: iso-testing
tags: added: trusty ui
Changed in unity:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Christopher Townsend (townsend)
Changed in unity (Ubuntu):
assignee: nobody → Christopher Townsend (townsend)
Changed in unity:
milestone: none → 7.3.0
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Stephen M. Webb (bregma) on 2014-06-20
Changed in unity:
milestone: 7.3.0 → 7.3.1
Travis Larson (tlarson) wrote :

I agree with Ro's comment above. The priority should be raised. This bug is the VERY FIRST thing you see when installing Ubuntu 14.04 LTS.

Stephen M. Webb (bregma) on 2015-02-11
Changed in unity:
milestone: 7.3.1 → 7.3.2
Stephen M. Webb (bregma) on 2015-03-19
Changed in unity:
milestone: 7.3.2 → 7.3.3
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.3.2+15.04.20150324.1-0ubuntu1

---------------
unity (7.3.2+15.04.20150324.1-0ubuntu1) vivid; urgency=medium

  [ Stephen M. Webb ]
  * Upstream release 7.3.2.
  * fix AP test failure due to new parameter added to key grabbing (LP:
    #1433648)
  * silenced GCC 5 warnings (LP: #1430784)
  * uses the new upstream .desktop file for D-Bus activated Nautilus
    instances (LP: #1428837)

  [ Brandon Schaefer ]
  * When we quit the quicklist it would check if the mouse was over the
    launcher, if it wasn't it would fold the launcher. We don't need to
    check this if we are in keynav as we want all the icons to be
    unfolded. (LP: #1246891)

  [ CI Train Bot ]
  * New rebuild forced.

  [ Chris Townsend ]
  * Use a 2 second delay before showing the first run shortcut hints to
    workaround a race condition on input handling. (LP: #1313597)

  [ Marco Trevisan (Treviño) ]
  * GnomeKeyGrabber: add timestamp support to accelerators (LP:
    #1433648)
 -- CI Train Bot <email address hidden> Tue, 24 Mar 2015 16:09:14 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma) on 2015-03-27
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu Trusty):
status: New → In Progress
importance: Undecided → Low
assignee: nobody → Christopher Townsend (townsend)
description: updated
description: updated

Hello Po-Hsu, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity/7.2.5+14.04.20150521.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Stephen M. Webb (bregma) wrote :

I can verify this appears to work in the SRU.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.5+14.04.20150521.1-0ubuntu1

---------------
unity (7.2.5+14.04.20150521.1-0ubuntu1) trusty; urgency=medium

  [ Chris Townsend ]
  * Releasing 7.2.5.
  * Bump version to 7.2.5.
  * Use a 2 second delay before showing the first run shortcut hints to
    workaround a race condition on input handling. (LP: #1313597)

  [ Andrea Azzarone ]
  * Add the possibility to specify the font size and the font weight
    without chaning the default font name. (LP: #886478)
  * Do not restore focus if a quicklist is opened during launcher key
    navigation. (LP: #932486)
  * Draw osk above unity shell. (LP: #1413165)
  * Forward first key event that happens on top of the blank window to
    the lockscreen. (LP: #1308265)
  * Make sure scope_views_[filter.id] exists before using operator[] on
    it. (LP: #926979)
  * Release pointer barrier if launcher is in lock_hide state. (LP:
    #1029114)

  [ Brandon Schaefer ]
  * When we quit the quicklist it would check if the mouse was over the
    launcher, if it wasn't it would fold the launcher. We don't need to
    check this if we are in keynav as we want all the icons to be
    unfolded. (LP: #1246891)

  [ CI Train Bot ]
  * New rebuild forced.

  [ Stephen M. Webb ]
  * AP tests: accounted for arbitrarily-raised exceptions in checking
    scaled windows (LP: #1436095)

 -- CI Train Bot <email address hidden> Thu, 21 May 2015 15:07:15 +0000

Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers