Language issue from the unity lense screen

Bug #1251193 reported by Jung-Kyu Park on 2013-11-14
82
This bug affects 28 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Jinkyu Yi
7.2
Fix Released
Medium
Jinkyu Yi
unity (Ubuntu)
Medium
Jinkyu Yi
Trusty
Undecided
Unassigned

Bug Description

[Impact]
Every characters over U+AA60 will shown as '?' in dash.
It's critical to Korean user because every hangul character(Korean alphabet) is over U+AA60.

[Test Case]
1. Install Ubuntu with Korean language.
2. Open dash.
3. See if dash show application's name as set of '?'.

[Regression Potential]
This fix modifies code added to prevent crashes in the Pango renderer when composing certain Unicode characters in the Burmese code plane. It is likely that the original problem is limited to that code plane, however it is possible that a similar desktop crash could occur with other Unicode code planes in which composite characters are rendered, including Hangul.

----------------------------------------

Form the Unity lens , There are several characters of "????"
There should be displayed name of certain package , files, etc

ProblemType: BugDistroRelease: Ubuntu 14.04
Package: unity 7.1.2+14.04.20131106.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.12.0-2.7-generic 3.12.0
Uname: Linux 3.12.0-2-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.12.6-0ubuntu1
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,staticswitcher,workarounds,scale,expo,ezoom,dbus]
Date: Thu Nov 14 19:38:05 2013
InstallationDate: Installed on 2013-11-13 (0 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha i386 (20131113)
MarkForUpload: TrueSourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jung-Kyu Park (bagjunggyu) wrote :
description: updated
Stephen M. Webb (bregma) wrote :

This is a know problem due to a workaround of a severe bug in the Cairo rendering library (a third-party library used by Unity to render text) in which it crashes when attempting to render certain characters, especially those from the Myanmar plane in Unicode.

A fix in Unity requires the upstream Cairo library be fixed. In the mean time, we deemed it was safer to display '?' rather than have your computer crash.

Adolfo Jayme (fitojb) on 2014-03-08
Changed in unity (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Jung-Kyu Park (bagjunggyu) wrote :

Temporary Cure for this issue )
It is not a small issue for a Korean and It might be for other non-english based distributions , I guess
Until its fixed releasing come out , We are now using this method
It is a kind of rolling back unity to 13.10
user "boramism" deleted issued packages and patched

command:
sudo add-apt-repository ppa:boramism/unity-1404; sudo apt update; sudo apt dist-upgrade

log out & log in

Jung-Kyu Park (bagjunggyu) wrote :

The above method , patch of boramism occur malfunction of sns message search in the Unity
And also It might cause other malfuntion in the Unity
Despite of this issue, we want to meet the KOREAN at the Unity
Include of myself , a lot of users of Korean run this patch now

Jinkyu Yi (jincreator) on 2014-05-03
description: updated
Jinkyu Yi (jincreator) wrote :

Stephen, that sounds weird. Why not try to fix cairo instead of blacklisting characters in dash? Is that bug reported to upstream?

Anyway, hangul is definitely not in burmese area. Wrong sign of inequality in code caused this bug.
https://bazaar.launchpad.net/~unity-team/unity/trunk/view/3791/dash/ResultRendererTile.cpp#L427

Jinkyu Yi (jincreator) wrote :

The code is at lp:~jincreator/unity/lp1251193 and you can easily test by adding ppa:jincreator/unity on trusty.

Jinkyu Yi (jincreator) on 2014-05-03
Changed in unity (Ubuntu):
assignee: nobody → Jinkyu Yi (jincreator)
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity:
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Jinkyu Yi (jincreator)
milestone: none → 7.2.1
Jinkyu Yi (jincreator) wrote :

Thank you for accept my merge proposal, Marco.
When will Unity 7.2.1 released into trusty?

Jung-Kyu Park (bagjunggyu) wrote :

I really appreciate your efforts
Thank you Jinkyu Yi and Marco.

Stephen M. Webb (bregma) on 2014-05-06
description: updated

Thank you Jinkyu Yi(이진규님 고맙습니다!).
It fixes the ugly ??? issue, and give us Korean back.

Stephen M. Webb (bregma) on 2014-05-07
Changed in unity:
milestone: 7.2.1 → 7.3.0
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.0+14.10.20140512.4-0ubuntu1

---------------
unity (7.2.0+14.10.20140512.4-0ubuntu1) utopic; urgency=low

  [ Stephen M. Webb ]
  * lockscreen/LockScreenAccelerators.h: added required header for
    std:vector definition
  * disabled precompiled headers on arm64 Ubuntu package builds (LP:
    #1317276)

  [ Brandon Schaefer ]
  * Set the max width, so our static text wraps. So we don't end up
    rendering text out of the view area. (LP: #1312749)

  [ Marco Trevisan (Treviño) ]
  * UnityScreen: toggle activation of all the unity compiz actions when
    locking the screen Also, make sure that the lockscreen views are
    treated as "always-on-front" windows by nux (and this applies to
    both visibility and events).
  * PanelService: emit an invalid EntryActivated signal if the menu
    hasn't actually been shown In addition, if the menu is not visible
    after the first popup call, try to show a menu without keyboard
    focus. This will make possible to see menus also when there's a key-
    grab (although they will be without keyboard support). Finally,
    reset the menu state, if that failed.
  * UnityScreen: always paint the lockscreen above, just add menu and
    onboard as exceptions Some code cleanup, factorizing similar code.
    (LP: #1313280)
  * UnityScreen: don't try to show Dash/Hud if the screen is grabbed
    Also move the dash opening out from LauncherController, and get rid
    of UBus as first initialization source, as it can only slow things
    down here. (LP: #741869)
  * PluginAdapter: make sure we don't try to call an invalid
    initiate/terminate callback function (LP: #1221673)
  * DebugDBusInterface: match properties if they are in the AP array
    form [<type>, <value>] (LP: #1307748)

  [ William Hua ]
  * Add proper support for modifier-only shortcuts on the lock screen.
    (LP: #1291461)

  [ Jinkyu Yi ]
  * Dash: Fix problem at checking blacklisted unicode range (LP:
    #1251193)

  [ Andrea Azzarone ]
  * Add a warning in the session dialog if other sessions are still
    open. (LP: #1281058)
 -- Ubuntu daily release <email address hidden> Mon, 12 May 2014 22:03:27 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released

Hello 박정규(Jung-Kyu, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/7.2.1+14.04.20140513-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

Hello 박정규(Jung-Kyu, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/7.2.1+14.04.20140513-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Jung-Kyu Park (bagjunggyu) wrote :

Thank you Chris , Brian
I have tested it now , but unfortunately, it failed to upgrade due to dependency problem
please see the screenshot

I checked it up through

sudo aptitude -t trusty-proposed

and found one unsatisfied dependency package : libunity-core-6.0-9 ( =7.2.1+14.04.20140513-0ubuntu1)

please check it up and let me know what I should do
best regards for helping to solve this issue
Thank you friends

I tried this, “unity” 7.2.1+14.04.20140513-0ubuntu1 on Proposed repository, and it works good. The ??? problem has gone.
There was no dependency issue for me, as Jung-Kyu Park wrote.

Ubuntu 14.04, 32bit. No ppa has been added other than google chrome's.

Thanks!

Jung-Kyu Park (bagjunggyu) wrote :

Thank you for test JH Park

Here is the way to test I have been through
I followed the guide line of
https://wiki.ubuntu.com/Testing/EnableProposed

* enabling the "trusty-proposed" at the software & update
* sudo gedit /etc/apt/preferences

Package: *
Pin: release a=trusty-proposed
Pin-Priority: 400

* sudo apt-get update;sudo apt-get upgrade -s
* sudo aptitude -t trusty-proposed

of course , I have failed to upgrade by both of them due to dependency
sudo apt-get update; sudo apt-get upgrade
and
sudo apt-get update;sudo apt-get dist-upgrade

please leave me a comment, If I did wrong process

Changed in unity:
status: In Progress → Fix Committed

@bagjunggyu

Enable trusty-proposed as you did.
Do 'sudo apt-get update'
Then just do 'sudo apt-get install unity'.

That should pull in the libunity-core package that is needed.

Thanks for trying to test this!

Jung-Kyu Park (bagjunggyu) wrote :

Thank you for comment Christopher
I have treid that already too, but , also failed to install it
I have tested for doing it by these after adding trusty-proposed repository

first , I tried
* sudo apt-get update; sudo apt-get upgrade -s
for checkinng upgrade , but there was no upgradable message from the terminal

so that I tried directly to upgrade to the system

* sudo apt-get update
* sudo apt-get install unity
* sudo apt-get install unity-services
* sudo apt-get upgrade
* sudo apt-get dist-upgrade

but, it said "unity is alreadya newiest package version" , "unity-services is already a newiest package version"
Thus, After that I tried to firgure out clearly by

* sudo aptitude -t trusty-proposed

and, I found one unsatisfied dependency package : libunity-core-6.0-9 ( =7.2.1+14.04.20140513-0ubuntu1)
from the terminal

I will re-install the ubuntu 14.04 for testing at the fresh install
and, I will check it again
Thank you for helping to make it clear
Thank you all

Jung-Kyu Park (bagjunggyu) wrote :

I forgot the screenshot for #19
Here it is

It sounds like libunity-core-6.0-9 did not get updated for some reason.

Could you give the output of the following:
apt-cache policy unity
apt-cache policy libunity-core-6.0-9

With trusty-proposed enabled, what happens if you type:
sudo apt-get install libunity-core-6.0-9

Jung-Kyu Park (bagjunggyu) wrote :

Oh~I already re-install the Ubuntu 14.04
I am sorry for can't help you for checking up libunity-core-6.0-9, Christopher.

By the way, For this "????" issue of related to Unity
The packages delivered from trusty-proposed repository worked perfect!
please see the screenshot

* software & update -> update -> trusty-proposed
* sudo apt-get update; sudo apt-get upgrade -s
* sudo apt-get upgrade

Thank you for all of you helping to solve this issue
Thank you

tags: added: verification-done
removed: verification-needed

Ok, no worries. Glad you got it working and thanks for testing this!

Sebastien Bacher (seb128) wrote :

(unsubscribing sponsors, it seems the change got uploaded/commited to unity, nothing else left to do there)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.1+14.04.20140513-0ubuntu2

---------------
unity (7.2.1+14.04.20140513-0ubuntu2) trusty; urgency=medium

  [ Brandon Schaefer ]
  * Set the max width, so our static text wraps. So we don't end up
    rendering text out of the view area. (LP: #1312749)

  [ Jnkyu Yi ]
  * fixed range of blacklisted Unicode characters (lp: #1251193)

  [ Marco Trevisan (Treviño) ]
  * UnityScreen: toggle activation of all the unity compiz actions when
    locking the screen Also, make sure that the lockscreen views are
    treated as "always-on-front" windows by nux (and this applies to
    both visibility and events).
  * PanelService: emit an invalid EntryActivated signal if the menu
    hasn't actually been shown In addition, if the menu is not visible
    after the first popup call, try to show a menu without keyboard
    focus. This will make possible to see menus also when there's a key-
    grab (although they will be without keyboard support). Finally,
    reset the menu state, if that failed.
  * PluginAdapter: make sure we don't try to call an invalid
    initiate/terminate callback function (LP: #1221673)
  * DebugDBusInterface: match properties if they are in the AP array
    form [<type>, <value>] (LP: #1307748)

  [ Stephen M. Webb ]
  * lockscreen/LockScreenAccelerators.h: added required header for
    std:vector definition (fixes FTBFS in Ubuntu)
  * disabled precompiled headers on arm64 Ubuntu package builds
    (lp: #1317276)
  * bump upstream release to 7.2.1

  [ William Hua ]
  * added proper support for modifier-only shortcuts on the lock screen
    (lp: #1291461)
 -- Ubuntu daily release <email address hidden> Tue, 13 May 2014 20:46:01 +0000

Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Stephen M. Webb (bregma) on 2014-06-20
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.