Unity not starting after boot

Bug #1212987 reported by WoodyEckelzone on 2013-08-16
This bug affects 7 people
Affects Status Importance Assigned to Milestone
unity (Ubuntu)

Bug Description

After boot today. Unity was missing. Empty desktop.
In ccsm is seems the unity plugin was disabled somehow, I re-enabled it.
Unity came back but coudn't set launcher icon size in settings -> appearance -> look.

I tried: (http://askubuntu.com/questions/17381/unity-doesnt-load-no-launcher-no-dash-appears/)
dconf reset -f /org/compiz/
unity --reset-icons &disown

Unity did reset

Still can set icon size in settings -> appearance -> look.
Have to use Unity Tweak Tool for that to set icon size on 32.
Then started Chromium and Unity crashed again.

Restart and still can't set icon size or launcher to autohide.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: unity 7.0.0daily13.06.19~13.04-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-27.40-generic
Uname: Linux 3.8.0-27-generic x86_64
ApportVersion: 2.9.2-0ubuntu8.3
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
Date: Fri Aug 16 10:24:51 2013
InstallationDate: Installed on 2013-04-26 (111 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MarkForUpload: True
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

WoodyEckelzone (bcr497) wrote :
WoodyEckelzone (bcr497) wrote :

Also workspaces stopped working.
Enabled disabled enable. They don show up

WoodyEckelzone (bcr497) wrote :

Happened again. After reseting everything, after a while crash and reboot.
Can set icon size in CCSM unity plugin,

Can NOT set icon size in:
settings -> appearance -> look
Unity tweak toel

Furthermore enabling PUT plugin, ( to enable essential shortcuts to move windows between monitors), unity crashes.

All problems started today, worked fine earlier

WoodyEckelzone (bcr497) wrote :

I can also set workspaces in CCSM General options
Unity Tweak tool or Settings-> appearance doesn't work any more for workspace or icon size settings.

Teo (teo1978) wrote :

I have the same issue (Unity disappeared after a reboot without a reason) but I can't work around it in any way.
None of the workarounds mentioned in this report work for me.
I still have no Unity launcher nor system bar, and hence my system is completely unusable.

For god's sake how can this be getting so little attention? This is HUGE.

Changed in unity (Ubuntu):
status: New → Confirmed
WoodyEckelzone (bcr497) wrote :

FYI I had this problem twice or three times, I had to make the settings with CompizConfig Settings Manager like described.
sudo apt-get install cssm

That solved all in the end.
After that I have not experienced this problem again. (Maybe caused by a powerfailuere back then?!)

Jack Senechal (jacksenechal) wrote :

This seems like two bugs:
1) Unity plugin mysteriously disabled, have to re-enable via ccsm
2) Launcher icon size can't be adjusted

I just experienced #1. The only thing I changed on the system between working and broken login sessions was to install gparted (0.16.1-1), which also installed libgtkmm-2.4-1c2a (>= 1:2.24.0)

I also found this in the syslog:

    Feb 7 12:32:05 Arcturus gnome-session[1803]: WARNING: Child process 2057 was already dead.
    Feb 7 12:32:05 Arcturus gnome-session[1803]: WARNING: Application 'compiz.desktop' killed by signal 9
    Feb 7 12:32:05 Arcturus gnome-session[1803]: WARNING: App 'compiz.desktop' respawning too quickly
    Feb 7 12:32:05 Arcturus gnome-session[1803]: CRITICAL: We failed, but the fail whale is dead. Sorry....

Kind of trouble-shooting in the dark here, but that's the best I've got. Beyond that I don't know what could have caused it.

no longer affects: unity
Changed in unity:
status: New → Confirmed
Ross Gayler (r-gayler) wrote :

I have the same problem. (Ubuntu 14.04 32-bit) I installed the most recent batch of updates (including one for compiz) and after the next reboot my system is effectively dead. After login I get wallpaper only. Ctrl-Alt-T doesn't get a terminal. Ctrl-Alt-F1 works OK.

I installed ccsm. The unity plugin was disabled. I enabled it, but I still don't have a GUI after a reboot (even though the unity plugin is still enabled)

Michael (discombobul8d) wrote :

I am having the same issue myself after doing a fresh install of 14.04 64-bit. I have tried most (but admittedly not all, as I am new to Ubuntu) of the fixes listed in http://askubuntu.com/questions/17381/unity-doesnt-load-no-launcher-no-dash-appears/ to no avail. As Ross stated above, after login I get wallpaper only, Ctrl-Alt-T doesn't get a terminal, but Ctrl-Alt-F1 works OK. I would only add that sometimes Ctrl-Alt-F1 does not work if it is not done fast enough. (After a bit, the whole thing locks up so bad that the keyboard and mouse no longer work.)

Henrique Goulart (jhgoulart) wrote :

This same problem suddenly appeared in my Ubuntu 14.04 LTS installation today. After login, there is no launcher, no dash, and the system shortcuts do not work. Unity itself does not work.

I have tried a bunch of different procedures that I found on forums, like those of http://askubuntu.com/questions/17381/unity-doesnt-load-no-launcher-no-dash-appears/286349#286349, but I couldn't make my system work again.

After having run out of possible fixes, I don't know which else to try.,

same problem here but on non-administrative accounts. also, when trying to initate guest session i get this on dmesg:

  315.630744] type=1400 audit(1418974500.180:73): apparmor="DENIED" operation="mount" info="failed mntpnt match" error=-13 profile="/usr/lib/lightdm/lightdm-guest-session" name="/proc/" pid=3486 comm="init" fstype="proc" srcname="proc" flags="rw"
[ 315.630773] type=1400 audit(1418974500.180:74): apparmor="DENIED" operation="mount" info="failed mntpnt match" error=-13 profile="/usr/lib/lightdm/lightdm-guest-session" name="/sys/" pid=3486 comm="init" fstype="sysfs" srcname="sysfs" flags="rw"
[ 315.668415] type=1400 audit(1418974500.216:75): apparmor="DENIED" operation="open" profile="/usr/lib/lightdm/lightdm-guest-session" name="/proc/3567/cmdline" pid=3555 comm="dbus-daemon" requested_mask="r" denied_mask="r" fsuid=120 ouid=0
[ 315.677254] type=1400 audit(1418974500.224:76): apparmor="DENIED" operation="open" profile="/usr/lib/lightdm/lightdm-guest-session" name="/proc/3573/cmdline" pid=3555 comm="dbus-daemon" requested_mask="r" denied_mask="r" fsuid=120 ouid=0
[ 315.738306] type=1400 audit(1418974500.288:77): apparmor="DENIED" operation="mount" info="failed mntpnt match" error=-13 profile="/usr/lib/lightdm/lightdm-guest-session" name="/run/user/120/gvfs/" pid=3623 comm="gvfsd-fuse" fstype="fuse.gvfsd-fuse" srcname="gvfsd-fuse" flags="rw, nosuid, nodev"
[ 319.666018] type=1400 audit(1418974504.208:78): apparmor="DENIED" operation="open" profile="/usr/lib/lightdm/lightdm-guest-session" name="/proc/1/cgroup" pid=3745 comm="gnome-session" requested_mask="r" denied_mask="r" fsuid=120 ouid=0
[ 320.027235] type=1400 audit(1418974504.572:79): apparmor="DENIED" operation="open" profile="/usr/lib/lightdm/lightdm-guest-session" name="/proc/1/cgroup" pid=3741 comm="gnome-settings-" requested_mask="r" denied_mask="r" fsuid=120 ouid=0

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers