Volume scrolling inconsistent

Bug #1091142 reported by Jeroen Marinus on 2012-12-17
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
The Sound Menu
Fix Released
Low
Marcus Tomlinson
Unity
Invalid
Low
Unassigned
indicator-sound (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

When adjusting the volume with the scroll wheel there are two scenario's which are inconsistent with eachother:

Scenario 1:
1. Click on the speaker icon in the top right corner
2. Keep hovering over the speaker icon
3. Scroll to adjust the volume. The volume is adjusted in small steps.

Sceanrio 2:
1. Click on the speaker icon in the top right corner
2. Move the cursor down and hover over the volume slider.
3. Scroll to adjust the volume. The volume is adjusted in large steps.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.14.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-29.46-generic 3.2.24
Uname: Linux 3.2.0-29-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.0.1-0ubuntu15
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
Date: Mon Dec 17 10:41:09 2012
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
MarkForUpload: True
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jeroen Marinus (marinus-jeroen) wrote :
Adolfo Jayme (fitojb) on 2012-12-18
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Omer Akram (om26er) wrote :

I like the behavior of the slider in scenario #1, looks smooth. I think we should track this bug for the slider to inhibit the same behavior when the mouse is over it and scrolled.

Changed in indicator-sound:
importance: Undecided → Low
Changed in unity:
importance: Undecided → Low
Changed in indicator-sound:
status: New → Triaged
status: Triaged → Confirmed
Changed in unity:
status: New → Confirmed
Changed in indicator-sound:
assignee: nobody → Marcus Tomlinson (marcustomlinson)
status: Confirmed → In Progress

I think we should not only match the scroll rates of these two scenarios, but drop the volume scroll rate as well (see https://bugs.launchpad.net/indicator-sound/+bug/1226931).

Jeroen Marinus (marinus-jeroen) wrote :

I agree.

Clearly according to Omer in commet #2 and the above referenced issue, finer grained control is desired.

Stephen M. Webb (bregma) on 2013-10-15
Changed in unity:
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Triaged → Invalid
Charles Kerr (charlesk) wrote :

https://wiki.ubuntu.com/Sound#Sound_menu discusses the behavior for scrolling on the volume menuitem and scrolling on the title:

> Whenever the volume item is highlighted:
>
> The Left and Right arrow keys should instantly decrease or
> increase the volume, respectively, to the nearest 5 percent step.
>
> The “-” and “+” keys should instantly decrease or increase the volume,
> respectively, to the nearest 5 percent step.
>
> Rolling a mousewheel up or down should increase or decrease the
> volume respectively, 10% per click.

and

> As a hidden treasure, when the pointer is over the title, whether
> the menu is open or not, clicking a mousewheel up or down should
> increase or decrease the volume respectively, to the nearest
> 10-percent step.

By my count, the volume menuitem seems to be correctly following the spec, requiring 10 mouse nudges to go from 0% to 100% volume.

The title takes something like 16-17 nudges, so the IMO the right way to make scrolling consistent between the two is to make title scrolling follow the spec.

There is a second bug here that intersects with bug #1226931: the left/right and -/+ keys don't follow the spec at all, so there's currently no simple way to walk the volume in smaller steps.

Ok fair enough, to satisfy a fix for this particular bug, I've increased the sensitivity of the scroll wheel's influence on volume when the mouse is over the panel icon to match that of the volume slider (and hence, the spec).

Changed in indicator-sound:
status: In Progress → Fix Committed
Changed in indicator-sound:
status: Fix Committed → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:indicator-sound/13.10 at revision 393, scheduled for release in indicator-sound, milestone 0.5.6

Changed in indicator-sound:
status: In Progress → Fix Committed
Changed in indicator-sound (Ubuntu):
status: New → Fix Committed
Lars Karlitski (larsu) on 2014-04-11
Changed in indicator-sound (Ubuntu):
status: Fix Committed → Fix Released
Changed in indicator-sound:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers