Scroll-Wheel-Adjust Volume is Too Coarse-grained

Bug #1226931 reported by Lonnie Lee Best on 2013-09-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
The Sound Menu
Fix Released
Undecided
Marcus Tomlinson

Bug Description

As you know Ubuntu Unity's Volume indicator allows you to adjust volume by scrolling the mouse-wheel (while the mouse-pointer is hovering over the sound indicator).

I realize that mouse-scroll-wheels have different degrees of precision, but for me if I move my scroll-wheel one notch it adjusts the volume by too large a unit of volume.

I would like this method of volume adjustment to be more fine-tune, so that my mouse-wheels adjustments can cover a more complete spectrum of volumes. As is, I often find that one scroll-wheel-up produces a volume that is too loud, while one scroll-wheel-down is too quite. Ultimately, I'm forced to click the indicator and move the volume-slider to achieve the desired volume that is in-between the course-grained adjustments provided by scroll-wheel-volume-adjustments.

Related branches

tags: added: precise saucy
description: updated

I agree, the scroll wheel does adjust the volume slider too quickly. Running Ubuntu under Parallels VM in Mac OS X I could compare the scroll rates of the Mac volume slider against the slider in Ubuntu. I found the Mac slider to move about 5 times slower relative to the scroll wheel than the Ubuntu one.

Changed in indicator-sound:
status: New → Confirmed
assignee: nobody → Marcus Tomlinson (marcustomlinson)
status: Confirmed → In Progress
Charles Kerr (charlesk) wrote :

The volume menuitem's scroll is following the spec at https://wiki.ubuntu.com/Sound#Sound_menu:

> Whenever the volume item is highlighted:
>
> The Left and Right arrow keys should instantly decrease or
> increase the volume, respectively, to the nearest 5 percent step.
>
> The “-” and “+” keys should instantly decrease or increase the volume,
> respectively, to the nearest 5 percent step.
>
> Rolling a mousewheel up or down should increase or decrease the
> volume respectively, 10% per click.

So (IMO) the problem isn't the scroll behavior, but rather that left/right and -/+ keys don't follow the spec, so there's not a good way to step the volume up & down in the smaller grain. We could handle this in IDO by giving idoscalemenuitem key-press-event and key-release-event handlers as is done in the sibling idoplaybackmenuitem

I am unassigning myself from this bug as my hopeful "kill 2 birds with 1 stone" fix is no longer relevant to the problem here (the issue has shifted from mouse scroll to key-presses)

Changed in indicator-sound:
assignee: Marcus Tomlinson (marcustomlinson) → nobody
status: In Progress → Confirmed
Lars Karlitski (larsu) wrote :

Charles, I fixed the left/right key handling as part of bug #1242550.

The spec still says to change the volume by 10% when scrolling.

Changed in indicator-sound:
assignee: nobody → Matthew Paul Thomas (mpt)

Although this obvious, I thought I'd explicitly state the fact that even specifications are subject to change upon proper proposal. And, bug reports sometimes lead to changes in specifications when they are seen as a legitimate correction or enhancement.

Lars Karlitski (larsu) wrote :

Of course. I assigned this bug to Matthew in hope he'll change the spec (he's the author).

Changed in indicator-sound:
status: Confirmed → In Progress
assignee: Matthew Paul Thomas (mpt) → Marcus Tomlinson (marcustomlinson)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:indicator-sound/13.10 at revision 393, scheduled for release in indicator-sound, milestone 0.5.6

Changed in indicator-sound:
status: In Progress → Fix Committed
Adolfo Jayme (fitojb) on 2014-03-13
Changed in indicator-sound:
status: Fix Committed → Fix Released

This may have improved some, but it is still not as fine-grained as I would like it to be.

tags: added: trusty utopic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers