Unity HUD uses wrong icon when switching from the Dash to HUD

Bug #1089482 reported by Łukasz Zemczak on 2012-12-12
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Łukasz Zemczak
unity (Ubuntu)
Low
Łukasz Zemczak

Bug Description

Bug when using lp:unity and lp:bamf.

As indicated by a failure in the Unity autopilot test: test_hud.HudVisualTests.test_dash_hud_only_uses_icon_from_current_desktop, unity fetches the wrong application icon when switching from the Dash to the HUD.

[Test Case]
1. Move to an empty desktop/workspace
2. Open the Dash (tapping Super)
3. Open the HUD (tapping Alt)

Expected: the HUD icon shows the BFB desktop icon

Actual: the HUD icon shows '?' icon, which is invalid

Versions: unity - 6.12.0daily12.12.05bzr2974pkg0quantal0, bamf - 0.4.0daily12.12.05bzr507pkg0quantal0.

Related branches

Francis Ginther (fginther) wrote :

Reproduced on raring using ppa:unity-team/staging.

MC Return (mc-return) on 2013-01-04
Changed in unity:
status: New → Confirmed
status: Confirmed → New
Changed in unity:
assignee: nobody → Łukasz Zemczak (sil2100)
importance: Undecided → Low
status: New → In Progress
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: New → Fix Committed
importance: Undecided → Low
assignee: nobody → Łukasz Zemczak (sil2100)
Changed in unity:
milestone: none → 7.0.0
Launchpad Janitor (janitor) wrote :
Download full text (3.4 KiB)

This bug was fixed in the package unity - 6.12.0daily13.01.11.2-0ubuntu1

---------------
unity (6.12.0daily13.01.11.2-0ubuntu1) raring; urgency=low

  [ Didier Roche ]
  * debian/control:
    - bump some missed build-deps
    - bump compiz and nux build-deps for the API and ABI breakages
      (LP: #1095981)
  * debian/rules:
    - disable pch for now as it's not working with -g -02 (LP: #1095978)

  [ Brandon Schaefer ]
  * Ported Compiz to 0.9.9
  * debian/control:
    - bump the build-deps
  * Dash and HUD do not have X event focus, causing XIM to not work.
    (LP: #1086988)
  * Windows losing focus after the start/restart of Unity (LP: #1097368)

  [ Łukasz 'sil2100' Zemczak ]
  * Dash - Update Dash nav bar icons (LP: #1089373)
  * Autopilot tests failing in the test_hud suite due to locale
    dependency (LP: #1076531)
  * Super key not registered if held too long (LP: #1097189)
  * Unity HUD uses wrong icon when switching from the Dash to HUD (LP:
    #1089482)

  [ Marco Trevisan (Treviño) ]
  * Using bleeding edge Mesa drivers causes GL_INVALID_OPERATION error
    in glDrawBuffer / glReadBuffer (LP: #1092550)
  * [Regression] Window buttons / Title doesn't redraw correctly on
    windows with no menus (LP: #1090439)

  [ Nick Dedekind ]
  * Dash - When the Dash preview is open, the ghost images should run
    all the way to the top of the screen as shown in the design (LP:
    #1060948)
  * Dash - When the Dash preview opens, the category headers should be
    expanded and the filters should hide (LP: #1060937)
  * Dash - In the Dash preview, when a user moves to the next or
    previous preview the highlighted ghost image should change (LP:
    #1060941)
  * Dash - As soon as a user starts dragging a .png file from the Dash,
    the file icon changes size (LP: #863412)

  [ Gord Allott <email address hidden>, Łukasz 'sil2100' Zemczak <email address hidden>, Didier Roche ]
  * "unitydashlegalseen" Causing back-up error (LP: #1066646)
  * unity dash should show legal disclaimer (LP: #1065652)

  [ Manuel de la Pena ]
  * StaticCairoText makes NUX get into an infinte loop (LP: #1071327)

  [ Daniel van Vugt ]
  * Minimized windows don't restore, or restore as blank (LP: #1089779)

  [ Andrea Azzarone ]
  * TestOverlayScrollBar.TestScrollDownSignal segfaults (LP: #1089888)
  * Dash - Update Dash Launcher icon tooltip to say "Search your
    computer and online sources" (LP: #1090325)
  * TestLauncherController.GetLastIconPriorityUnStickyWithNoIconsAndUri
    segfaults (LP: #1089894)
  * TestDashController.TestShowAndHideDash fails (LP: #1089904)
  * [Regression] Tapping super key shows shortcuts overlay. (LP:
    #1090388)
  * [Regression] Unity fails to restore initially minimized windows.
    (LP: #1097686)
  * launcher does not show minimized update manager while clicked (LP:
    #1003950)
  * Dash - Update Dash Home search box hint message to say "Search your
    computer and online sources" (LP: #1090327)
  * can't quit a minimized application (LP: #1086366)
  * Unity daily-build (07.01.13) empty space between launcher and dash
    in non default launcher size (LP: #1097184)

  [ Sam Spilsbury ]
  * Fonts get chang...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.0.0 "R series".

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers